LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 9 & Wireless configuration (http://www.linuxquestions.org/questions/slackware-14/slackware-9-and-wireless-configuration-82963/)

hecresper 08-17-2003 10:22 PM

Slackware 9 & Wireless configuration
 
Hello,

I've gone thru all the threads I found from a search results, but none address my situtation. That's why I'm starting this thread.

My Configuration:
OS: Slackware 9 Kernel 2.4.20
Laptop: Dell Latitude CPx H500
WiFi Card: Linksys WPC51AB
WiFi Drivers: MADWIFI Project

Before I got the wireless card, my Xircom Ethernet card was recognized without a problem. DHCP would find and assign an IP address to the Xircom just fine. I got the madwifi drivers and installed them and upon rebooting, I noticed the wonderful boot messages recognizing my wireless card. Awesome! Now I'm trying to get my wireless card to be setup by DHCP just like the Xircom used to. Slackware is obsessed with using either eth0 or eth1. The WiFi card is being found as ath0. The Slackware book does not go into details about how to manually configure a new network card or what files to edit and how to exactly edit those files. I was thinking that if I symlink ath0 to eth0(or whatever the symlink order is), that I would be able to fool Slackware into configuring my wireless card. Can I just use the symlink idea? I'm writing this from my desktop box so I'll have to go to my laptop and write down some details as to what I'm doing to try to get it working.

carboncopy 08-18-2003 03:03 AM

I don't have wireless card. But I would guess editing /etc/rc.d/rc.inet1 would help.
In rc.inet1 it is writen for eth0 and eth1.
<snip>
/sbin/dhcpcd -t 10 ${DHCP_HOSTNAME2} -d eth1
<snip>
enable #USE_DHCP2=yes
by decommenting it (delete #) and then edit the code above by replacing eth1 with ath0

I am not sure whether you need to edit anything else. You got to go through the script line by line.

Hope this helps. Cheers.

carboncopy 08-18-2003 03:08 AM

Oh yuh one more thing.

You have to either reboot your system
OR
bring it to run level 1 and then to run level 3 again
init 1
init 3 (if u don't want to reboot)

OR
just execute the rc.inet1 by
sh /etc/rc.d/rc.inet1

after you edit it.

I recommend the last option. :)

hecresper 08-18-2003 11:05 PM

Ok, I've decided that rc.local is my best friend. ;)

I placed the following commands in /etc/rc.d/rc.local:

ifconfig ath0 up
dhcpcd ath0

I guess I was being a little impatient when using dhcpcd before.

Thanks for your help, though.

sclebo05 03-27-2004 12:37 PM

i have had success with my wifi/laptop combination, but why do i have to do a 'ifconfig eth0 down' to actually connect to wireless. as long as eth0 is up, i can't do wifi. if i take it down, i am on instantly. it seems that when i ping/do anything internet related, the system is using my eth0 connection instead of my ath0. why does this happen?


All times are GMT -5. The time now is 01:28 AM.