Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 01-12-2004, 02:21 AM   #1
Registered: Jul 2003
Location: columbia
Distribution: Linux+XP
Posts: 40

Rep: Reputation: 15
Unhappy slackware 9.1 sound problems

I updated kernel-ide and kernel-modules and now i am not getting the sound. (also updated the alsa-packages provided by slackware) i am getting the following error:

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.

any ideas how to fix it.

(i can see /dev/dsp is linked to /dev/dsp0 and both of them have enough permissions).

thanks in advance
Old 01-12-2004, 02:57 AM   #2
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
What about your modules? Check "lsmod".

You may like to look for some information about your sound card in
(choose the manufacturer of your card, and read the documentation.)

Old 01-12-2004, 04:10 AM   #3
Senior Member
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
Are you sure your sound modules are installed?
Recompiling the kernel wipes out the sound modules.
Please try reinstalling the alsa-driver package.
Old 01-12-2004, 03:32 PM   #4
Registered: Jul 2003
Location: columbia
Distribution: Linux+XP
Posts: 40

Original Poster
Rep: Reputation: 15
i will try (recompiling kernel/reinstalling alsa) soon and will let you know guys.

thanks for your help.

Old 01-12-2004, 03:36 PM   #5
Registered: Mar 2002
Location: Asheville, NC
Distribution: Ubuntu
Posts: 257

Rep: Reputation: 30
Did you run alsaconf? It will detect your sound card. You then run alsamixer to set your volumes. You then run alsactl store to store your settings. Let us know if this doesn't work.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
sound problems slackware 10.1 canislupine Slackware 13 12-13-2005 02:21 PM
Slackware sound problems. tankertuff Slackware 12 09-19-2005 09:46 AM
Sound Problems on Slackware crackm0nk3y Linux - Hardware 2 12-11-2003 02:19 AM
Slackware 8.1 Via Sound Problems GinoCod Linux - Hardware 5 11-07-2002 07:26 PM
slackware sound problems cerberus Linux - General 32 04-14-2002 06:23 AM

All times are GMT -5. The time now is 11:29 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration