LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware 9.0 install promble with hotplug (http://www.linuxquestions.org/questions/slackware-14/slackware-9-0-install-promble-with-hotplug-77508/)

dickmitnick 07-30-2003 11:32 PM

slackware 9.0 install promble with hotplug
 
I have a box with slcakware 9.0 installed.But there is a promble with me.
If I say "yes" for the hotplug active option when install,the system will be booted and detect pci cards with some error message,eg."insmod 810.ng.gz failed" or "insmod 8139too.o failed "(or something like that.sorry,I colundn't more when booting).The system will load all kinds of modules,but computer will reboot in one or two minutes.
If I say "no" for the hotplug active option when install,the system can be booted narmol without detecting pci cards or error message,the computer won't reboot ,but I cann't use my sound car or video card ,etc..I found the system loads only tow modules.
What can I do with this promble?
Thanks!

dickmitnick 07-31-2003 12:53 AM

Re: slackware 9.0 install promble with hotplug
 
This is my error message:
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz: insmod /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz failed
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz: insmod i810_rng failed
i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810-tco.o.gz: init_module: No such device
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810-tco.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810-tco.o.gz: insmod /lib/modules/2.4.20/kernel/drivers/char/i810-tco.o.gz failed
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810-tco.o.gz: insmod i810-tco failed
i810_rng: RNG not detected
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz: init_module: No such device
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz: insmod /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz failed
insmod: /lib/modules/2.4.20/kernel/drivers/char/i810_rng.o.gz: insmod i810_rng failed

synaptical 07-31-2003 01:15 AM

Re: Re: slackware 9.0 install promble with hotplug
 
i was getting messages similar to that, and what i did was add the module name to the bottom of the /etc/hotplug/blacklist file.

for example, using your messages, i would experiment by adding one or more of the following:

i810-tco
i810-tco.o
i810_rng
i810_rng.o
i810

etc. to see which one/s turned off the errors. you might have to experiment a little to see what format is needed (i.e., with the .o, without the .o, etc.). that worked for me, but i didn't have the reboot problem you mentioned having. still, i think it's worthwhile to blacklist the ones you are getting errors about, and then go from there.

Anibal 07-31-2003 02:21 AM

Re: Re: Re: slackware 9.0 install promble with hotplug
 
Quote:

Originally posted by synaptical
i was getting messages similar to that, and what i did was add the module name to the bottom of the /etc/hotplug/blacklist file.

for example, using your messages, i would experiment by adding one or more of the following:

i810-tco
i810_rng


You are right this is the solution.. sometimes you need to reboot twice cause after the first reboot sometimes your still get errors.. just try a second reboot.. they will be gone..

dickmitnick 07-31-2003 11:21 PM

Re: Re: Re: Re: slackware 9.0 install promble with hotplug
 
Thanks!
I have done so.The error messages disappeared,but the computer still auto reboot.
I find the hotplug actully work though simulating pci cards hotplug to detect and load proper modulers when boot(see /etc/rc.d/rc.hotplug).So I do as follow
boot and login, lsmod >/root/tmp.txt
boot from slackware and mount /dev/hxx /mnt
mv /mnt/etc/rc.d/rc.hotplug /mnt/etc/rc.d/bakrc.hotplug
mv /mnt/etc/rc.d/rc.modules /mnt/etc/rc.d/bakrc.modules
edit /mnt/etc/rc.d/rc.modules to activate proper modules in the /mnt/root/tmp.txt
Now I can enjoy myself.

Zappa 08-02-2003 11:59 AM

The same issue is addressed in this thread.

I think they found the reason...

/Zappa


All times are GMT -5. The time now is 01:23 PM.