LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-04-2013, 09:14 AM   #16
goarilla
LQ Newbie
 
Registered: Sep 2005
Location: Belgium
Distribution: slackware 10
Posts: 8

Rep: Reputation: 2

I can confirm this happens with VirtualBox 4.3.2 as well. But the intel_pstate=disable workaround does work !
 
Old 11-04-2013, 05:16 PM   #17
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 134

Rep: Reputation: 20
Quote:
Originally Posted by goarilla View Post
I can confirm this happens with VirtualBox 4.3.2 as well. But the intel_pstate=disable workaround does work !
ditto, issue in 4.3.0 and 4.3.2 here with same workaround.
 
Old 11-05-2013, 01:13 PM   #18
slack-uke
LQ Newbie
 
Registered: Nov 2013
Location: Toronto, Ontario, Canada
Distribution: Slackware 14.0 64-bit
Posts: 4

Rep: Reputation: Disabled
I just tried installing slackware64-current-install-dvd.iso (03-Nov-2013 20:19 RC3) version on XenServer 6.2.0 -- it installed with no issues and/or modifications.
 
Old 11-08-2013, 02:16 PM   #19
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Rep: Reputation: 210Reputation: 210Reputation: 210
Can't seem to get it with work around...

I passed huge.s root=/dev/sda1 rdinit=ro intel_pstate=disable , still panics
 
Old 11-08-2013, 05:09 PM   #20
Gerardo Zamudio
Member
 
Registered: Jan 2011
Distribution: Slackware
Posts: 30

Rep: Reputation: 10
Quote:
Originally Posted by Jeebizz View Post
Can't seem to get it with work around...

I passed huge.s root=/dev/sda1 rdinit=ro intel_pstate=disable , still panics
Try just huge.s intel_pstate=disable. If it's a new install on VirtualBox you don't have any partitions on the virtual disk yet so root=/dev/sda1 wouldn't work
 
1 members found this post helpful.
Old 11-08-2013, 06:35 PM   #21
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by Gerardo Zamudio View Post
Try just huge.s intel_pstate=disable. If it's a new install on VirtualBox you don't have any partitions on the virtual disk yet so root=/dev/sda1 wouldn't work
That did it, thank you!
 
Old 11-08-2013, 06:51 PM   #22
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Rep: Reputation: 210Reputation: 210Reputation: 210
Hmm, well I was able to boot , tried to trick virtualbox - I went and added the following to lilo.conf

Code:
# Append any additional kernel parameters:
append=" vt.default_utf8=0,intel_pstate=disable'
Ran /sbin/lilo afterwards , no errors and rebooted, still panics, lol
 
Old 11-08-2013, 08:30 PM   #23
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
Quote:
Originally Posted by Jeebizz View Post
Hmm, well I was able to boot , tried to trick virtualbox - I went and added the following to lilo.conf

Code:
# Append any additional kernel parameters:
append=" vt.default_utf8=0,intel_pstate=disable'
Ran /sbin/lilo afterwards , no errors and rebooted, still panics, lol
Kernel command line parameters are separated by spaces, not commas.
 
Old 11-08-2013, 09:00 PM   #24
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by turtleli View Post
Kernel command line parameters are separated by spaces, not commas.
That fixed it... derp, dopey me!
 
Old 11-08-2013, 11:19 PM   #25
Gerardo Zamudio
Member
 
Registered: Jan 2011
Distribution: Slackware
Posts: 30

Rep: Reputation: 10
Quote:
Originally Posted by Jeebizz View Post
Hmm, well I was able to boot , tried to trick virtualbox - I went and added the following to lilo.conf

Code:
# Append any additional kernel parameters:
append=" vt.default_utf8=0,intel_pstate=disable'
Ran /sbin/lilo afterwards , no errors and rebooted, still panics, lol
There is a step during the install that asks if you want to append any parameters to lilo.conf. Type intel_pstate=disable here to have it automatically added. When you reboot it will be saved. Useful to know if you do another install in VirtualBox
 
Old 11-18-2013, 10:25 PM   #26
meetscott
Samhain Slackbuild Maintainer
 
Registered: Sep 2004
Location: Phoenix, AZ, USA
Distribution: Slackware
Posts: 411

Rep: Reputation: 42
I don't know if I would call this solved. I followed the suggestions and settings here and I still get the kernel panic.

In my case I'm running a VM on Windows for routing purposes only. So I simply installed the huge 3.2.29 kernel from Slackware 14.0 and left the rest of the 14.1 upgrade as is. It's working fine for SSH and routing so I'm not going to burn anymore time on it.

Last edited by meetscott; 11-19-2013 at 08:13 AM.
 
Old 11-19-2013, 08:05 AM   #27
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 72

Rep: Reputation: 7
<deleted this post>

Last edited by burdi01; 11-20-2013 at 04:31 AM.
 
Old 12-19-2013, 01:08 AM   #28
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 134

Rep: Reputation: 20
Seems to be fixed in VirtualBox 4.3.6
 
1 members found this post helpful.
Old 12-19-2013, 05:11 AM   #29
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 72

Rep: Reputation: 7
I hereby confirm that the intel_pstate problem is resolved with VB 4.3.6 r91406.
 
1 members found this post helpful.
Old 12-19-2013, 09:01 AM   #30
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 253

Rep: Reputation: 27
Thank you dr.s, burdi01, I also confirm with VB 4.3.6 r91406.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 13.37 64bit, Kernel Panic Error, Fresh install KvK Slackware 13 03-24-2014 07:18 PM
slackware 64bit virtualbox guest zenlunatic Slackware 32 12-01-2013 12:55 PM
[SOLVED] Running 64bit Slackware on 32 VirtualBox host? barry_lamb Slackware 8 04-01-2013 11:35 AM
[SOLVED] system settings and opengl issues Slackware 14 64bit kernel 3.7.1 perezomail Slackware 3 01-31-2013 03:14 AM
Custom Kernel on VirtualBox Slackware Guest daidoji Linux - Virtualization and Cloud 3 01-27-2010 08:00 PM


All times are GMT -5. The time now is 08:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration