LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-03-2011, 12:40 PM   #1
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 92

Rep: Reputation: 17
Slackware 64 crashes after booting generic kernel (64 bit)


I am really puzzled by this problem.

I've installed Slackware64 on a Toshiba Qosmio laptop (booting with ext4, SAMSUNG HM500JI HDD, 3 GB Ram, Intel Core 2 Duo Processor, Intel chipset and graphics).

The system boots the huge kernel just fine. But after booting with the generic kernel AND after having prepared a mkinitrd with the mkinitrd generator, the boot process crashes at ~4sec with a panic.

Any hint about what could be the cause of this problem?

Thanks in advance!
 
Old 05-03-2011, 12:58 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,364
Blog Entries: 2

Rep: Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981
Please past the last lines before the panic occurs.
 
Old 05-03-2011, 01:12 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,183

Rep: Reputation: Disabled
Also describe exactly what you mean by "prepared a mkinitrd with the mkinitrd generator", especially what you did after you created an initrd.gz (update /etc/lilo.conf? If so, how? Did you run "lilo" at the end?)

Eric
 
Old 05-03-2011, 01:39 PM   #4
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
@Eric: What I did was basically:

Code:
# /usr/share/sbin/mkinitrd_command_generator.sh > my_mkinitrd.sh
# chmod a+x my_mkinitrd.sh
# ./my_mkinitrd.sh && /sbin/lilo -v
 
Old 05-03-2011, 01:46 PM   #5
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
upon booting, the kernel panics after 4 s, complaining of the following:

Code:
No filesystem could mount root, tried: romfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)
Pid: 1, comm: swapper Not tainted 2.6.37.6 #2
Call Trace:
<more details, not copied>
 
Old 05-03-2011, 01:54 PM   #6
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
The my_mkinitrd.sh contents were, in the relevant part (i.e., omitting comment lines):

Code:
mkinitrd -c -k 2.6.37.6 -f ext4 -r /dev/sda3 -m usbhid:ehci-hcd:uhci-hcd:jbd2:mbcache:ext4 -u -o /boot/initrd.gz
It seems to me that there is some module that should be loaded by mkinitrd but somehow it is overlooked by the mkinitrd_command_generator script. The problem is, I have no clue as to which one is.

Thanks again
 
Old 05-03-2011, 02:42 PM   #7
qweasd
Member
 
Registered: May 2010
Posts: 436

Rep: Reputation: Disabled
I may be wrong, but I remember fixing something like this by compiling my root filesystem driver (in my case, ext4) into the kernel (as opposed to just a module).
 
Old 05-03-2011, 02:46 PM   #8
sparkyhall
Member
 
Registered: Nov 2009
Location: Chatteris---UK
Distribution: Slackware 13.0 & 14.0
Posts: 41

Rep: Reputation: 7
You can check to see which modules are included in the mkinitrd created initrd-tree by looking in:

/boot/init-tree/lib/modules/2.6.37.6/kernel
 
Old 05-03-2011, 02:49 PM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,183

Rep: Reputation: Disabled
Quote:
Originally Posted by sombragris View Post
@Eric: What I did was basically:

Code:
root@darkstar:~# /usr/share/sbin/mkinitrd_command_generator.sh > my_mkinitrd.sh
# chmod a+x my_mkinitrd.sh
# ./my_mkinitrd.sh && /sbin/lilo -v
Code:
# /usr/share/mkinitrd/mkinitrd_command_generator.sh
#
# mkinitrd_command_generator.sh revision 1.40
#
# This script will now make a recommendation about the command to use
# in case you require an initrd image to boot a kernel that does not
# have support for your storage or root filesystem built in
# (such as the Slackware 'generic' kernels').
# A suitable 'mkinitrd' command will be:

mkinitrd -c -k 2.6.33.4 -f ext4 -r /dev/sda5 -m jbd2:mbcache:ext4 -o /boot/initrd.gz
You see that what it does not do, is update /etc/lilo.conf . If you did not add the new kernel to it yourself, then running "lilo" does not do anything.
This will give you the lines to add:
Code:
root@darkstar:~# /usr/share/mkinitrd/mkinitrd_command_generator.sh -l /boot/vmlinuz-generic-2.6.33.4 
# Linux bootable partition config begins
# initrd created with 'mkinitrd -c -k 2.6.33.4 -f ext4 -r /dev/sda5 -m jbd2:mbcache:ext4 -o /boot/initrd.gz'
image = /boot/vmlinuz-generic-2.6.33.4
  initrd = /boot/initrd.gz
  root = /dev/sda5
  label = 2.6.33.4
  read-only
# Linux bootable partition config ends
Eric
 
Old 05-03-2011, 02:50 PM   #10
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,364
Blog Entries: 2

Rep: Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981
I had a somewhat similar issue. My solution was rather simple. I use a generic kernel without initrd. Just compile the drivers needed to boot your system into the kernel instead of as module, and everything else as module. this way you don't need to fiddle with the initrd. Works fine here.
 
Old 05-03-2011, 03:54 PM   #11
zordrak
Member
 
Registered: Feb 2008
Distribution: Slackware
Posts: 595

Rep: Reputation: 115Reputation: 115
Sorry just one thing.

Can everyone please stop calling the initrd a mkinitrd.

You use mkinitrd to MaKe an initrd

Thanks.
 
Old 05-03-2011, 10:29 PM   #12
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,415

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Quote:
Originally Posted by TobiSGD View Post
I had a somewhat similar issue. My solution was rather simple. I use a generic kernel without initrd. Just compile the drivers needed to boot your system into the kernel instead of as module, and everything else as module. this way you don't need to fiddle with the initrd. Works fine here.
IMO, the time and effort required to recompile the kernel is greater than the time and effort to make a correct initrd to use with the provided generic kernel.

And yes, my opinion is not your opinion.
 
Old 05-04-2011, 03:11 AM   #13
zordrak
Member
 
Registered: Feb 2008
Distribution: Slackware
Posts: 595

Rep: Reputation: 115Reputation: 115
The time and effort are greater, but so are the rewards Depends which goals you seek.
 
Old 05-04-2011, 03:40 AM   #14
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by Richard Cranium View Post
IMO, the time and effort required to recompile the kernel is greater than the time and effort to make a correct initrd to use with the provided generic kernel.

And yes, my opinion is not your opinion.
Well, I configure my kernel one time for a computer. I use .config with every new kernelversion (via "make oldconfig"). I only have to compile and install the kernel and have never used an initrd with Slackware.

Markus
 
Old 05-04-2011, 08:18 AM   #15
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
Aw shucks. My bad. Eric was right. I never updated lilo.conf to add a line telling the Linux section where the initrd was.

Since I was used to my older laptop, with an inherited config dating back from Slack 9 days, the relevant line used to just be there, and I never realized that an install from scratch needed that. My Slack laptop now boots fine with a generic kernel.

Thanks to everybody!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 13.37rc2 btrfs with generic kernel spudgunner Slackware 14 03-22-2013 09:46 PM
Kernel panic with generic kernel Slackware 13.1 goodadamgood Slackware 3 01-31-2011 04:57 PM
GoogleEarth Crashes in Slackware 13.1 (32-bit) with ATI Radeon X300 Series tronayne Slackware 1 09-22-2010 01:30 PM
[SOLVED] 32-bit Firefox crashes in Slackware Multilib 13.1 hajatvrc Slackware 2 07-10-2010 02:06 PM
Slackware 12, changing to generic kernel on raid1, mkinitrd issue [GOD]Anck Slackware 15 02-14-2008 07:25 PM


All times are GMT -5. The time now is 12:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration