LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-31-2002, 10:38 AM   #1
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Rep: Reputation: 0
Question questions on executing floppy program


I am new to Linux and recently installed RedHat 7.2. I am trying to configure PPP. I have downloaded PPPSetup (slackware) on a floppy. What commands to I need to type in from the root in order to execute this program? Do I need to 'mount' anything first? If so, how? Please list the commands, as I am a beginner. Thank You!

Last edited by dameliod; 05-31-2002 at 10:43 AM.
 
Old 05-31-2002, 01:15 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Why can't you use any of the PPP setup programs that come with Redhat ??

Well if you wanted to use a program that you have downloaded onto a floppy, first you have to mount the floppy, and then unpack it then install it depending on what type of file it is. I don't know for sure what the PPPSetup from Slackware will do for you any different from any of the Redhat PPP setups will do... ??

My first question to you is, what kind of modem do you have ? That will help you determine if your going to waste your time if its not supported as it might be a winmodem or something like that.
 
Old 05-31-2002, 01:58 PM   #3
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
RE:

sorry for the double post. Thanks for responding.

Actually, I tried using the redhat PPP dialer, I entered all the required information. (I put my modem as 'generic' since it is an older model 56k: it works find in windows98). After I submit the info and try to launch Netscape, I get the following message:

Following Host Unknown
home.nesscape.com
home6.netscape.com
internic.net

perhaps there is a problem with Ur name server?
If Ur site must use a non root name server U will need to set the
$socks_ns environment variable to point at the appropriate nameserver. It may be necessary (may not be) to set this variable or the socks host preference, to the IP address of the host in question rather than its name.

Do you know how to fix this?
 
Old 05-31-2002, 02:47 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
So does it actually connect or appear to connect after dialing out ?
 
Old 05-31-2002, 03:16 PM   #5
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
RE

It doesn't connect. I do not hear the modem dialing.
 
Old 05-31-2002, 04:31 PM   #6
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Then I wouldn't worry about launching netscape then, your only going to get "host not found" if your not connected. Any particular error messages when dialing out ?

Have you taken a look at the Modem howto at www.tldp.org ? Great info about modems in Linux. Also you never answered on what type of modem you have either, hardware modem or a Winmodem ?
 
Old 06-01-2002, 01:40 PM   #7
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
my modem is a MDP7800.
when I hit the 'debug' option I get the following message:
"unable to initialize modem"
 
Old 06-01-2002, 01:42 PM   #8
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
I also noticed when going through the PPP dialer wizard it has a german flag with what must me german ISP's to choose from. However my time is set to US eastern standard. I don't know how to change this.
 
Old 06-01-2002, 01:43 PM   #9
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
I am in the US by the way.....I meant I'm not sure how to change the german ISP selection to US.
 
Old 06-01-2002, 02:07 PM   #10
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Your modem appears to be a winmodem which means there is a slight chance it won't work or isn't supported in anyway.
Your going to want to go to www.linmodems.org for info and see if there are drivers for this particular modem.
 
Old 06-01-2002, 02:32 PM   #11
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
Good call, it is a winmodem. Thanks for your help. I appreciate it.
 
Old 06-01-2002, 10:01 PM   #12
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
well, I know have a linux supported modem, "us robotics"
the ppp dialer still shows 'germany' in the wizard, how do I change this to the U.S. so that I can choose the correct ISP?
 
Old 06-02-2002, 12:56 AM   #13
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
You shouldn't have to choose a ISP to connect, you should be able to dial into your own ISP that you may already have an account with. If your modem is a winmodem, first get it working properly if there are drivers for it. Just because its a US Robotics doesn't mean its supported. Is this the same model we were referring to before ??
 
Old 06-02-2002, 01:09 AM   #14
milos
LQ Newbie
 
Registered: May 2002
Posts: 12

Rep: Reputation: 0
/etc/rc.modules??????

You might want to find out what the name of your driver is and use a text editor to edit your /etc/rc.modules. In this file you might find a line under the heading modems that has your particular driver listed. I think if you uncomment (remove #) that line and reboot you should be able to use/configure your modem. Not sure though because i'm using a cable modem. But that is how I got my ethernet card to work.
good luck
 
Old 06-03-2002, 01:23 PM   #15
dameliod
LQ Newbie
 
Registered: May 2002
Location: na
Distribution: na
Posts: 13

Original Poster
Rep: Reputation: 0
re

The PPP dialer asks me to select form a list (cable, modem, isdn)
I select modem. on the next screen there is a german flag with all german ISP's if I leave it blank and type in my isp's info and user name and password I can click finish and work through it fine, but I still can't dial up. I do have a linux compatible modem, its a US robotics 56k performance pro and its supported on the www.linmodems.org site.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 09:54 AM
Dual boot windows/slackware, but slackware installed first? Cryptic_K Slackware 3 11-20-2006 12:49 PM
Slackware 10 RC2 released; Slackware 10 imminent... SBing Slackware 22 06-22-2004 07:53 AM
Newer Slackware Packages on older slackware version pengStudent Slackware 2 11-12-2003 12:47 PM
wine and winesetuptk working well with slackware 9.0 and slackware 9.1 oobe Linux - Software 0 10-19-2003 12:29 PM


All times are GMT -5. The time now is 04:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration