LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-02-2012, 06:25 PM   #1
donallen
LQ Newbie
 
Registered: Apr 2010
Posts: 26

Rep: Reputation: 7
Slackware 14 sound problem


I just installed Slackware 14 on my desktop machine (hardware details below), I have no sound, and alsamixer fails:

dca@sergei:~$ alsamixer
cannot load mixer controls: Invalid argument

I'm running the stock (huge) kernel.

Hardware:

dca@sergei:~$ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB controller: nVidia Corporation MCP61 USB 1.1 Controller (rev a3)
00:02.1 USB controller: nVidia Corporation MCP61 USB 2.0 Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control

Loaded modules:

dca@sergei:~$ lsmod
Module Size Used by
snd_seq_dummy 1455 0
snd_seq_oss 29048 0
snd_seq_midi_event 5620 1 snd_seq_oss
snd_seq 51265 5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device 5228 3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss 39183 0
snd_mixer_oss 15404 1 snd_pcm_oss
ipv6 279979 34
fuse 66626 5
lp 9787 0
usbhid 35615 0
hid 82876 1 usbhid
k10temp 2843 0
snd_hda_codec_realtek 195474 1
nouveau 724472 2
forcedeth 52696 0
mxm_wmi 1385 1 nouveau
wmi 8403 1 mxm_wmi
video 11378 1 nouveau
evdev 9574 6
snd_hda_intel 23267 0
snd_hda_codec 81925 2 snd_hda_intel,snd_hda_codec_realtek
snd_hwdep 6324 1 snd_hda_codec
snd_pcm 72864 3 snd_hda_codec,snd_hda_intel,snd_pcm_oss
snd_page_alloc 7081 2 snd_pcm,snd_hda_intel
ttm 53508 1 nouveau
drm_kms_helper 26133 1 nouveau
drm 187389 4 drm_kms_helper,ttm,nouveau
agpgart 27372 2 drm,ttm
ppdev 5958 0
processor 25592 0
button 4529 1 nouveau
thermal_sys 14578 2 processor,video
hwmon 1329 3 thermal_sys,nouveau,k10temp
parport_pc 19423 1
parport 31427 3 parport_pc,ppdev,lp
snd_timer 18798 2 snd_pcm,snd_seq
snd 57796 11 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,snd_mixer_oss,snd_pcm_ oss,snd_seq_device,snd_seq,snd_seq_oss
i2c_algo_bit 5319 1 nouveau
soundcore 5474 1 snd
i2c_nforce2 5056 0
i2c_core 19978 5 i2c_nforce2,i2c_algo_bit,drm,drm_kms_helper,nouveau
serio_raw 4389 0
loop 18192 0

Suggestions for how to fix this would be appreciated.

Thanks --
/Don Allen
 
Old 10-02-2012, 06:32 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,613
Blog Entries: 1

Rep: Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048
Are you in the audio group?

Can you post the output of:

Code:
cat /proc/asound/cards
Can you run alsamixer as root?

Edit: Have a look at this thread
http://www.linuxquestions.org/questi...-a-4175429566/

Last edited by sycamorex; 10-02-2012 at 06:34 PM.
 
Old 10-02-2012, 08:34 PM   #3
donallen
LQ Newbie
 
Registered: Apr 2010
Posts: 26

Original Poster
Rep: Reputation: 7
With your help, I've solved this problem. See below. I've also provided answers to your questions. Might be useful to someone else with the same problem.

Quote:
Originally Posted by sycamorex View Post
Are you in the audio group?

Yes.

Can you post the output of:

Code:
cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfe024000 irq 21


Can you run alsamixer as root?

I tried it and it failed in the same way.

Edit: Have a look at this thread
http://www.linuxquestions.org/questi...-a-4175429566/
The trick is to create the file /etc/modprobe.d/sound.conf containing the line:

options snd-hda-intel model=auto

This Slackware installation replaced an Arch install that I did when I built this machine in May. I never had any problems with sound. Before installing Slackware, I tar'ed /etc and just checked it -- nothing in /etc/modprobe.d. Why this is a problem in Slackware and not Arch on the same hardware is a bit of a mystery (yes, different kernel version, but the alsa package versions look to be the same in Arch and Slackware 14).

Anyway, thanks very much for your help in getting this resolved.

/Don Allen
 
Old 10-03-2012, 11:42 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Could you supply the make and model of your machine?
It would be good to add this to the SlackDocs page. http://docs.slackware.com/howtos:har..._snd-hda-intel
 
Old 10-04-2012, 12:20 AM   #5
donallen
LQ Newbie
 
Registered: Apr 2010
Posts: 26

Original Poster
Rep: Reputation: 7
Quote:
Originally Posted by allend View Post
Could you supply the make and model of your machine?
It would be good to add this to the SlackDocs page. http://docs.slackware.com/howtos:har..._snd-hda-intel
I built the machine myself. Motherboard is a GIGABYTE AM3+ NVIDIA GeForce 7025/nForce 630a Chipset DDR3 1600 Micro ATX AMD Motherboard GA-M68MT-S2. AMD Athlon II X2 250 processor. 4 GB DDR3 memory. 500 Gb 7200 rpm SATA drive. See lspci output in my original post for other hardware details.
 
Old 10-04-2012, 01:43 AM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Thankyou for the details. An update to the SlackDocs page has been made.
 
Old 10-07-2012, 01:05 PM   #7
lee88abc
Member
 
Registered: Apr 2011
Location: northeast USA
Distribution: slackware
Posts: 30

Rep: Reputation: 0
I have another audio problem.

I can play mpg123 myfile.mp3 on the black console.

But when I start up runmode 4 gui and kde starts. Then I get error saying audio device not work falling back to default.

Running as root, I can play audio in kde.
 
Old 10-07-2012, 01:49 PM   #8
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 258

Rep: Reputation: 32
Quote:
Originally Posted by lee88abc View Post
I have another audio problem.

I can play mpg123 myfile.mp3 on the black console.

But when I start up runmode 4 gui and kde starts. Then I get error saying audio device not work falling back to default.

Running as root, I can play audio in kde.
Make sure your user is in the audio group. Maybe plugdev too, I can't remember. If you chose the default groups when creating the user, those should have been added. Remember that you'll have to log in and then out again to get the new group list to take effect.
 
Old 10-07-2012, 04:30 PM   #9
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,849
Blog Entries: 15

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
You probably also could run the alsaconf script. AlienBOB has a copy on his website maintained for just-in-case.
 
Old 02-25-2013, 11:56 PM   #10
lee88abc
Member
 
Registered: Apr 2011
Location: northeast USA
Distribution: slackware
Posts: 30

Rep: Reputation: 0
forgot to check back.
Thanks everyone.
In previous slackware versions I never had this problem.
In slack 14 for some reason I need to add user to audio group in passwd.
Is this a new requirement?

I've repeated the same process on physical machines and virtual machines. In each case I had to add user to audio group.
 
Old 02-26-2013, 01:36 AM   #11
zeroberto
Member
 
Registered: Aug 2008
Location: Serbia
Distribution: Slackware-current
Posts: 39

Rep: Reputation: 1
I need to add user to audio group only if I use pulseaudio, otherwise there is no sound. But with pure alsa I don't need to do that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 13 Sound Problem tairoesp Linux - Hardware 13 02-26-2010 09:03 PM
Sound Problem in Slackware 12.1 leo-v Linux - Newbie 1 11-26-2008 03:44 AM
Slackware 12.1 sound problem danny1ro Slackware 1 07-31-2008 09:00 AM
Slackware 11 - Sound problem Tux-Slack Slackware 8 03-10-2007 04:45 PM
Slackware 9 sound problem wildtiger23 Linux - Hardware 2 03-27-2003 01:56 PM


All times are GMT -5. The time now is 09:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration