View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 10-25-2012, 06:09 PM   #1
Registered: Aug 2009
Posts: 150

Rep: Reputation: 15
Slackware #14 runs S-L-O-W!

I've had a problem with Slackware #14 since I installed it. It runs like it's stuck in molasses. I've seen that Slackware installs a "huge" kernel, and that there's a way to cut the kernel down, but I haven't come across any kind of a guide to do that. And it sounds like a Gentoo kinda move, and I can't imagine doing it without recompiling and generating a new image for the boot loader to have to find. How hard is it, and is that going to help speed up what I've got now?

Here's lspci, if that gives any information. Looks like I've got a lot of Nvidia and AMD to work with.
larry@larry-desktop ~ $ lspci
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:05.0 Bridge: nVidia Corporation CK8S Ethernet Controller (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5) (rev a2)
00:09.0 IDE interface: nVidia Corporation nForce3 Serial ATA Controller 2 (rev a2)
00:0a.0 IDE interface: nVidia Corporation nForce3 Serial ATA Controller (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2)
Old 10-25-2012, 06:27 PM   #2
Senior Member
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540
Replacing the huge kernel probably is not intuitive or obvious to newcomers.

The basic idea is to boot with the huge kernel and then when ready, create a generic kernel with an initrd.

After booting, as root, run something like this:

mkinitrd -c -k 3.2.29-smp -m ext3:ext4 -f ext4 -r /dev/sda1 -o /boot/initrd-3.2.29.gz

'man mkinitrd' will explain the options. The explanations are reasonably straightforward.

Of course, use only the options you need and modify that example command for your system.

If you use lilo, then update /etc/lilo.conf and run the lilo command before rebooting. But don't worry, you can use the CD/DVD as a boot disk to get into your system if you unknowingly mangle lilo.conf.

If you use grub legacy, then edit /boot/grub/menu.lst as necessary.

With either lilo or grub, don't remove the original boot commands. Instead add a new section for the generic kernel and initrd. That way, in addition to the CD/DVD, you also can boot into the system with the original huge kernel boot option.
Old 10-25-2012, 06:30 PM   #3
LQ Newbie
Registered: Oct 2012
Location: Somewhere after <?php
Distribution: Slackware-current
Posts: 16

Rep: Reputation: 2
Nothing that much of a work

First, you run as root /usr/share/mkinitrd/
It will show you what command you need to enter in order to generate the proper initrd
Copy and paste it again in the console, it will be something like this:
mkinitrd -c -k 3.2.29-smp -f ext4 -r /dev/sda6 -m mbcache:jbd2:ext4 -u -o /boot/initrd.gz
Then edit /etc/lilo.conf. Add another Linux section which should look like this
image = /boot/vmlinuz-generic-smp-3.2.29-smp
initrd = /boot/initrd.gz
root = /dev/sdb1
label = Linux
Save and run

lilo -v
Anyway, just in case, check out what you have in /boot before rebooting. You're looking for a vmlinuz-generic-(smp)-(version) kernel. If you see only vmlinuz-huge- kernel, get the kernel-generic-smp package from the repositories.

Last edited by NorthBridge; 10-25-2012 at 06:32 PM.
Old 10-25-2012, 07:28 PM   #4
Registered: May 2001
Posts: 28,826
Blog Entries: 55

Rep: Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341Reputation: 3341
Could anyone address the OPs question "if that is going to help speed up what he's got now"?

I mean I know what ANNOUNCE and CHANGES say (including somewhere it reads it's OK to run what you installed ;p) and everyone knows kernels that load about everything plus the kitchen sink cost boot time and memory but apart from that (and it's not like the OP actually offered any data wrt real or perceived bottlenecks) I don't see it quantified anywhere what performance gain can be had. Or should I take it is just SOP to say running "huge" has a huge impact on performance w/o needing baseline SAR or other diagnostic output analysis? If so, with all due respect, doesn't that sound just a wee bit unscientific?
Old 10-25-2012, 07:33 PM   #5
Registered: Aug 2009
Posts: 150

Original Poster
Rep: Reputation: 15
unSpawn, it's a good question, but , well there's a sure-fire quick (I hope!) way to find out! The system is going down for a kernel rebuild in 5...4...3..2..
Old 10-25-2012, 07:59 PM   #6
Registered: Nov 2001
Location: California
Distribution: Slackware 14.1
Posts: 300

Rep: Reputation: 62
If it's still slow after switching to the generic kernel, then try running Fluxbox (not KDE) and see if that makes a difference. You can use the "xwmconfig" program to switch between DE's/WM's.
Old 10-25-2012, 08:12 PM   #7
Registered: Aug 2009
Posts: 150

Original Poster
Rep: Reputation: 15
I just ran the kernel command and was able to reboot after giving the grub update command from the Linux Mint I have on another hard drive, and Slackware booted right up, and all seemed well.

Then when I went to post this from Google Chrome, Chrome froze up big time when I opened more than one tab to check some things. The mouse and keyboard would still work, and that's all that kept me from going for the shut down button on the front of the computer, so I still have issues.

Not sure what to make of it. I installed Slackware because I was having Google Chrome freeze up so badly on the Ubuntu install that I originally had on the other hard drive so badly that the mouse and keyboard were totally inoperative, and a hard shut down was the only way to get anything to work. Then it would freeze again after about 15 minutes of use. Never found out if it was Google, Ubuntu, my computer, or what. There wasn't any way to get a log to see what happened after the reboot, as far as I could tell. So now I've got this. I wanted to see how Slackware wireless worked with Network Manager, and that seems to work fine. But whatever makes this thing slow to a crawl is a pain in the nether regions.

Maybe something with the newer kernels, who knows? I also tried Fedora, although not on this computer. Never froze, but wireless was worthless, couldn't connect to my router which is in the next room.
Old 10-25-2012, 08:20 PM   #8
Senior Member
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 15 , Linux-Lite 2.4, Slackel 14.1, ChromeOS
Posts: 3,677
Blog Entries: 19

Rep: Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239
I am suprised nobody mentioned post

readout to see what is hogging what.
Old 10-25-2012, 08:22 PM   #9
Registered: Mar 2011
Distribution: Slack64
Posts: 111

Rep: Reputation: 20
Originally Posted by pottzie View Post
Maybe something with the newer kernels, who knows?
It probably has nothing to do with the kernel and everything to do with X / Desktop Environment / Video drivers. Turn off composite and all shiny effects in KDE. Or use XFCE or some other window manager and see if the problem persists. Try using the NVIDIA binary blob (but make sure to blacklist nouveau if you do).
Old 10-25-2012, 08:43 PM   #10
Registered: Aug 2009
Posts: 150

Original Poster
Rep: Reputation: 15
Just ran top to see what the output was, not sure what to make of the info. Changing to XFCE is pretty easy, if I remember, but how to deselect nouveau and go with NVIDIA?
top - 21:42:32 up  1:02,  3 users,  load average: 2.11, 1.18, 1.14
Tasks: 152 total,   5 running, 147 sleeping,   0 stopped,   0 zombie
Cpu(s): 17.3%us,  5.2%sy,  0.7%ni, 51.8%id, 24.8%wa,  0.0%hi,  0.3%si,  0.0%st
Mem:    493820k total,   485496k used,     8324k free,      204k buffers
Swap:        0k total,        0k used,        0k free,    85628k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 2231 larry     20   0  302m  41m  12m R  6.3  8.6   0:13.67 plasma-desktop     
 2205 larry     20   0  289m  29m 6392 R  3.6  6.0   0:30.26 kwin               
 2067 root      20   0 81760  21m  11m S  3.3  4.5   0:54.84 X                  
 2502 larry     20   0  195m  33m  12m R  1.7  6.8   2:38.41 chrome             
 2171 root      20   0 24948 1584  940 S  1.3  0.3   0:01.32 udisks-daemon      
 2315 larry     20   0  383m  64m 9448 R  1.3 13.4   1:44.30 chrome             
 1901 messageb  20   0  3532 1220  416 S  0.3  0.2   0:01.01 dbus-daemon        
 2131 larry     20   0  153m 8884 2176 S  0.3  1.8   0:03.28 kded4              
 2247 larry     20   0  239m  19m  876 S  0.3  4.0   0:04.94 mysqld             
 2281 larry     39  19  172m 7988  760 S  0.3  1.6   0:02.26 nepomukservices    
 2554 larry     39  19 98520 4180 1276 S  0.3  0.8   0:00.56 nepomukservices    
 2681 root      20   0     0    0    0 S  0.3  0.0   0:03.04 kworker/0:0        
 2816 larry     20   0  2836  780  480 R  0.3  0.2   0:01.25 top                
 2821 root      20   0     0    0    0 S  0.3  0.0   0:00.01 kworker/0:1        
 2822 root      20   0     0    0    0 S  0.3  0.0   0:00.13 kworker/u:1        
    1 root      20   0  2008   64    0 S  0.0  0.0   0:01.04 init               
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.00 kthreadd
Old 10-25-2012, 08:54 PM   #11
Registered: Aug 2009
Posts: 150

Original Poster
Rep: Reputation: 15
Just made the switch to XFCE, and it's WAY faster, multiple tabs are no problem now. I'll play with this for a bit and if it works, mark this as solved. Thanks!

EDIT: Yeah, it's better by a mile Slackware just went from being the slowest operating system I'm using to perhaps the fastest, although I I have to still give a nod to Fedora on a Thinkpad I'm using.

But this is way better, and I like that the answer was relatively painless, too.

Last edited by pottzie; 10-25-2012 at 09:13 PM.
Old 10-25-2012, 09:18 PM   #12
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 16,648
Blog Entries: 2

Rep: Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599Reputation: 4599
Just for the explanation, it seems that you have only 512MB RAM in that machine, minus a part for the videocard, which seems to be onboard.
For the heavy desktop environments, like KDE 4 or Ubuntu's Unity this is simply not enough, especially when you run a web-browser, which nowadays also are resource hogs.
I would recommend to put some more RAM into that machine, if possible, or, as you already have done, switch to a more lightweight environment and maybe also more lightweight software.
Old 10-25-2012, 09:25 PM   #13
LQ Guru
Registered: Jul 2011
Location: California
Distribution: FreeBSD 11.0-Current Slackware64-Current
Posts: 5,245
Blog Entries: 15

Rep: Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551Reputation: 1551
You should have at least 2GB RAM or more for modern PCs and software. Try to add more RAM before you do anything else. It will help.
Old 10-26-2012, 12:03 AM   #14
Senior Member
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Originally Posted by ReaperX7 View Post
You should have at least 2GB RAM
Well that's a bit of a stretch. I mean my personal preference is a minimum of 6GB and my new machine has 32 (and I managed to use 31 of them!), but I have a machine that has an old Celeron and 1 GB of memory and it works. Just for browsing etc it is just fine and I used it at 512...BUT and this relates to the OP's top output... I use a swap space on that machine. Running a machine with 512mb of memory with no swap space isn't going to work for squat.

So to the OP... if you have any room left on that machine to add a swap space you should do so, and of course more memory would help. I guess I should also mention that while that Celeron machine will run kde 4.x and Gnome 2.3.x, I generally use fluxbox on it. Once the features of KDE are gone, I don't see the point of XFCE. Fluxbox is just an awesome little window manager and on a system that can't have too many open windows to begin with, the right click anywhere thing is super sweet in my opinion. I think I drifted off topic here... my apologies.
Old 10-26-2012, 03:11 AM   #15
Mark Pettit
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.1 64 Multi-Lib
Posts: 474

Rep: Reputation: 157Reputation: 157
Despite the fact that swapping RAM to/from disk does work, I think that any system doing that is pretty much poked. The history of virtual memory goes back to the days when memory was VERY scarce and VERY expensive, while disk was (relatively) cheap and fast. What's happened over time (> 30 years) is that memory has become incredibly fast and cheap. On the other hand, while disk size has increased by the same ratio (that's a guess), disk access times and speeds have NOT. Thus 30 years ago we could swap to disk with a penalty of say 100 times slower (a guess), today that same swap would be 10 000 000 times slower. Point is that if you have to swap in and out continually just to run, you're not going to have fun. (unless you like to watch paint dry).

Summary : buy RAM !
1 members found this post helpful.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why Slackware runs fast? nuxrl Slackware 26 10-29-2009 06:02 AM
Slackware: configured, but monitor runs on 59Hz. the_ruthless Linux - Newbie 4 06-14-2006 03:37 AM
Slackware runs perfect with no partitions??? OpenCircuit Slackware 2 02-04-2006 11:47 PM
Slackware runs XboX! jymbo Slackware 8 09-29-2004 01:36 PM
rh8 or slackware,which runs better for amd k6-2 sas Linux - Distributions 1 01-10-2003 06:04 PM

All times are GMT -5. The time now is 12:05 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration