LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-03-2012, 09:24 AM   #1
lkraemer
Member
 
Registered: Aug 2008
Posts: 111

Rep: Reputation: 10
Slackware 14 - No Networking Icon on XFCE Top Right Panel


I've installed Slackware 14 several times. I'm using XFCE for my Desktop. I have tried to set up Networking by using "netconfig" during install, and without "netconfig" during install until after I have added user (larry) and have all my groups (lp, cdrom, floppy, audio, video, plugdev, netdev, scanner) assigned. I don't have any Domain specified in my Router, and Slackware's install and setup in "netconfig" won't let me press ENTER instead of assigning a Domain name. How do I assign
a Domain name of "NONE", or remove it after executing "netconfig"?

I never get any Icon in the Top Right XFCE Panel, and I can't find any installed software (GUI) that will allow me to get my Wifi working.
APPLICATIONS MENU -> SETTINGS -> NETWORK CONNECTIONS doesn't do anything when I Left Click on it. WHY?

I've set ESSID, KEY, and WLAN0 with iwconfig, but the power is at Zero.
I can't ping anything, and I'm still stuck. Network restarts don't help, and neither do reboots.

I've found this site that is supposed to make it easy to enable the Wifi, but so far it hasn't helped me get my Wifi working.

http://www.slackbook.org/html/networ...-wireless.html

What am I missing/overlooking?
Do I need KwalletManager enabled before the Wifi(Networking) works?
Why don't I have a Network Icon in the Top Right XFCE Panel?
Internet & forum searches haven't helped find what I'm doing incorrectly.

I'm at the point where I need detailed instructions to get the Wifi functional.

Thanks, for any assistance you can offer.

Larry

Last edited by lkraemer; 10-03-2012 at 09:26 AM.
 
Old 10-03-2012, 10:05 AM   #2
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
Quote:
Originally Posted by lkraemer View Post
Why don't I have a Network Icon in the Top Right XFCE Panel?
Because the program which provides the icon is not installed. You need to install networkmanager or wicd. The former is usually available at slackbuilds.org and the latter is usually in /extra on the slackware DVD. I prefer wicd, though YMMV.

The reason there is not a "network icon" by default is because a GUI networking applet it is not required for the purpose of establishing a connection (nor should it be).

Also: http://alien.slackbook.org/dokuwiki/...ckware:network
 
Old 10-03-2012, 10:06 AM   #3
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
if you select the option in netconfig to use NetworkManager you will have nm-applet in the system tray in KDE, XFCE and Fluxbox. You can also start nm-applet from the command line if it's not running or run netconfig if you need to select NetworkManager after the installation. Assuming your wifi card is supported by the kernel networking will "just work" using NetworkManager. You can set any domain name you want for a desktop or laptop.

DNA
AKA mrascii

Last edited by mrascii; 10-03-2012 at 10:08 AM.
 
Old 10-03-2012, 10:15 AM   #4
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
Quote:
Originally Posted by el chapulín View Post
Because the program which provides the icon is not installed. You need to install networkmanager or wicd. The former is usually available at slackbuilds.org and the latter is usually in /extra on the slackware DVD. I prefer wicd, though YMMV.

The reason there is not a "network icon" by default is because a GUI networking applet it is not required for the purpose of establishing a connection (nor should it be).

Also: http://alien.slackbook.org/dokuwiki/...ckware:network
While some prefer wicd NetworkManager is part of the standard Slackware 14.0 installation and does not need to be installed from SlackBuilds. el chapulin is correct that you can established a wifi connection without a graphical application but if you're running XFCE using NetworkManager is much easier and it is the standard for just about every other Linux distribution. Re-run netconfig if you need to and wifi will work if the support for your card is in the kernel.

DNA
AKA mrascii
 
Old 10-03-2012, 10:31 AM   #5
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,275

Rep: Reputation: 187Reputation: 187
In Xfce you need to go to,

"Settings" > "Session & Startup" > "Application Autostart" and put a check mark in the box to the left of "Network (Manage your netork connections", and then logout and restart Xfce.

You should probably also check "PolicyKit Authorization Agent" and whatever else you think will be useful.

Last edited by cwizardone; 10-03-2012 at 10:42 AM.
 
Old 10-03-2012, 10:53 AM   #6
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
Quote:
Originally Posted by cwizardone View Post
In Xfce you need to go to,

"Settings" > "Session & Startup" > "Application Autostart" and put a check mark in the box to the left of "Network (Manage your network connections", and then logout and restart Xfce.

You should probably also check "PolicyKit Authorization Agent" and whatever else you think will be useful.
Network will already be checked in XFCE if NetworkManager is selected during the install. But it may not be (haven't checked) if you run netconfig later so cwizardone offers good advise.

DNA
AKA mrascii
 
Old 10-03-2012, 12:02 PM   #7
lkraemer
Member
 
Registered: Aug 2008
Posts: 111

Original Poster
Rep: Reputation: 10
mrascii & el chapulin

It does appear that my Atheros AR9285 hardware is functional, and recognized according to my previous question/testing on this forum.

I'm following the URL that el chapulin posted and I finally have my Wifi working.

A note to this URL needs to be added to the Documentation that is on the DVD!

THANK YOU!

Now I can finish setting up Slackware. WHEW!

Larry
 
Old 10-04-2012, 11:19 AM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,275

Rep: Reputation: 187Reputation: 187
Quote:
Originally Posted by mrascii View Post
Network will already be checked in XFCE if NetworkManager is selected during the install...
Well, that might be the theory , but in practice I have always had to manually add the network icon as outlined in my previous post.
Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Is there a way to remove a menu icon on an XFCE panel? CGBS Linux - Newbie 1 11-29-2011 04:13 AM
How do I add the Firefox icon to the XFCE panel? Travis86 Linux - Software 3 05-02-2006 03:48 PM
icon problem in xfce4 panel using slackware 10 gravityworks Slackware 2 06-27-2004 03:46 PM
XFCE - where are all my programs, no program icon in the panel. coolwater Linux - Newbie 8 12-23-2003 09:31 AM


All times are GMT -5. The time now is 08:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration