LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14 - Keyboard now requires acpi to be off (http://www.linuxquestions.org/questions/slackware-14/slackware-14-keyboard-now-requires-acpi-to-be-off-4175430996/)

Hangdog42 10-07-2012 01:56 PM

Slackware 14 - Keyboard now requires acpi to be off
 
I just upgraded my Dell XPS 15z from 13.37 to 14 following the instructions in UPGRADE.txt. Things seemed to go smoothly until I booted into runlevel 3 using the generic kernel (initrd is working, I guess) and found that I get absolutely no keyboard function. I mean they keyboard doesn't work at all, I can't even log in. Booting using the huge kernel made no difference.

I rebooted and turned off acpi, and that restores keyboard function to normal. However, this is a change as 13.37 didn't need acpi to be off for the keyboard to function.

Any ideas or have I missed something about the way 14 handles keyboards?

elesmod 10-09-2012 04:04 AM

Ok, this will probably not help, because keyboards are not attached to PCI, but since you have a lot more experience with Linux than I, it might make you think of other ideas :)

I also was passing noacpi to the kernel, because my motherboard wouldn't boot many distributions (Slack included). I did some reading and people suggested passing pci=nocrs instead of noacpi. Apparently it just reverts the default method for finding PCI resources. And remember what I wrote at the beginning :P

H_TeXMeX_H 10-09-2012 04:56 AM

What kind of keyboard is it ? USB ? PS/2 ?

EDIT: nevermind, it's a laptop

allend 10-09-2012 06:40 AM

According to this https://bbs.archlinux.org/viewtopic.php?pid=1154399 adding 'acpi=noirq' as a kernel option fixes this.

Hangdog42 10-09-2012 05:30 PM

Thanks all, that thread allend linked to did the trick. Running with "acpi=off" wasn't tenable long term since this laptop really needs bumblebee to function properly, and bumblebee requires acpi to be functional. I also had success using 'noapic', which was probably a better option than acpi=off, but I'm not good enough enough with hardware-level problems to really know.


All times are GMT -5. The time now is 07:27 AM.