LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14 can't install amd ATI driver (http://www.linuxquestions.org/questions/slackware-14/slackware-14-cant-install-amd-ati-driver-4175434122/)

boy_China 10-25-2012 11:03 PM

Slackware 14 can't install amd ATI driver
 
Today I download 14 and install it .
After install 14,then install amd ati driver.My video card is HD4330 .I installed in 13.37,it worked well.But can't install on slackware 14.

I download amd ati driver and ecexute" sh ./amd-driver-installer-12-4-x86.x86_64.run.
not success:(

This is the log:
Code:

Error: Module radeon is in use
Unloading drm module...
Error: Module drm is in use by: drm_kms_helper ttm radeon
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.2.29-smp/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-3.2.29'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_fpu_begin':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5812:28: error: 'TS_USEDFPU' undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5812:28: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-3.2.29'
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
[Reboot] Kernel Module : mkinitrd

Is there someone know how to install amd ati driver? Can you give some suggest .Thanks :)

TobiSGD 10-25-2012 11:07 PM

The Catalyst 12.4 driver will not work without being patched on 32 bit kernels version 3.2.8 or higher. For your card you should install the Catalyst 12.6 Legacy driver: http://support.amd.com/us/gpudownloa...eon_linux.aspx

boy_China 10-26-2012 03:03 AM

Quote:

Originally Posted by TobiSGD (Post 4815123)
The Catalyst 12.4 driver will not work without being patched on 32 bit kernels version 3.2.8 or higher. For your card you should install the Catalyst 12.6 Legacy driver: http://support.amd.com/us/gpudownloa...eon_linux.aspx

Thanks a lot :)
This problem has solved . Next , I will make my bcm wireless card work


All times are GMT -5. The time now is 11:01 PM.