LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-07-2012, 11:14 AM   #1
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Rep: Reputation: 2
Cool Slackware 14: Always need to run alsactl init manually in order to bring live Audio?


Hi all Slackers,

Just updated Slackware from 13.37 to 14 a few days ago.

Alsaconf is gone. Now it appears that I have to run
#alsactl init
manually everytime after login to KDE, else it will be no sound.

#alsactl store after setting #alsamixer and run #alsactl init also doesn't make any differences.

I tried to put alsactl init command into rc.local but without result.

I tried to create /etc/modprobe.d/snd-hda-intel.conf and put the content (a line):
options snd-hda-intel model=auto
I changed the model= to several type (referring to /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt )
This also fails to bring the sound automatically.

Additionally, my KDE keeps asking (pop-up after login):
KDE detected that one or more internal devices were removed.
Do you want KDE to permanently forget about these devices?
This is the list of devices KDE thinks can be removed:
Capture: HDA Intel (ALC269 Analog)
Output: HDA Intel (ALC269 Analog)
Output: HDA Intel, ALC269 Analog (Default Audio Device)

What is happening actually? I think it might be a failure of modprobe. Anyone having the same problem ?

Last time after the initial install of 13.37, I just ran alsaconf once, and the audio is active everytime. Now I have to manually run alsactl init everytime after login into KDE.

Cheers....

RJ
 
Old 10-07-2012, 12:46 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
If you really need alsaconf, I have saved a copy of the script here: http://www.slackware.com/~alien/tools/alsaconf

Just stick it in /usr/local/sbin and make it executable.

Eric
 
3 members found this post helpful.
Old 10-07-2012, 09:31 PM   #3
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Hi Eric,

It didn't occur to me before to use alsaconf as I tried to make everything works by the standard of Slackware 14, but your advice works like charm.

I'm still wondering what is happening with that alsactl init thingy though.

But I'm a happy person now thanks to you Eric

Cheers....

RJ
 
Old 10-08-2012, 05:42 AM   #4
clifford227
Member
 
Registered: Dec 2009
Distribution: Slackware 14
Posts: 282

Rep: Reputation: 64
Im having a problem with sound too.

For me, there seems to be some conflict between the pci sound card and the NVIDIA graphics card (with HDA? audio), as when both are plugged in together, I can play video with sound through mplayer, but when I try to play mp3's with an audio player I get:

Quote:
ALSA error: snd_mixer_find_selem failed

ALSA error: snd_pcm_hw_params_set_format failed : Invalid argument
If I take out the video card, I can play mp3's with the correct driver for the sound card.

I've tried Alienbobs alsaconf script, but it reports:

Quote:
No supported PnP or PCI card found
ALSA mixer shows that the pci soundcard is being selected, but I still get the invalid argument error above.

Running 'alsactl init' I get these messages:

Quote:
/usr/share/alsa/init/00main:34: invalid filename '/usr/share/alsa/init/ca0106
Found hardware: "CA0106" "CA0106" "" "ox1102" 0x100a"
Hardware is intialized using a generic method
Ive also created an /etc/modprobe.d/alsa.conf, with the following line:

Quote:
options snd-hda-intel model=auto
Any help to get sound work would be appreciated.

Last edited by clifford227; 10-08-2012 at 05:55 AM.
 
Old 10-08-2012, 06:36 AM   #5
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Hi Clifford,

your trouble seems deeper than mine.

Is Slackware 14 your first slackware install ?

Does everything run smoothly using 13.37 before ?

Cheers...

RJ
 
1 members found this post helpful.
Old 10-08-2012, 06:40 AM   #6
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,564
Blog Entries: 1

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
I had the same problem, Clifford. I blacklisted the module which fixed the problem.
 
Old 10-08-2012, 06:55 AM   #7
clifford227
Member
 
Registered: Dec 2009
Distribution: Slackware 14
Posts: 282

Rep: Reputation: 64
Quote:
Originally Posted by RJwen View Post
Hi Clifford,

your trouble seems deeper than mine.

Is Slackware 14 your first slackware install ?

Does everything run smoothly using 13.37 before ?

Cheers...

RJ
RJwen,

My last install was Slack 12.2 which I ran up untill last week, and it run both the sound card and the Nvidia graphics card in tandem with no problems.


Quote:
Originally Posted by sycamorex
I had the same problem, Clifford. I blacklisted the module which fixed the problem.
Which module was that sycamorex?

Last edited by clifford227; 10-08-2012 at 06:58 AM.
 
Old 10-08-2012, 07:02 AM   #8
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,564
Blog Entries: 1

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
I think it was snd-hda-intel but I am not at my computer now.
 
1 members found this post helpful.
Old 10-08-2012, 08:21 AM   #9
clifford227
Member
 
Registered: Dec 2009
Distribution: Slackware 14
Posts: 282

Rep: Reputation: 64
Quote:
Originally Posted by sycamorex View Post
I think it was snd-hda-intel but I am not at my computer now.
I blacklisted the 'snd-hda-intel' module in /etc/modprobe.d/blacklist.conf, and it removed the Nvidia card from Alsamixer, and now Im getting sound through Mpg123 audio player, which returned errors before the removal.

Audacious (my prefered audio player) still returns the 'invalid argument' error, so I think that is particular to audacious. I'll try upgrading it to the latest version.

Thanks sycamorex and RJwen.
 
Old 10-08-2012, 09:31 PM   #10
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Hi Clifford,

Keep us updated

Cheers...

RJ
 
Old 10-09-2012, 05:21 AM   #11
clifford227
Member
 
Registered: Dec 2009
Distribution: Slackware 14
Posts: 282

Rep: Reputation: 64
Quote:
Originally Posted by RJwen View Post
Hi Clifford,

Keep us updated

Cheers...

RJ
I upgraded to Audacious 3.3.2, and I no longer get the error message, and it is able to play sound.

The difficulty in diagnosing where the problem lay with Audacious, was that certain settings in Audacious 3.3.1 (slackware 14 version) preferences may not have been set correctly.

The 'PCM device', the 'Mixer device', and the 'Mixer element', seem to have changed from what I normally have to set for Audacious to output sound.

But Audacious 3.3.2 is outputting sound

Last edited by clifford227; 10-09-2012 at 05:22 AM.
 
Old 10-13-2012, 08:21 AM   #12
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Hi Clifford,

Good to hear that it's working for you!

I'm closing this thread as SOLVED.

Cheers...

RJ
 
1 members found this post helpful.
Old 02-19-2013, 12:40 PM   #13
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Rep: Reputation: 7
Quote:
Originally Posted by Alien Bob View Post
If you really need alsaconf, I have saved a copy of the script here: http://www.slackware.com/~alien/tools/alsaconf

Just stick it in /usr/local/sbin and make it executable.

Eric
Is there a way to do this without this script? As a matter of fact, there is no such file in Slackware 14, i would like to know what to do in "new" way of Slackware 14. I have exacly the same problem just like in post one: two soundcard that are switched on every boot.

I would like to learn the "new" way of setting things in 14 - there is no alsaconf command, was removed, there is no script so i would like to learn and know what to do in this way, where there are no script and alsaconf command.
 
Old 04-08-2013, 12:05 AM   #14
mshlinux
Member
 
Registered: Mar 2013
Posts: 92

Rep: Reputation: Disabled
Quote:
Originally Posted by clifford227 View Post
I blacklisted the 'snd-hda-intel' module in /etc/modprobe.d/blacklist.conf, and it removed the Nvidia card from Alsamixer, and now Im getting sound through Mpg123 audio player, which returned errors before the removal.

Audacious (my prefered audio player) still returns the 'invalid argument' error, so I think that is particular to audacious. I'll try upgrading it to the latest version.

Thanks sycamorex and RJwen.
how to blacklist HDA intel. i don't have blacklist.conf file in the /etc/modprobe.d directory.
i have the same problem...
 
Old 04-08-2013, 02:03 AM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,438

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
To blacklist the snd-hda-intel kernel module, as root,
Code:
echo "blacklist snd-hda-intel" >> /etc/modprobe.d/blacklist.conf
then reboot to test.
 
1 members found this post helpful.
  


Reply

Tags
audio, driver, modprobe, slackware 14


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manually bring up network interface every time mahmoodn Ubuntu 8 11-25-2010 01:13 AM
Need to run 'alsaconf' at every boot, even with 'alsactl store'. wtn2die Linux - Hardware 7 03-12-2010 01:48 AM
LXer: Report: Bring Order to Your Open Source LXer Syndicated Linux News 0 07-05-2007 05:31 PM
Bring order to Linux How-tos oudent Linux - General 7 01-25-2004 06:49 PM
Where is 'init' run from? (slackware 9.0) itsjustme Slackware 12 05-18-2003 03:14 PM


All times are GMT -5. The time now is 07:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration