LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14: Always need to run alsactl init manually in order to bring live Audio? (http://www.linuxquestions.org/questions/slackware-14/slackware-14-always-need-to-run-alsactl-init-manually-in-order-to-bring-live-audio-4175430976/)

RJwen 10-07-2012 12:14 PM

Slackware 14: Always need to run alsactl init manually in order to bring live Audio?
 
Hi all Slackers,

Just updated Slackware from 13.37 to 14 a few days ago.

Alsaconf is gone. Now it appears that I have to run
#alsactl init
manually everytime after login to KDE, else it will be no sound.

#alsactl store after setting #alsamixer and run #alsactl init also doesn't make any differences.

I tried to put alsactl init command into rc.local but without result.

I tried to create /etc/modprobe.d/snd-hda-intel.conf and put the content (a line):
options snd-hda-intel model=auto
I changed the model= to several type (referring to /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt )
This also fails to bring the sound automatically.

Additionally, my KDE keeps asking (pop-up after login):
KDE detected that one or more internal devices were removed.
Do you want KDE to permanently forget about these devices?
This is the list of devices KDE thinks can be removed:
Capture: HDA Intel (ALC269 Analog)
Output: HDA Intel (ALC269 Analog)
Output: HDA Intel, ALC269 Analog (Default Audio Device)

What is happening actually? I think it might be a failure of modprobe. Anyone having the same problem ?

Last time after the initial install of 13.37, I just ran alsaconf once, and the audio is active everytime. Now I have to manually run alsactl init everytime after login into KDE.

Cheers....

RJ :)

Alien Bob 10-07-2012 01:46 PM

If you really need alsaconf, I have saved a copy of the script here: http://www.slackware.com/~alien/tools/alsaconf

Just stick it in /usr/local/sbin and make it executable.

Eric

RJwen 10-07-2012 10:31 PM

Hi Eric,

It didn't occur to me before to use alsaconf as I tried to make everything works by the standard of Slackware 14, but your advice works like charm.

I'm still wondering what is happening with that alsactl init thingy though.

But I'm a happy person now thanks to you Eric :)

Cheers....

RJ

clifford227 10-08-2012 06:42 AM

Im having a problem with sound too.

For me, there seems to be some conflict between the pci sound card and the NVIDIA graphics card (with HDA? audio), as when both are plugged in together, I can play video with sound through mplayer, but when I try to play mp3's with an audio player I get:

Quote:

ALSA error: snd_mixer_find_selem failed

ALSA error: snd_pcm_hw_params_set_format failed : Invalid argument
If I take out the video card, I can play mp3's with the correct driver for the sound card.

I've tried Alienbobs alsaconf script, but it reports:

Quote:

No supported PnP or PCI card found
ALSA mixer shows that the pci soundcard is being selected, but I still get the invalid argument error above.

Running 'alsactl init' I get these messages:

Quote:

/usr/share/alsa/init/00main:34: invalid filename '/usr/share/alsa/init/ca0106
Found hardware: "CA0106" "CA0106" "" "ox1102" 0x100a"
Hardware is intialized using a generic method
Ive also created an /etc/modprobe.d/alsa.conf, with the following line:

Quote:

options snd-hda-intel model=auto
Any help to get sound work would be appreciated.

RJwen 10-08-2012 07:36 AM

Hi Clifford,

your trouble seems deeper than mine.

Is Slackware 14 your first slackware install ?

Does everything run smoothly using 13.37 before ?

Cheers...

RJ

sycamorex 10-08-2012 07:40 AM

I had the same problem, Clifford. I blacklisted the module which fixed the problem.

clifford227 10-08-2012 07:55 AM

Quote:

Originally Posted by RJwen (Post 4800145)
Hi Clifford,

your trouble seems deeper than mine.

Is Slackware 14 your first slackware install ?

Does everything run smoothly using 13.37 before ?

Cheers...

RJ

RJwen,

My last install was Slack 12.2 which I ran up untill last week, and it run both the sound card and the Nvidia graphics card in tandem with no problems.


Quote:

Originally Posted by sycamorex
I had the same problem, Clifford. I blacklisted the module which fixed the problem.

Which module was that sycamorex?

sycamorex 10-08-2012 08:02 AM

I think it was snd-hda-intel but I am not at my computer now.

clifford227 10-08-2012 09:21 AM

Quote:

Originally Posted by sycamorex (Post 4800165)
I think it was snd-hda-intel but I am not at my computer now.

I blacklisted the 'snd-hda-intel' module in /etc/modprobe.d/blacklist.conf, and it removed the Nvidia card from Alsamixer, and now Im getting sound through Mpg123 audio player, which returned errors before the removal.

Audacious (my prefered audio player) still returns the 'invalid argument' error, so I think that is particular to audacious. I'll try upgrading it to the latest version.

Thanks sycamorex and RJwen.

RJwen 10-08-2012 10:31 PM

Hi Clifford,

Keep us updated :)

Cheers...

RJ

clifford227 10-09-2012 06:21 AM

Quote:

Originally Posted by RJwen (Post 4800845)
Hi Clifford,

Keep us updated :)

Cheers...

RJ

I upgraded to Audacious 3.3.2, and I no longer get the error message, and it is able to play sound.

The difficulty in diagnosing where the problem lay with Audacious, was that certain settings in Audacious 3.3.1 (slackware 14 version) preferences may not have been set correctly.

The 'PCM device', the 'Mixer device', and the 'Mixer element', seem to have changed from what I normally have to set for Audacious to output sound.

But Audacious 3.3.2 is outputting sound :)

RJwen 10-13-2012 09:21 AM

Hi Clifford,

Good to hear that it's working for you!

I'm closing this thread as SOLVED.

Cheers... :)

RJ

firekage 02-19-2013 01:40 PM

Quote:

Originally Posted by Alien Bob (Post 4799552)
If you really need alsaconf, I have saved a copy of the script here: http://www.slackware.com/~alien/tools/alsaconf

Just stick it in /usr/local/sbin and make it executable.

Eric

Is there a way to do this without this script? As a matter of fact, there is no such file in Slackware 14, i would like to know what to do in "new" way of Slackware 14. I have exacly the same problem just like in post one: two soundcard that are switched on every boot.

I would like to learn the "new" way of setting things in 14 - there is no alsaconf command, was removed, there is no script so i would like to learn and know what to do in this way, where there are no script and alsaconf command.

mshlinux 04-08-2013 01:05 AM

Quote:

Originally Posted by clifford227 (Post 4800215)
I blacklisted the 'snd-hda-intel' module in /etc/modprobe.d/blacklist.conf, and it removed the Nvidia card from Alsamixer, and now Im getting sound through Mpg123 audio player, which returned errors before the removal.

Audacious (my prefered audio player) still returns the 'invalid argument' error, so I think that is particular to audacious. I'll try upgrading it to the latest version.

Thanks sycamorex and RJwen.

how to blacklist HDA intel. i don't have blacklist.conf file in the /etc/modprobe.d directory.
i have the same problem...

allend 04-08-2013 03:03 AM

To blacklist the snd-hda-intel kernel module, as root,
Code:

echo "blacklist snd-hda-intel" >> /etc/modprobe.d/blacklist.conf
then reboot to test.


All times are GMT -5. The time now is 03:07 PM.