LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware 14.1 from current tree 10/23 - kernel 3.10.17 bug (nouveau) (http://www.linuxquestions.org/questions/slackware-14/slackware-14-1-from-current-tree-10-23-kernel-3-10-17-bug-nouveau-4175481991/)

marbangens 10-24-2013 07:32 AM

slackware 14.1 from current tree 10/23 - kernel 3.10.17 bug (nouveau)
 
hi, I tested an home made iso from the current slackware tree. when I booted from the dvd there was no framebuffer console. Then I installed lilo and got nouveau and errors from the dmesg command. Now that I compiled the 3.4.67 kernel all is fine. The 3d grafik is now faster (KDE) and there is no nouveau boot errors. I will go back to slackware 14.0 and give you some log files later. ;) Im ready to test 14.1 agin before its released. Have a nice day!! Happy Haloween!!! :)

Didier Spaier 10-24-2013 12:27 PM

I have an up to date -current installed with a nVidia card using nouveau and that works.

To try narrowing down the issue, please send output of
Code:

/sbin/lspci -vnn | grep -A10 VGA
and the error messages you had in dmesg.

That could possibly help debug something before release of Slackware-14.1

GazL 10-24-2013 01:27 PM

Mine also seems to be working well, apart from glxgears thinking I'm "GLXVBlank true" when I'm clearly not.

gegechris99 10-24-2013 02:10 PM

Quote:

Originally Posted by Didier Spaier (Post 5051621)
To try narrowing down the issue, please send output of
Code:

/sbin/lspci --vnn | grep -A10 VGA

The correct syntax would be

Code:

/sbin/lspci -vnn | grep -A10 VGA
;)

By the way, here the nouveau driver is working fine with latest Slackware-current 32bit edition (at time of writing):

Code:

$/sbin/lspci -vnn | grep -A10 VGA
00:12.0 VGA compatible controller [0300]: NVIDIA Corporation C67 [GeForce 7000M / nForce 610M] [10de:0533] (rev a2) (prog-if 00 [VGA controller])
        Subsystem: Acer Incorporated [ALI] Device [1025:0126]
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17
        Memory at f1000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at f2480000 [disabled] [size=128K]
        Capabilities: [48] Power Management version 2
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Kernel driver in use: nouveau
        Kernel modules: nvidiafb, nouveau


Didier Spaier 10-24-2013 02:19 PM

Quote:

Originally Posted by gegechris99 (Post 5051678)
The correct syntax would be

Code:

/sbin/lspci -vnn | grep -A10 VGA

Thanks, typo corrected.

marbangens 10-25-2013 09:51 AM

1 Attachment(s)
sorry for the delays
Code:

bash-4.2# /sbin/lspci -vnn | grep -A10 VGA
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation C77 [GeForce 8200M G] [10de:0845] (rev a2) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device [103c:360a]
        Flags: bus master, fast devsel, latency 0, IRQ 19
        Memory at c1000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at c4000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4000 [size=128]
        [virtual] Expansion ROM at c6000000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Kernel driver in use: nouveau


marbangens 10-25-2013 10:02 AM

KDE doesn't feel slow with the 3.10.17 kernel anymore. But the error messages are still there. But the main problem is that I don't get nouveau to sett up the frame buffer console when using the live intsall iso as a boot loader, (boot into the localy installed system from usb)

marbangens 10-25-2013 10:06 AM

do you want me to boot from the usb into the hard drive and get the dmesg from there too?

Didier Spaier 10-25-2013 11:50 AM

In dmesg output we see that handover doesn't occur as ther is no line like these (e.g.)
Code:

Console: switching to colour frame buffer device 160x64
fb0: nouveaufb frame buffer device

About the error messages like this one:
Code:

[    5.770816] nouveau E[    PBUS][0000:02:00.0] MMIO read of 0x00000008 FAULT at 0x100238
I have no clue.

Still you can use kernel 3.4.6n on Slackware-14.1 as you know, a config file for it being provided in /testing. As kernel version is somehow frozen for 14.1 now and if you suspect a regression in nouveau support, I'd suggest you investigate further with help of this page and possibly file a bug.


All times are GMT -5. The time now is 02:26 PM.