LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-23-2014, 03:28 AM   #1
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 380

Rep: Reputation: 37
Slackware 14.1: Either KLauncher is not running


My environment is this

On my desktop I have a top panel with icons for a number of applications like - firefox, konsole, libreoffice, kontact etc.

What I'm about to describe can relate to any of them.

Starting about a week ago immediately after I log on and try to start an application, through the top panel, the system seems to hang and eventually after about 60 secs I get this message box appear, in this example I tried to start Kontact, could equally apply to Konsole, etc.

Quote:
Error launching
/usr/share/application/kde4/Kontact.desktop
Either KLauncher is not running anymore, or it failed to start the application
Equally I also get it on Konsole. Always the first application I try after a fresh login. Konsole and Kontact seem to my favourite Apps when I log on!

When I close the message box and try again everything seems to be fine and I can start any application. However, when I try and shut down and click the power icon nothing happens - no dialog appears. So to shut down the system I have to either switch user and force a power down through them. Or start konsole and switch to root and power down from the command line.

This problem effects other users on the system.

Any thoughts?

Alex
 
Old 04-28-2014, 03:32 AM   #2
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 380

Original Poster
Rep: Reputation: 37
Well researching this seemed to indicate some sort or race was going on when the user was logging on to kde.

Eventually tracked it down to gkrellm which I'd only recently enabled to always start when I'd logged onto kde. Can't remember how I did this.

Anyway, I resolved it by

System Settings -> Startup & Shutdown -> Session Management

Then pushing the "Start with an empty session" radio button. It's been a few days since I did that and the problem hasn't reoccurred.

If time permits I might try to repeat the problem and raise a bug against kde.

Alex
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KLauncher could not be reached via D-Bus, What do I do?? tpsomers Linux - General 2 06-19-2008 08:05 AM
kmail issue-klauncher pbcartwright Linux - Software 0 09-04-2007 09:11 AM
kde applications without klauncher alexrait1 Debian 5 12-05-2006 03:57 PM
klauncher error Valkyrie_of_valhalla Linux - Software 10 07-29-2006 02:14 AM
HELP! klauncher failing... lhoff Linux - Software 1 05-17-2002 08:03 PM


All times are GMT -5. The time now is 07:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration