LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14.1: Either KLauncher is not running (http://www.linuxquestions.org/questions/slackware-14/slackware-14-1-either-klauncher-is-not-running-4175502662/)

aikempshall 04-23-2014 03:28 AM

Slackware 14.1: Either KLauncher is not running
 
My environment is this

On my desktop I have a top panel with icons for a number of applications like - firefox, konsole, libreoffice, kontact etc.

What I'm about to describe can relate to any of them.

Starting about a week ago immediately after I log on and try to start an application, through the top panel, the system seems to hang and eventually after about 60 secs I get this message box appear, in this example I tried to start Kontact, could equally apply to Konsole, etc.

Quote:

Error launching
/usr/share/application/kde4/Kontact.desktop
Either KLauncher is not running anymore, or it failed to start the application
Equally I also get it on Konsole. Always the first application I try after a fresh login. Konsole and Kontact seem to my favourite Apps when I log on!

When I close the message box and try again everything seems to be fine and I can start any application. However, when I try and shut down and click the power icon nothing happens - no dialog appears. So to shut down the system I have to either switch user and force a power down through them. Or start konsole and switch to root and power down from the command line.

This problem effects other users on the system.

Any thoughts?

Alex

aikempshall 04-28-2014 03:32 AM

Well researching this seemed to indicate some sort or race was going on when the user was logging on to kde.

Eventually tracked it down to gkrellm which I'd only recently enabled to always start when I'd logged onto kde. Can't remember how I did this.

Anyway, I resolved it by

System Settings -> Startup & Shutdown -> Session Management

Then pushing the "Start with an empty session" radio button. It's been a few days since I did that and the problem hasn't reoccurred.

If time permits I might try to repeat the problem and raise a bug against kde.

Alex


All times are GMT -5. The time now is 04:50 AM.