LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-03-2014, 05:26 AM   #1
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,960

Rep: Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976
Slackware 14.1: copy/paste with Vim in Xfce Terminal


Hi,

I'm running Slackware64 14.1 + Xfce on my main workhorse PC. I've noticed an annoying change in Vim's behaviour, or maybe it's Xfce's terminal. I can't seem to copy/paste text from another application into Vim. Right now I have Firefox open, and I want to copy/paste text from a webpage into Vim. There's no way to do this.

Anyone knows what's wrong?
 
Old 01-03-2014, 07:09 AM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,121

Rep: Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819
It works for me (64-bit, 14.1, Xfce). I just highlight a bunch of text in some other window, do insert in vim, center click and there it is (sometimes I do have to right click in the source and copy then right click and paste in vim, though, don't know why that is).

I do that sort of thing all the time between Google search and Google Translate then copy-paste into the editor without any problem. The only thing that's goofy now an again is that because I always have autoindent set in ~/.exrc and that can get messy but otherwise no problems.
 
Old 01-03-2014, 08:20 AM   #3
arsivci0
Member
 
Registered: Nov 2013
Location: Antalya
Distribution: Slackware64 14.1
Posts: 84

Rep: Reputation: 10
No problems, here. Vim ver: 7.4.50, 14-1 64bit.
 
Old 01-03-2014, 09:25 AM   #4
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 736

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
This is slightly Off Topic but should be of considerable interest to those who love VIM.

http://www.youtube.com/watch?feature...&v=aHm36-na4-4

I had read that Stallman surfs the web with Emacs but I still had no idea just how powerful and varied vim can be even after more than 10 years experience. Enjoy!

Last edited by enorbet; 01-03-2014 at 09:26 AM.
 
1 members found this post helpful.
Old 01-03-2014, 10:31 AM   #5
bosth
Member
 
Registered: Apr 2011
Posts: 235

Rep: Reputation: 68
If you are using gvim/qvim, you can use 'p' to paste when you have:
Code:
set clipboard=unnamed
 
Old 01-03-2014, 11:12 AM   #6
xflow7
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 161

Rep: Reputation: 21
If you're trying to use 'p' or 'P' to paste from the clipboard ("+) into Vim running in the terminal window, you'll need to rebuild Vim to be X-aware by removing the --without-x option in vim.SlackBuild. That is, replace

Code:
config_vim --without-x --disable-gui
with

Code:
config_vim --disable_gui
This isn't new with 14.1, though.

Dave
 
Old 01-03-2014, 11:57 AM   #7
TracyTiger
Member
 
Registered: Apr 2011
Location: California, USA
Distribution: Slackware
Posts: 304

Rep: Reputation: 77
Use Window Edit Functions

This doesn't answer your question, but just some information on how I handle it....

I find that keyboard commands sometimes don't work when copying from a graphics application and pasting into VIM. If I use COPY from the EDIT menu found in most graphic applications, then use the PASTE selection of the EDIT menu in the Xfce Terminal Emulator it works 99%-100% of the time.

Before I paste into VIM I open a new line for input ('o' command) then do the paste.

I don't copy/paste very many times a week so this process works for me. Because I'm using this "window menu based solution" I haven't noticed any changes that may have occurred in the last couple of years. I'm currently using Slack64-14.0.

EDIT: You may want to try the copy/paste on different web pages in case the problem is just with one site. I believe a web page can be constructed to make text unselectable. For example, the old trick of placing a single transparent pixel on top of an item on the page.

Last edited by TracyTiger; 01-03-2014 at 12:28 PM. Reason: Web Page Restrictions
 
Old 01-03-2014, 05:16 PM   #8
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with KDE
Posts: 246

Rep: Reputation: 33
in XFCE terminal you'll need to press shift+ctrl+v in order to paste. Or right click and select paste.
 
1 members found this post helpful.
Old 01-03-2014, 08:06 PM   #9
dugan
Guru
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 5,002

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
The first thing I do in a new Slackware installation is rebuild vim with the "--with-x" flag. And with Ruby support.
 
Old 01-04-2014, 03:44 AM   #10
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,960

Original Poster
Rep: Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976Reputation: 976
Quote:
Originally Posted by Bertman123 View Post
in XFCE terminal you'll need to press shift+ctrl+v in order to paste. Or right click and select paste.
Right click context menu seems to be deactivated in Vim. But the keyboard shortcut worked!

Thanks very much everybody. Problem solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vi/vim copy and paste from another editor. theKbStockpiler Linux - General 9 09-23-2011 07:20 PM
[SOLVED] Can't copy-paste from one terminal to another using vim cola Slackware 11 12-18-2009 11:51 PM
copy-paste in vim proNick Linux - Newbie 5 02-17-2008 08:29 PM
How to copy paste into VIM ? EAD Linux - Software 15 12-12-2006 07:38 PM
Buggy copy n paste with vim in terminal Kovacs Slackware 1 09-05-2006 01:13 AM


All times are GMT -5. The time now is 08:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration