LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14.1 64bit on Acer Apire V3 - no display after boot (http://www.linuxquestions.org/questions/slackware-14/slackware-14-1-64bit-on-acer-apire-v3-no-display-after-boot-4175498706/)

botzko 03-19-2014 05:33 AM

Slackware 14.1 64bit on Acer Apire V3 - no display after boot
 
Hello,
I bought new laptop and try to install 14.1 on it. Laptop is with SSD (using GPT) and HDD (using MBR) so I decide to use LVM.
  1. /dev/sda1 - /boot (no lvm)
  2. /dev/sda2 - / (lvm /dev/system/root)
  3. /dev/sdb1 - different lvm for swap, /var /tmp /home (/dev/data/XXX)

After boot I used `mkinitrd_command_generator.sh` to create initrd disk. Suggested modules were 'mbcache:jbd2:ext4'. On lilo.conf `vga` is set to `normal`. On lilo execution I receive:
Quote:

Warning :LBA32
Warning: Unable to determine video adapter in use in the present system.
Warning: Video adapter does not support VESA BIOS extensions needed for display of 256 colors. Boot loader will fall back to TEXT only operation.
After reboot I can see linux start to load but on some point display go black. Only hdd led flash (1-2 times on a second). If I press a button hdd led stay turned on for some time. I can press Ctrl+Alt+Del and laptop is restarted after some time.

Did I miss something (do I need to add some video driver in initrd disk)?

P.S. Video is Nvidia GT 750M. Used generic kernel.

bmarley83 03-19-2014 01:11 PM

Hope this helps.
 
I got this from Dugen Chen's website ----> http://duganchen.ca/writings/slackware/setup/

"Setting the Console Video Mode

If you’re lucky, your video card might support a VESA video mode in your monitor’s native resolution. That will allow you to use a framebuffer in that resolution.

Go to SlackBuilds.org and install hwinfo. Then enter the following as root:

hwinfo --framebuffer

It will print out a list of VESA video modes that you can set your Linux console to. For example:

Mode 0x0361: 1280x800 (+5120), 24 bits

The important parts are self explanatory: the mode number, which starts with 0x, the width and height, and the number of colors.

If I have a 1280800 monitor and I like the mode above, I would edit lilo.conf and change the vga setting to 00361.

If you don’t see a mode appropriate for your monitor, then just set vga=normal. It’s faster."

Maybe if you use the hex code in lilo it will work?

TobiSGD 03-19-2014 01:20 PM

Don't use the vga= setting to set the resolution, that was deprecated when drivers switched to KMS, use the video= setting, for example
Code:

video=1024x768@60
for a resolution of 1024x768 at 60 Hz refresh rate. In any case, since the GT750 is quite new and the nouveau driver does not support that card very well I would recommend to install the proprietary driver.

botzko 03-19-2014 05:47 PM

Here you can see the logs from boot:
  1. dmesg
  2. messages
  3. syslog

there I found this
Quote:

[ 10.013937] Console: switching to colour frame buffer device 240x67
[ 10.022980] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 10.023021] i915 0000:00:02.0: registered panic notifier
[ 10.023476] i915 0000:00:02.0: More than 8 outputs detected
So I have second video card (VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller rev 06) and 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] rev a1.

I add `nomodeset` option on boot and no more blank screen. At this moment nvidia card is not used (no nvidia logo on X startup).

Is it possible to switch between cards for power save and performance? How to force to use nvidia card instead of intel card?

P.S. I install nvidia drivers 331.49 as suggested. Try to use `video=1024x768@60` but lilo does not recognize `video` so I continue using `vga = normal`.

TobiSGD 03-19-2014 06:17 PM

The nomodeset option will prevent the free drivers (Intel and Nvidia) from working properly. Also (I should have mentioned that), the video= option is not a Lilo option, but needs to be used in conjunction with the append option.
If you have Intel and Nvidia graphics you should use the latest proprietary driver together with Bumblebee for switching graphics.
http://docs.slackware.com/howtos:har...nvidia_optimus

botzko 03-21-2014 05:31 PM

Thank you for your answers. I use the HOWTO to install bumblebee.

About the black screen after reboot - I compile kernel 3.13.6 (current stable) and now I have no problem with the black screen.


All times are GMT -5. The time now is 09:40 PM.