LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-12-2014, 06:23 AM   #1
glupa4e
Member
 
Registered: Jan 2011
Posts: 96

Rep: Reputation: 0
Unhappy Slackware 14.1 64 - Logitech Performance MX is not working plug and play


Hello,

i have one mouse - Logitech Performance MX. i am trying to use it under Slackware but it is not working plug and play. i plugged the receiver in the USB and the mouse cursor is not moving when i switch the mouse on. This is a wireless mouse.

dmesg output:
Code:
[ 1434.359730] usb 1-2: USB disconnect, device number 5
[ 1440.655458] usb 1-2: new full-speed USB device number 6 using xhci_hcd
[ 1440.669342] usb 1-2: New USB device found, idVendor=046d, idProduct=c52b
[ 1440.669347] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1440.669350] usb 1-2: Product: USB Receiver
[ 1440.669352] usb 1-2: Manufacturer: Logitech
[ 1440.674939] logitech-djreceiver 0003:046D:C52B.0009: hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-2/input2
Code:
# lsusb
Bus 001 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 04b3:301a IBM Corp. 
Bus 001 Device 003: ID 09da:000e A4 Tech Co., Ltd X-F710F Optical Mouse 3xFire Gaming Mouse
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04b3:301b IBM Corp. SK-8815 Keyboard
Bus 003 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 003 Device 004: ID 064e:8126 Suyin Corp.
Is there a possibility to get this mouse working under Slackware?

Thank you!
 
Old 04-12-2014, 10:37 AM   #2
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,060

Rep: Reputation: Disabled
Make sure the mouse is fully charged and have only one mouse plugged in at once. I have an older version of this mouse and it works fine, except the batteries don't work too well anymore.
 
Old 04-12-2014, 10:53 AM   #3
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,225

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by metaschima View Post
Make sure the mouse is fully charged and have only one mouse plugged in at once. I have an older version of this mouse and it works fine, except the batteries don't work too well anymore.
Ditto. Mine has worked for many years. Just plug and play.

Edit: BTW, if and when the rechargeable batteries or the charger stand get flaky, you can use conventional AA batteries (or invest in some new rechargeable batteries).

Last edited by cwizardone; 04-12-2014 at 11:15 AM.
 
Old 04-12-2014, 11:17 AM   #4
neymac
Member
 
Registered: May 2009
Distribution: Slackware64-14.0
Posts: 116

Rep: Reputation: 12
I use this mouse with Slackware. Did you try it on other computer or the same computer with other OS? Try load one LiveCD distribution or Live USB, then you'll see if the problem is the mouse or your Slackware configuration. To use mine I'd just plugged it.

Last edited by neymac; 04-12-2014 at 11:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Logitech c270 webcam Dell Vostro 410 Slackware 13.37 Skype microphone not working rhamel Linux - General 2 09-21-2012 06:36 AM
Logitech G15 under Slackware 11, g15daemon not working. dangerboy Linux - Hardware 6 04-29-2007 04:38 AM
Logitech USB Mouse Wheel not working on Slackware 9.1 Ken Ju-On Linux - Hardware 9 04-11-2004 10:39 PM
Slackware Plug and Play animeresistance Slackware 2 02-05-2004 02:25 PM
Slackware 9.0 Plug and Play? shilivan Linux - Newbie 3 10-17-2003 04:35 PM


All times are GMT -5. The time now is 03:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration