LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14.0 rc3 and virtualbox (http://www.linuxquestions.org/questions/slackware-14/slackware-14-0-rc3-and-virtualbox-4175424258/)

StreamThreader 08-27-2012 01:16 PM

Slackware 14.0 rc3 and virtualbox
 
Hello!
I install slackware 14 rc3 in virtualbox from opensourcelab rsync mirror.
create /etc/X11/xorg.conf.d/disable-composite.conf
add
Section "Extensions"
Option "Composite" "Disable"
EndSection
But KDE not load, kwin bugreport.
Under user account and from root.

EDDY1 08-27-2012 03:48 PM

my kde errored / full (low disk space) if you used default 8gig that's most ikely problem.

StreamThreader 08-28-2012 02:39 AM

This problem fix in next Release Candidate ?

vharishankar 08-28-2012 02:43 AM

deleted.

ppr:kut 08-28-2012 02:50 AM

That's not something that can be fixed in Slackware, it's something that should be fixed in VirtualBox.

Quote:

I install slackware 14 rc3 in virtualbox from opensourcelab rsync mirror.
create /etc/X11/xorg.conf.d/disable-composite.conf
add
Section "Extensions"
Option "Composite" "Disable"
EndSection
I doubt this is sufficient. The problem is that kde on startup checks the capabilities of the graphics driver in use. That check somehow crashes kwin, so you have to disable the check.
You can do this by putting:

Quote:

[Compositing]
OpenGLIsUnsafe=true
into ~/.kde/share/config/kwinrc for every user or globally into /usr/share/config/kwinrc

Habitual 08-28-2012 07:38 AM

Steps I used are here...
I'm fairly certain it was from the 4.x series of Vbox and a non-Slackware OS with KDE.
I can't remember ever having to run the command since.

Sorry, not much help otherwise.
Have a Great Day!

lemmens 08-28-2012 08:07 AM

Kwin keeps crashing in Slackware 14 RC3
 
Hi,

I have a similar problem both in KVM and Virtualbox. However, I also tried to use a remote X session with XDMCP and Xephyr on a real computer and see the same problem there , so I don't think Compositing (detection) is the problem here.

My five cents ...


All times are GMT -5. The time now is 11:44 PM.