LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-17-2013, 10:19 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Slackware 14.0 on vintage hardware


I'm tinkering with Slackware 14.0 on a PI and PII class machine. I'm using the generic 3.2.29 kernel (not smp) and an initrd with both. Both systems share a 1280x1024 17" LCD monitor through a KVM.

K6-III+ system:

1. Sound won't autoconfigure. The sound card is a Creative Labs Sound Blaster AWE64 ISA Plug and Play sound card. The card autoconfigured in Slackware 13.1. The 14.0 dmesg log indicates the card is recognized:

[ 1.056321] isapnp: Scanning for PnP cards...
[ 1.178596] 00:01: card 'Creative SB AWE64 PnP'
[ 1.178611] isapnp: 1 Plug & Play card detected total

The problem is the snd-sbawe module not loading automatically. I added 'modprobe snd-sbawe' to rc.modules and then sound, rc.alsa, alsactrl init all work. Is there a udev rule not working correctly to cause the sound module not to load?

2. I can't disable kernel mode set. As soon as udev triggers the console font gets way too small (1280x1024?). Adding the nomodeset boot option does not help. Adding vga=normal does not help. The video card is a Diamond Stealth 3D 3000 PCI video card S3 ViRGE/VX. I've tried some different boot options but nothing seems to work. In the past I never was able to use modeset on this system. I prefer having a smaller console text (1024x768?) but not this small.

PII system:

1. The PII system has an ACPI compliant PSU. I added the acpi=force boot option. The system powers down on its own but despite the boot option, I am unable to eliminate the associated ("BIOS age fails cutoff...") warning message when the system loads the initrd. Is there a way to disable the warning?

Otherwise both systems seem to be running fine under 14.0.

Thanks.
 
Old 02-17-2013, 10:29 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,650
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
Quote:
Originally Posted by Woodsman View Post
2. I can't disable kernel mode set. As soon as udev triggers the console font gets way too small (1280x1024?). Adding the nomodeset boot option does not help. Adding vga=normal does not help. The video card is a Diamond Stealth 3D 3000 PCI video card S3 ViRGE/VX. I've tried some different boot options but nothing seems to work. In the past I never was able to use modeset on this system. I prefer having a smaller console text (1024x768?) but not this small.
Normally nomodeset should work, but the vga= option is deprecated for KMS enabled drivers. Try it with the video= option, for example
Code:
video=1024x768@60
for a resolution of 1024x768 with a refresh rate of 60Hz.
 
Old 02-17-2013, 11:10 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
Try it with the video= option, for example
Been trying that to no avail. When rc.udev starts the boot option is ignored.
 
Old 02-17-2013, 11:54 PM   #4
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,947

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
Try video=1024x600 or video=800x600 without the @60.

Also, some video cards (like Intel) require including the kernel module (intel-agp, i915) into the initrd to work correctly. I know this is a long shot, but give it a try.
 
Old 02-18-2013, 11:34 AM   #5
philanc
Member
 
Registered: Jan 2011
Posts: 71

Rep: Reputation: 34
Thumbs up

Quote:
Originally Posted by Woodsman View Post
2. I can't disable kernel mode set. As soon as udev triggers the console font gets way too small (1280x1024?). Adding the nomodeset boot option does not help. Adding vga=normal does not help. The video card is a Diamond Stealth 3D 3000 PCI video card S3 ViRGE/VX. I've tried some different boot options but nothing seems to work. In the past I never was able to use modeset on this system. I prefer having a smaller console text (1024x768?) but not this small.
An alternative is to keep KMS doing its job and set a larger console font. You could get for example the Terminus fonts (very nice console fonts) and change console font at boot time (in rc.local) or at login time (.bash_profile for just the current VT):
Code:
 
  # for example set size 24:
  setfont /path/to/terminus/consolefonts/ter-124n.pcf.gz
For X, you could either use xrandr to change the resolution if needed, or play with the DPI to keep the best resolution and get larger system fonts.

HTH

Phil

Last edited by philanc; 02-18-2013 at 11:42 AM.
 
Old 02-18-2013, 01:06 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
Try video=1024x600 or video=800x600 without the @60.
Also, some video cards (like Intel) require including the kernel module (intel-agp, i915) into the initrd to work correctly. I know this is a long shot, but give it a try.
Thanks for the suggestions. I tried all of the above to no avail. The only thing that seems to work is the sledge hammer: blacklisting.

By the way the modules used s3fb and fb_ddc.

I found the source code for the s3fb module. I'm not a C coder but from what I see there are no options that could be used in a modprobe.d file. Seems the s3fb module is "all or nothing."

Interestingly, the PII, which uses the same monitor through a KVM, has none of these problems. Of course, that machine has a different video card but I don't see any framebuffer related module being loaded on that system.

Quote:
An alternative is to keep KMS doing its job and set a larger console font.
Good idea. I started tinkering with that last night, although I focused on the opposite direction: blacklisting the s3fb and fb_ddc modules and selecting a smaller font. The problem with that approach is all of the fonts are fixed width for a traditional 80 character wide VGA screen. In other words the fonts are not too appealing because the height changes but not the width.

I tried booting the system with the s3fb module enabled but the monitor powered off and the result was a screen that looked a lot like braille.

Yet even should I allow the s3fb module and find a larger console font, I noticed many times where the console screen simply disappeared. A simple ls command would result in a few lines and then the remainder of the screen was blank. Also the s3fb module seems to slow down screen response considerably. I thought this was my imagination until I started to successfully blacklist the module and then I noticed screen response was again snappy.

Quote:
For X, you could either use xrandr to change the resolution if needed, or play with the DPI to keep the best resolution and get larger system fonts.
X is not a problem, just the console framebuffer module.

I still haven't found any clues why the snd-sbawe module is not loading automatically.
 
Old 02-18-2013, 01:29 PM   #7
philanc
Member
 
Registered: Jan 2011
Posts: 71

Rep: Reputation: 34
Quote:
Originally Posted by Woodsman View Post
The problem with that approach is all of the fonts are fixed width for a traditional 80 character wide VGA screen. In other words the fonts are not too appealing because the height changes but not the width.
Maybe you tried all the unusual VGA modes (80xnn), then you didn't change the font (just used the same font with a different height/width ratio).

Maybe you tried some alternative fonts, as proposed in Slackware setup. Most of them are not better than the default font.

The Terminus fonts I suggested (size 24 or more) are just larger, with a correct height/width ratio, not flattened. On my PC, I use the size 14 which is closer to the PC default font. Just looking better.

Phil
 
Old 02-19-2013, 04:16 PM   #8
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
The s3fb module does not behave correctly, occasionally resulting in the common but annoying blank screen that often is reported with KMS problems. The console also responds much slower with the module. I would like to use smaller fonts but not at the expense of simple usability. Unless I discover specific configuration options for the s3fb module, I'll keep blacklisting.

I installed the terminus fonts but the only small fonts are 12 point and they won't load, resulting in a 'putfont: KDFONTOP: Invalid argument' error. I can setfont other terminus sizes.

The basic problem with smaller fonts is the fixed width VGA display. There are only a few VGA options, all of which other than normal look squished.

This is an older computer and not important. The original problem was to resolve how to stop the s3fb module from loading.
 
Old 02-19-2013, 04:33 PM   #9
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,656

Rep: Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233
Quote:
Originally Posted by Woodsman View Post
I found the source code for the s3fb module. I'm not a C coder but from what I see there are no options that could be used in a modprobe.d file.
From what "modinfo s3fb" says:
Code:
...
parm:           mode_option:Default video mode ('640x480-8@60', etc) (charp)
parm:           mode:Default video mode ('640x480-8@60', etc) (deprecated) (charp)
parm:           mtrr:Enable write-combining with MTRR (1=enable, 0=disable, default=1) (int)
parm:           fasttext:Enable S3 fast text mode (1=enable, 0=disable, default=1) (int)
may be you could try to set the mode_option parameter?
 
2 members found this post helpful.
Old 02-19-2013, 06:24 PM   #10
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
may be you could try to set the mode_option parameter?
Hey! That works!

I ended up using the following:

s3fb.mode_option=1024x768-8

That is the equivalent of vga=773.

I've only been using for less than an hour but the screen seems stable too.

Thank you!
 
Old 02-19-2013, 06:37 PM   #11
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,656

Rep: Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233
Quote:
Originally Posted by Woodsman View Post
I've only been using for less than an hour but the screen seems stable too.
I cross my fingers, hoping that this will last!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: SNA Is Doing Well For Vintage Intel Hardware LXer Syndicated Linux News 0 06-02-2012 06:50 PM
LXer: Five Updates For Vintage X.Org Drivers LXer Syndicated Linux News 0 05-13-2012 07:30 PM
Vintage Distros phantom_cyph General 10 03-01-2007 02:19 PM
Trying to locate some vintage mandrakes maclover2@mail.com Mandriva 3 05-20-2006 11:28 AM
RH 7.2 up2date probs on vintage PC CORMEAU Linux - Distributions 0 02-28-2002 01:35 PM


All times are GMT -5. The time now is 11:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration