LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14.0:No sound (http://www.linuxquestions.org/questions/slackware-14/slackware-14-0-no-sound-4175430985/)

mpregos 10-07-2012 12:15 PM

Slackware 14.0:No sound
 
Hi guys,

I done a clean install of Slackware 14 in my desktop and i have a problem with my onboard audio card.
Motherboard : Asus p5k
Audio card model : Realtek ALC 883, 8 -Channel High-Definition Audio CODEC

when i try to play from some kind of media player, e.g dragon,audacious xmms , complaint about : Couldn't open audio, Please check that : Your soundcard is configured properly mpla mpla mpla......
The problem is , that i don;t have any other process that use audio resources....(except if my ears have problem....;) )
This was not reproducible when i first boot.
I think, that the error initialized when tried to play a mp4 video that should had audio but unfortunately , Mplayer or Kplayer or Dragon failed to play audio.
From that moment , no audio with every media player in my desktop.

Here are some useful information :

Code:

bash-4.2# lsmod |grep snd
snd_seq_dummy          1119  0
snd_seq_oss            24956  0
snd_seq_midi_event      4568  1 snd_seq_oss
snd_seq                41599  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          4276  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            33254  0
snd_mixer_oss          12984  1 snd_pcm_oss
snd_hda_codec_realtek  150654  1
snd_hda_intel          19503  0
snd_hda_codec          70505  2 snd_hda_intel,snd_hda_codec_realtek
snd_hwdep              4802  1 snd_hda_codec
snd_pcm                59013  3 snd_hda_codec,snd_hda_intel,snd_pcm_oss
snd_page_alloc          5925  2 snd_pcm,snd_hda_intel
snd_timer              14798  2 snd_pcm,snd_seq
snd                    43657  11 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore              4570  1 snd

Code:

bash-4.2# lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
bash-4.2#

Code:

bash-4.2# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf9ff8000 irq 44
bash-4.2#

Code:

bash-4.2# lsmod |grep snd
snd_seq_dummy          1119  0
snd_seq_oss            24956  0
snd_seq_midi_event      4568  1 snd_seq_oss
snd_seq                41599  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          4276  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            33254  0
snd_mixer_oss          12984  1 snd_pcm_oss
snd_hda_codec_realtek  150654  1
snd_hda_intel          19503  0
snd_hda_codec          70505  2 snd_hda_intel,snd_hda_codec_realtek
snd_hwdep              4802  1 snd_hda_codec
snd_pcm                59013  3 snd_hda_codec,snd_hda_intel,snd_pcm_oss
snd_page_alloc          5925  2 snd_pcm,snd_hda_intel
snd_timer              14798  2 snd_pcm,snd_seq
snd                    43657  11 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore              4570  1 snd

I tried this solution but not helped.

Suggestions for how to fix this would be appreciated.

marnold 10-07-2012 12:46 PM

Is this just in KDE or in a console (not a Konsole)? Check to make sure your user is in the audio group (and probably plugdev too, I don't remember for sure).

mpregos 10-08-2012 10:11 AM

[Solved]Slackware 14.0:No sound
 
Marnold

you were right.
Somehow the user removed from groups - I add again in audio and plugdev. Reboot and voila....my old 4.1 speaker have life again.
In the dialog ,of inserting new user i remember that i had press up key in order to add the user in the default groups - I had sound when i first boot.
Mystery is how user removed from the groups????Any idea???


Note.In the meantime , between good and bad audio state i create the vboxuser groups and using usermod add user....

ponce 10-08-2012 10:15 AM

can it be you used usermod with the -G option? From "man usermod"
Code:

-G, --groups GROUP1[,GROUP2,...[,GROUPN]]]
          A list of supplementary groups which the user is also a member of. Each group is separated from the next by a comma, with no intervening whitespace. The groups are subject
          to the same restrictions as the group given with the -g option.

          If the user is currently a member of a group which is not listed, the user will be removed from the group. This behaviour can be changed via the -a option, which appends the
          user to the current supplementary group list.

as an habit, if I have to add an user to an additional group I use gpasswd
Code:

gpasswd -a myuser mygroup


All times are GMT -5. The time now is 11:04 PM.