LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-03-2012, 04:15 PM   #1
ve2tmq
LQ Newbie
 
Registered: Nov 2012
Posts: 3

Rep: Reputation: Disabled
Slackware 14.0 KDE keyboard layouts bug


Hi. I just reinstall my Slackware 13.37 to 14.0 (Format and reinstall, not just an upgrade). On 13.37 KDE Keyboard layout working good, I see flags on tray bar and can change layouts by clicking on it (layout US and CA). On 14.0 I try to config on KDE control pannel but flag doesn't appear on tray. I try to activate plugin (Keyboard layout), so I see flag, but could change by clicking on it.

When I right click and select configuration, I've got error : "Cannot load library /usr/lib/kde4/kcm_keyboard.so (/usr/lib/qt/lib/libQtWebKit.so.4: undifined symbol: get_x_overlay_set_window_handle)".

I find work around : on command line, I type : "setxkbmap -layout ca or setxkbmap -layout us". It's working good, and the flag on tray change to represent the current keyboard layout.

So, does any body have same issue as me? Did you find to correct it?

Thanks a lot.
 
Old 12-03-2012, 04:20 PM   #2
kabamaru
Member
 
Registered: Dec 2011
Location: Greece
Distribution: Slackware
Posts: 276

Rep: Reputation: 133Reputation: 133
I experienced the same issue, i.e. layout switcher not showing up (although I didn't have an error message). Logging out and back in, fixed it.
 
Old 12-03-2012, 09:41 PM   #3
ve2tmq
LQ Newbie
 
Registered: Nov 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Well, I tryed to logoff, logon, reboot... not success .
 
Old 12-04-2012, 03:34 AM   #4
kabamaru
Member
 
Registered: Dec 2011
Location: Greece
Distribution: Slackware
Posts: 276

Rep: Reputation: 133Reputation: 133
You could try deselecting "Configure Layouts" from KDE's settings (but leave "Show layout indicator" selected), and create a /etc/X11/xorg.conf.d/90-keyboard.conf file:

Code:
Section "InputClass"
  Identifier "Keyboard0"
  MatchIsKeyboard "on"
  MatchDevicePath "/dev/input/event*"
  Driver "evdev"
  Option "XkbLayout" "us,ca"
  Option "XkbOptions" "grp:alt_shift_toggle"
EndSection
as a workaround. If you already have an /etc/X11/xorg.conf file you can put the code there instead.

The error message you get sounds like a library incompatibility. Is this a vanilla full install of Slackware? I run Slackware 14.0 64bit on my machine and a 32bit virtual machine and cannot reproduce your error.
 
Old 12-04-2012, 07:41 PM   #5
ve2tmq
LQ Newbie
 
Registered: Nov 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Hi. I just found the solution. On my installation I keep /usr/local with old apps, libs and others. So they were conflict with new install. So I decide to clean /usr/local and reinstall apps and libs from sources, only for apps and libs neded.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 11 & 12 w/ fluxbox keyboard and mouse command bug Anithen Slackware 2 07-09-2008 12:51 AM
available keyboard layouts sinister035 Linux - Newbie 4 07-02-2007 05:11 AM
How to display keyboard layouts in KDE farpoint Linux - Desktop 0 06-09-2007 11:58 AM
Slackware 10.2 - a problem with keyboard layouts AndrewR Slackware 2 03-21-2006 04:22 AM
keyboard layouts misulo Fedora 0 08-17-2004 02:29 PM


All times are GMT -5. The time now is 10:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration