-   Slackware (
-   -   slackware 14.0/current dbus problem (

marbangens 09-09-2012 06:51 AM

slackware 14.0/current dbus problem
I have an full upgrade from 13.37 to current today 9 sep 2012.
I wana use NetworkManager for my xfce.
The upgrade was done with slackpkg and I ran slackpkg clean-system, upgrade-all and install-new before and after rebooting the new system.
also I did overwright .new to old config after the upgrade.

I get:
bash-4.2$ nm-applet

** (nm-applet:2245): CRITICAL **: dbus_set_g_error: assertion `gerror == NULL || *gerror == NULL' failed
Segmentation fault

and etc:
bash-4.2# find /etc | grep .new

has this something to do with the new passwd and shadow to do?

marbangens 09-09-2012 06:55 AM

also from starxfce:

(polkit-gnome-authentication-agent-1:2094): polkit-gnome-1-WARNING **: Unable to determine the session we are in: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '2094'

marbangens 09-09-2012 07:44 AM

I found this in /var/log/messages

Sep 9 13:31:09 compaq kernel: [ 138.199835] nm-applet[2089]: segfault at ffff3ff0 ip b646d6ae sp bf868950 error 4 in[b6

tpreitzel 09-26-2012 02:35 AM

Me, too, having problems with nm-applet in Slackware64-Current

nm-applet[7623]: segfault at d ip 00007ffd4ffdb13e sp 00007fff1d614cb0 error 4 in[7ffd4ff92000+1b3000]

sorinm 09-26-2012 05:10 AM

That`s a bug in NetworkManager and it isn`t Slackware related.

sorinm 09-26-2012 05:41 AM

Browsed and found out that NetworkManager 0.9.6 was released but was not announced on the first page.

Compiled this version with the Slackbuild provided in source and NetworkManager doesn`t segfault anymore.

Also a new version of nm-applet was available but NetworkManager 0.9.6 works just fine with nm-applet provided in -current.

From the changelog of NetworkManager 0.9.5

Overview of changes since NetworkManager-0.9.4

This is a new stable release of NetworkManager. Notable changes include:

* Many libnm-glib fixes, including crashes when NetworkManager restarts
* Enhanced IPv6 stability and compatibility
* Fix regression in carrier handling for devices that don't support carrier detect
* Add ability to connect to new WiFi networks from nmcli
* Add native support for ADSL modems using PPPoE or PPPoATM
* Reduce number of changes made to DNS information during connection setup
* Add support for IPv6-enabled VPN connections
* Add device driver version, firmware version, and autoconnect properties to D-Bus API
* Add on-demand WiFi scan support
* Fix IPv6 default gateway handling for DHCPv6
* Add Vala language bindings

It seems the segfault was fixed since 0.9.5

tpreitzel 09-29-2012 04:45 PM

It's unfortunate that Slackware is using this crappy & buggy software pushed by other vendors. Thankfully, it can be disabled ...

chrisretusn 09-29-2012 08:13 PM

Which crappy and buggy software? NetworkManager? It's working perfectly for me. On all of my Slackware Linux installations. This one I*am on now is a Toshiba Laptop.

marbangens 10-25-2012 12:33 PM

I think this problem is solved. For me, I use wicd now.
It works fine.

marnold 10-26-2012 07:32 PM

NetworkManager also works fine for me with a clean install of 14.0. No problems. My guess would be that it was from something in the upgrade process that got borked.

marbangens 10-27-2012 06:32 AM

Okej, I like NetworkManager more then wicd. I'll think I tray it out.
If I have have problems I will post here.

marbangens 10-27-2012 07:00 AM

It works perfectly with only some warnings outputted.
I don't mind, have a lot of those. :)

All times are GMT -5. The time now is 03:33 AM.