LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2013, 08:37 PM   #1
girvinh
Member
 
Registered: Mar 2011
Distribution: Slackware
Posts: 31

Rep: Reputation: 2
Slackware 14.0 Console changes setting during boot


Greetings,
I am trying to install Slackware 14.0 (32-bit) and I am having difficulty with the console setting. This is similar to an older thread titled "Frame Buffer Console", but different. I am using an ATI Radeon graphics card and the smp huge stock kernel. When I set up LILO in setup, I used the 1024x768x256 framebuffer mode (vga=773), which is the same as my Slack 12.2 setting, which does not exhibit this problem. The console initially gets set to the 80x25 framebuffer mode with Tux in the upper left corner, but partway through the boot, the screen blanks, comes back at 80x25 with a 2" offset to the right with no Tux, then switches to a much finer resolution, still with the 2" offset and no Tux. Looking at the dmesg file (below) indicates it switches to 160x64 from 80x25. This is way too small for my old eyes to see for long periods. The screen blanking is annoying, but I can live with it. Same with Tux disappearing.

How do I keep the 80x25 mode after boot and prevent the switch to 160x64?
Is there a boot-time configuration file, like xorg.conf, which controls the graphics driver setup?

Here is a snippet of my dmesg file:
---------------------------------------------------------------
....
[ 24.207652] Linux agpgart interface v0.103
[ 24.210585] agpgart: Detected VIA KT400/KT400A/KT600 chipset
[ 24.221870] agpgart-via 0000:00:00.0: AGP aperture is 128M @ 0xd0000000
[ 24.800252] WARNING! power/level is deprecated; use power/control instead
[ 24.963248] [drm] Initialized drm 1.1.0 20060810
[ 25.209999] snd_via82xx 0000:00:11.5: found PCI INT C -> IRQ 10
[ 25.210941] snd_via82xx 0000:00:11.5: sharing IRQ 10 with 0000:00:0f.0
[ 25.212061] snd_via82xx 0000:00:11.5: sharing IRQ 10 with 0000:00:10.2
[ 25.219726] snd_via82xx 0000:00:11.5: setting latency timer to 64
[ 25.237791] [drm] radeon defaulting to kernel modesetting.
[ 25.238018] [drm] radeon kernel modesetting enabled.
[ 25.240177] checking generic (d8000000 4000000) vs hw (d8000000 8000000)
[ 25.240183] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
[ 25.241174] Console: switching to colour dummy device 80x25
[ 25.243170] [drm] initializing kernel modesetting (RV100 0x1002:0x5159 0x148C:0x2030).
[ 25.243227] [drm] register mmio base: 0xE1000000
[ 25.243237] [drm] register mmio size: 65536
[ 25.244078] agpgart-via 0000:00:00.0: AGP 2.0 bridge
[ 25.244104] agpgart-via 0000:00:00.0: putting AGP V2 device into 4x mode
[ 25.244171] radeon 0000:01:00.0: putting AGP V2 device into 4x mode
[ 25.244186] radeon 0000:01:00.0: GTT: 128M 0xD0000000 - 0xD7FFFFFF
[ 25.244205] radeon 0000:01:00.0: VRAM: 128M 0x00000000D8000000 - 0x00000000DFFFFFFF (64M used)
[ 25.244230] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 25.244241] [drm] Driver supports precise vblank timestamp query.
[ 25.244269] [drm] radeon: irq initialized.
[ 25.244493] [drm] Detected VRAM RAM=128M, BAR=128M
[ 25.244520] [drm] RAM width 64bits SDR
[ 25.244668] [TTM] Zone kernel: Available graphics memory: 440312 kiB.
[ 25.244680] [TTM] Zone highmem: Available graphics memory: 503804 kiB.
[ 25.244691] [TTM] Initializing pool allocator.
[ 25.244758] [drm] radeon: 64M of VRAM memory ready
[ 25.244768] [drm] radeon: 128M of GTT memory ready.
[ 25.267075] radeon 0000:01:00.0: WB disabled
[ 25.268690] [drm] Loading R100 Microcode
[ 25.343654] [drm] radeon: ring at 0x00000000D0001000
[ 25.343699] [drm] ring test succeeded in 1 usecs
[ 25.344275] [drm] radeon: ib pool ready.
[ 25.344417] [drm] ib test succeeded in 0 usecs
[ 25.344609] input: ImExPS/2 Logitech Wheel Mouse as /devices/platform/i8042/serio1/input/input2
[ 25.349529] [drm] No TV DAC info found in BIOS
[ 25.349611] [drm] Radeon Display Connectors
[ 25.349620] [drm] Connector 0:
[ 25.349626] [drm] VGA
[ 25.349634] [drm] DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
[ 25.349644] [drm] Encoders:
[ 25.349651] [drm] CRT1: INTERNAL_DAC1
[ 25.349659] [drm] Connector 1:
[ 25.349665] [drm] S-video
[ 25.349671] [drm] Encoders:
[ 25.349677] [drm] TV1: INTERNAL_DAC2
[ 25.483460] [drm] fb mappable at 0xD8040000
[ 25.483488] [drm] vram apper at 0xD8000000
[ 25.483496] [drm] size 5242880
[ 25.483503] [drm] fb depth is 24
[ 25.483510] [drm] pitch is 5120
[ 25.485148] fbcon: radeondrmfb (fb0) is primary device
[ 25.642125] Console: switching to colour frame buffer device 160x64
[ 25.670446] fb0: radeondrmfb frame buffer device
[ 25.670599] drm: registered panic notifier
[ 25.675752] [drm] Initialized radeon 2.12.0 20080528 for 0000:01:00.0 on minor 0
....
------------------------------------------------------------
BTW: I am currently using 1280x1024 in X/KDE3 with Slackware 12.2. I would still like to have that resolution with Slackware 14.0 (KDE4).

Thanks in advance.
Girvin Herr
 
Old 03-18-2013, 08:41 PM   #2
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 861

Rep: Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680Reputation: 1680
See this thread:

http://www.linuxquestions.org/questi...er-4175454068/
 
1 members found this post helpful.
Old 03-19-2013, 08:49 PM   #3
girvinh
Member
 
Registered: Mar 2011
Distribution: Slackware
Posts: 31

Original Poster
Rep: Reputation: 2
Pat,
Thanks a lot for the lead. This got my console font to the point where I no longer need a magnifying glass to read it.

However, I still have the monitor screen shift of about 2 inches to the right, truncating display data on the right side. I may be able to manually adjust my monitor to shift it back to the left, but then the first part of the boot, before the Kernel Mode Setting (KMS) for my graphics card takes effect, would most likely be truncated on the left. I haven't tried that yet, since I am still toggling between the Slack 14.0 setup and my old Slack 12.2 system (separate removable hard drives) and I don't want to keep messing with my monitor adjustments each time I swap. How can I set up the KMS settings to the ATI Radeon driver to match the left margin?

I remember doing this with a previous xorg.conf setting for X, but I cannot find any information about a similar configuration file for the KMS modes passed to the ATI Radeon kernel driver. Nothing in the Slackware documentation on the DVD either. I tried the "vga=normal" option to LILO, but that only changed the pre-KMS display.

Thanks again for your help.
Girvin Herr
 
Old 03-19-2013, 10:09 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,530
Blog Entries: 2

Rep: Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024
For KMS drivers the "vga=" option is deprecated, you have to use the "video=" option instead, for example with "video=1024x768@60", which will give you a resolution of 1024 by 768 pixels with a refresh rate of 60Hz. Depending on your monitor you have to adjust those settings to something that you like/works better with your monitor.
 
Old 03-23-2013, 01:24 PM   #5
girvinh
Member
 
Registered: Mar 2011
Distribution: Slackware
Posts: 31

Original Poster
Rep: Reputation: 2
TobiSGD,
Sorry I didn't get back sooner. Life intervened and I only got to try your solution yesterday.
Thanks very much for your solution about using "video=". It worked perfectly. Now the boot text is all the same readable font, the screen shift to the right is gone, and the after-boot console text is fine. It looks the same as my Slack 12.2 console now. I read the "dmesg" file and is looks like the video is now being set to 128x48 instead of the 160x64 previously. In fact, it looks better now without the font change suggested earlier.
Thanks again. Now that this problem is resolved, I can continue configuring my Slack 14.0 installation.
Girvin Herr
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 14.0 - Framebuffer Console Causes Hang on Boot (?) jandonuts Slackware 2 01-02-2013 10:08 AM
[SOLVED] Setting up Linux Console ... Fail when boot up Linux from scratch Runicer Linux From Scratch 2 01-24-2012 12:34 AM
Boot Msg : Setting up Linux console... [ FAIL ] R3D Linux From Scratch 2 08-02-2011 12:23 AM
Setting framebuffer console refresh rate on Slackware 12.1/GeForce 8 ErV Slackware 5 09-01-2008 05:25 PM
setting console boot resolution Gill Bates Linux - Newbie 2 09-10-2003 02:54 PM


All times are GMT -5. The time now is 12:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration