LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14.0 ati radeon HD 6530D and console resolution (http://www.linuxquestions.org/questions/slackware-14/slackware-14-0-ati-radeon-hd-6530d-and-console-resolution-4175466435/)

cesarion76 06-17-2013 09:37 PM

Slackware 14.0 ati radeon HD 6530D and console resolution
 
Hi all, after installing 14.0 x86_64 multilib in my new pc I managed to install the ati catalyst driver 13.4 from amd site.

All was going well, but don't know why I'd think, let's try the 13.6 beta driver, since it supports APU6 according to the change log.

Again all seemed to work well, but I get an Ugly watermark "only for testing" :) and the fps reported from fgl_glxgears was half of what I get with the stable 13.4 driver. :(

So again removed the 13.6 beta, reinstalled mesa, compiled and installed the 13.4 driver.

Code:

# sh amd-driver-installer-catalyst-13-4-x86.x86_64.run
# installpkg fglrx-12.104-x86_64-1.tgz
# aticonfig --initial -f

radeon and radeonhd are blacklisted

Now I can log in KDE and 3D works no problem, but an odd thing happens if I try to switch to from KDE to VT1,2,etc using crtl+alt+F1,F2,etc the console is unreadable, lines superimposed and duplicated.

Checked this forum and others for a similar problem but I couldn't find any.

Any help is welcome

My system:

Slackware 14.0 x86_64 multilib KDE 4.10.4

Code:

uname -a
Linux vampirin 3.2.45 #1 SMP Fri May 31 20:05:26 CDT 2013 x86_64 AMD A6-3500 APU
with Radeon(tm) HD Graphics AuthenticAMD GNU/Linux

Code:

lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Radeon HD 6530D]
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series]
00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Port
00:11.0 SATA controller: Advanced Micro Devices [AMD] Hudson SATA Controller [IDE mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices [AMD] Hudson SMBus Controller (rev 14)
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] Hudson LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] Hudson PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:16.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:16.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
02:06.0 Ethernet controller: Atheros Communications Inc. AR2417 Wireless Network Adapter [AR5007G 802.11bg] (rev 01)

Code:

lsmod
Module                  Size  Used by
nls_utf8                1352  1
isofs                  32730  1                                                                                                     
pci_stub                1373  1                                                                                                     
vboxpci                15029  0                                                                                                     
vboxnetadp            18387  0
vboxnetflt            16972  0
vboxdrv              1820449  3 vboxnetflt,vboxnetadp,vboxpci
snd_seq_dummy          1455  0
snd_seq_oss            29048  0
snd_seq_midi_event      5620  1 snd_seq_oss
snd_seq                51330  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          5228  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            39311  0
snd_mixer_oss          15532  3 snd_pcm_oss
ipv6                  280597  20
lp                      9787  0
ppdev                  5958  0
parport_pc            19295  0
parport                31427  3 parport_pc,ppdev,lp
fuse                  66601  3
ohci_hcd              23764  0
fglrx                5175652  142
snd_hda_codec_realtek  195794  1
ath5k                138817  0
processor              25496  3
snd_hda_intel          23299  5
ath                    14794  1 ath5k
ssb                    47856  1 ohci_hcd
snd_hda_codec          81989  2 snd_hda_intel,snd_hda_codec_realtek
snd_hwdep              6484  1 snd_hda_codec
snd_pcm                73335  4 snd_hda_codec,snd_hda_intel,snd_pcm_oss
snd_page_alloc          7081  2 snd_pcm,snd_hda_intel
thermal_sys            14578  1 processor
i2c_piix4              8152  0
i2c_core              20049  1 i2c_piix4
mac80211              227923  1 ath5k
snd_timer              18830  3 snd_pcm,snd_seq
cfg80211              169034  3 mac80211,ath,ath5k
rfkill                15428  3 cfg80211
mmc_core              77822  1 ssb
agpgart                27443  1 fglrx
pcmcia                35731  1 ssb
pcmcia_core            12061  1 pcmcia
k10temp                2843  0
hwmon                  1329  2 k10temp,thermal_sys
r8169                  49018  0
ehci_hcd              41000  0
mii                    3987  1 r8169
snd                    58091  15 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
psmouse                61842  0
button                  4529  1 fglrx
evdev                  9574  4
serio_raw              4389  0
soundcore              5570  3 snd
loop                  18256  0
ext4                  411375  2
jbd2                  66646  1 ext4
mbcache                5826  1 ext4

Code:

xorg.conf
Section "ServerLayout"
        Identifier    "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID      "PCI:0:1:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device    "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection


volkerdi 06-17-2013 09:57 PM

Quote:

Originally Posted by cesarion76 (Post 4973849)
Now I can log in KDE and 3D works no problem, but an odd thing happens if I try to switch to from KDE to VT1,2,etc using crtl+alt+F1,F2,etc the console is unreadable, lines superimposed and duplicated.

I don't use proprietary drivers, but have a possible idea. Is your console set to vga=normal in lilo.conf? This is currently recommended when using non-free drivers.

As I said, I don't use them myself, but if you aren't using vga=normal I'd say it's worth a shot.

cesarion76 06-18-2013 12:31 AM

thx, volkerdi

Edited lilo.conf and set vga=normal, kde starts ok but console now is black screen.

Before installing the 13.6 beta driver (the 13.4 was running no problem) the console was set 'VESA framebuffer console @ 1024x768x64k vga=791'

More odd, removed everything, reinstalled the 13.6 beta and the problem is gone, switches to VT, still the performance issue (and the ugly wattermark :P ).

Again removed everything, reinstalled /x packages full, reinstalled driver 13.4. and... the same result. the console remains unreadeble.

By the way, I first set the system to use the slackware radeon driver but can't get it to work right so I switched to catalyst driver.

cesarion76 06-19-2013 11:24 AM

I reinstalled slackware 14.0 upgraded kernel 3.2.45 installed driver 13.4 stable and no console again. A black screen in vga=normal mode

I switched back to kernel 3.2.29, remove/reinstall the driver and works again. I now have my console in VESA framebuffer @ 1024x768x64k vga=791 when switching to virtual terminals.

Kernel 3.2.45 and driver 13.4 stable don't work
Kernel 3.2.45 and driver 13.6 beta works

cisneros 06-19-2013 05:57 PM

i had the same problem, im guessing different version of the driver are made for different versions of the Kernel, i use to have the 12.4 driver on my laptop, with the kernel 2.6.37, but when i update to slackware 14 - current, the driver did not work, and even the lastest driver 13.4 did not work for me, just a black screen after startx, so i install the beta 13.6 and is the only one that have been working fine for the last month or so.

if you want to remove the watermark, use this:
https://dl.dropboxusercontent.com/u/...termark_nix.sh

FeyFre 06-21-2013 05:58 AM

Had the same problem described here but in -current.
vga=normal doesn't help
nomodeset doesn't help
vesa driver for Xorg doesn't works either(AFAIR)
It seems it is not problem of initalizing video driver(mode), but problem of switching modes by X.

> # aticonfig --initial -f
I suggest you additionally specify screen resolution, because if not to restrict stupid driver applies resolution not supported by my monitor.

stormbr 06-21-2013 07:31 AM

Patch 13.4
 
1 Attachment(s)
I had the same symptoms and solved the problem using a patch that I got from Arch. I've attached it since its so small.

Patch the umpacked driver source and rebuild the Slackware packages.

cesarion76 09-22-2013 05:33 PM

Just switched to -current with kernel 3.10.12 and the problem is gone. Using own slackware radeon or catalyst driver works. This thing flies :P


All times are GMT -5. The time now is 11:11 AM.