LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 14.0 64-bit will not boot without error if Slack DVD not in drive. (http://www.linuxquestions.org/questions/slackware-14/slackware-14-0-64-bit-will-not-boot-without-error-if-slack-dvd-not-in-drive-4175466407/)

Redraider89 06-17-2013 04:51 PM

Slackware 14.0 64-bit will not boot without error if Slack DVD not in drive.
 
I have a load of Slackware 14.0 64-bit sharing a Windows drive, dual boot. But I kept running out of space on my Linux partition. So I installed another hard drive, 100GB, and installed Linux on that drive with the Windows/Linux dual boot and files drive (an additional hard drive with files) disconnected. I had problems with a Kernel panic VFS errors, "VFS: Cannot open root device "803" or unknown-block(8,3)". I believe I got it to work with the drive by itself, without the other drives connected. So I then reconnected all of the drives and basically fought with it and fought with it, trying to get it to work, because I was getting the kernel panic errors after doing that. But gradually I made progress until I'm where I am now. This is basically it and the steps I take:

1. I boot to the hard drive, I get kernel panic errors, "VFS: Cannot open root device "803" or unknown-block(8,3)"

2. So I boot to the Slackware DVD, mount my Linux drive (all the other drives are connected as well, but not mounted).

3. Go to Setup and run the Slackware installation script for Lilo.

4. Do Expert, Begin - Start with new LILO header and choose /dev/sda1.

5. On the Linux setting, I choose the Linux partition.

6. On the Windows option, I select where my Windows is.

7. Then select the 4 option to Install. It installs with no errors.

Here is the problem, I reboot my PC and press F11 for my BIOS boot selection and choose the drive with Linux on it, the slackware boot screen comes up, and I choose Linux. Here is the weird part, unless I keep the CD in the DVD drive, I get a kernel panic error. But if I leave the Slackware DVD in, most of the time it boots fine. But take out the DVD and it will fail with the kernel panic and VFS: Cannot open root device "803" or unknown-block(8,3)"

I am currently logged in because at boot: I entered "huge.s /dev/sda1 init= ro" Something like that, I can't remember exactly, I'm new to this, but I'm pretty sure that is it because here I am, booted fine. Here is my lilo.conf file:

Code:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sda1

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 800x600x64k
vga = 788
# Normal VGA console
#vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# VESA framebuffer console @ 1024x768x64k
#vga=791
# VESA framebuffer console @ 1024x768x32k
#vga=790
# VESA framebuffer console @ 1024x768x256
#vga=773
# VESA framebuffer console @ 800x600x64k
#vga=788
# VESA framebuffer console @ 800x600x32k
#vga=787
# VESA framebuffer console @ 800x600x256
#vga=771
# VESA framebuffer console @ 640x480x64k
#vga=785
# VESA framebuffer console @ 640x480x32k
#vga=784
# VESA framebuffer console @ 640x480x256
#vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/sdc1
  label = Windows
  table = /dev/sdc
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Linux
  read-only
# Linux bootable partition config ends

Also, it may work the first reboot after running the LILO script from the DVD the first time, but even with the DVD in the drive upon reboot, I get the error again. The only thing I can think of that is causing the problem is that the mounting of the DVDROM drive is making the mapping out of wack and it confuses LILO. Thanks for your help.

Didier Spaier 06-18-2013 03:30 PM

Make sure that partition /dev/sda1 be bootable - and only that one. 'cfdisk' alllows you to toggle the 'Boot' flag.

PS I'm assuming that your hard drives are permanently connected to the computer - no USB HDD that you'd plug in or out.

PS2 I almost forgot... Welcome on LQ!

ReaperX7 06-18-2013 04:06 PM

You may also want to install LILO to the Master Boot Record also. Installing it to the /(root) of the /sda1 partition often will not work leaving the drive unbootable even if cfdisk flags it as "Bootable". You have to install it to /sda (Master Boot Record) for your hard disk to have an MBR capable boot loader.

Didier Spaier 06-19-2013 07:01 AM

Quote:

Originally Posted by ReaperX7 (Post 4974412)
You may also want to install LILO to the Master Boot Record also. Installing it to the /(root) of the /sda1 partition often will not work leaving the drive unbootable even if cfdisk flags it as "Bootable". You have to install it to /sda (Master Boot Record) for your hard disk to have an MBR capable boot loader.

I have a setting with /dev/sda3 bootable (/ for Linux) as boot device and Windows boot on /dev/sda2 flawlessly.

I'd avoid installing lilo on rhe MBR if possible, as this will wipe the boot sector and in some situations (installing a Service Pack e.g.) Windows will need to be booted from the MBR. Granted, you can save the boot sector and restore it, but that's one more thing to take care of.

So my advise to the OP remains to just insure that /dev/sda1 be bootable and only if after that he can't boot from the HDD find another way.

Redraider89 06-26-2013 06:47 AM

I have never had problems installing to the MBR, until now. And I think that because I installed Slackware with the other drives disconnected, that when I reconnected the drives, it made LILO irreparably confused. So, I just did a reinstall, with all the drives connected, but installed on a drive where Linux is the only one there, and it seems to be working. The only issue now, is that it blew up my Windows and the Windows link isn't working on the boot screen. So I had to reinstall Windows where it has always been and both work now, I just can't use the LILO boot screen to choose the OS but have to select at POST what drive I want to boot to. But as long as Linux is working and not getting the error, I'm OK and I'll work on getting the boot screen to work later. Thanks for your help.


All times are GMT -5. The time now is 07:46 AM.