LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-16-2009, 11:28 AM   #1
Cryophile
LQ Newbie
 
Registered: Dec 2009
Location: Toronto, Canada
Distribution: Slackware 13.0
Posts: 4

Rep: Reputation: 0
Slackware 13 wireless not working (ath9k)


I'm not new to Linux, but it's a return to Slackware for me. I haven't used it since Slack 9.1. I'm not the most experienced Linux user, though. Hopefully my question is in the right place.

I have an ASUS 1005HA-P, and my wifi adapter uses the AR9285 chipset. So far I can't get any results for networks in wicd, or with "iwlist wlan0 scan". I'm not sure what I'm doing wrong, but it's probably something very simple.

Code:
bash-3.1$ lsmod |grep ath
ath9k                 299632  0 
mac80211              155588  1 ath9k
rfkill                  9296  5 ath9k,eeepc_laptop
led_class               3392  1 ath9k
bash-3.1$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

bash-3.1$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:26:18:41:bb:77  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:28 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:25:d3:24:6e:99  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-25-D3-24-6E-99-6C-6F-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Am I missing any other information?
 
Old 12-16-2009, 12:37 PM   #2
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 422

Rep: Reputation: 58
Try upgrading the wireless drivers with 'compat-wireless-2.6.32-rc7.tar.bz2' available online. It uses the new 'ath9k' driver and the 'ath9k' module. That's what I needed to do recently with my Acer Aspire One
 
Old 12-16-2009, 01:30 PM   #3
Cryophile
LQ Newbie
 
Registered: Dec 2009
Location: Toronto, Canada
Distribution: Slackware 13.0
Posts: 4

Original Poster
Rep: Reputation: 0
I'd tried that previously, and it was a no go. I just tried it again now, and I've had absolutely no change. Everything looks to be fine, but I can't see any networks. It's almost like my laptop's wireless itself is off, but as far as I can tell it's not.
 
Old 12-16-2009, 01:45 PM   #4
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Rep: Reputation: 15
Try installing wicd. It can be found in the "extra" directory of your Slackware installation CD, or at a Slackware download site. Change the drivers used by wicd in the preferences.

Run this:
Code:
wpa_supplicant -Dwext -iwlan0 -c /etc/wpa_supplicant.conf
and tell us the results. Swap "wext" for "ndiswrapper" and tell us the results.

Last edited by suChris; 12-16-2009 at 01:48 PM.
 
Old 12-16-2009, 02:07 PM   #5
Cryophile
LQ Newbie
 
Registered: Dec 2009
Location: Toronto, Canada
Distribution: Slackware 13.0
Posts: 4

Original Poster
Rep: Reputation: 0
I'd already installed wicd, and I hadn't got any results from it.
As for the supplicant that command by itself will just spew CTRL-EVENT-SCAN-RESULTS, but with -dd there's some more useful information (here's an excerpt). I didn't the ndiswrapper. Not sure how that would help.

Received 0 bytes of scan results (0 BSSes)
CTRL-EVENT-SCAN-RESULTS
CTRL_IFACE monitor send - hexdump(len=23): 2f 74 6d 70 2f 77 70 61 5f 63 74 72 6c 5f 31 30 30 36 31 2d 32 30 00
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.



and so it goes. Not sure if this is what you were looking for.
 
Old 12-16-2009, 04:06 PM   #6
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
This is my solution. Write a script for root with the following text:

Quote:
#!/bin/sh
/sbin/ifconfig wlan0 up
/sbin/iwconfig wlan0 ap any
/sbin/iwlist wlan0 scan
echo -n "Enter the ESSID of choice: "
read ESSID
/sbin/iwconfig wlan0 essid "$ESSID"
/sbin/dhcpcd -k wlan0 2> /dev/null
/sbin/dhcpcd wlan0
/sbin/ifconfig wlan0
echo "Press any key to exit"
read
Careful! You need to run it as a script, and you might have to be quick when entering the ESSID. Try it a number of times and good luck!

Chris
 
Old 12-16-2009, 04:16 PM   #7
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
just checked my system. I have also ath9k, but it is sony vaio. I use wicd and everything worked out for me automatically. I didn't have to do any extra tuning on this hardware. It worked with stock 2.6.29.6, but now I run 2.6.32 and this is my lsmod:

Code:
vladimir@darkstar:~$ lsmod |grep ath
ath9k                 278573  0
mac80211              159245  1 ath9k
ath                     8336  1 ath9k
cfg80211              120258  3 ath9k,mac80211,ath
led_class               2545  2 ath9k,sdhci
Maybe you need some of this modules to be loaded?
 
Old 12-17-2009, 04:33 AM   #8
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Rep: Reputation: 15
Hmmm...can you post the output of lsmod? Maybe there are some conflicting drivers operating...
 
Old 12-17-2009, 09:09 AM   #9
Cryophile
LQ Newbie
 
Registered: Dec 2009
Location: Toronto, Canada
Distribution: Slackware 13.0
Posts: 4

Original Poster
Rep: Reputation: 0
Haha, wow. I'm really sorry about this. Just on a whim I decided to check my bios because I knew that everything should be working properly. Somehow my bios settings had been reset to default and the Onboard WLAN was disabled. I have no idea how or when this happened, but it must have been within the last three days. It works perfectly now. Again, I'm sorry for the inconvenience.
 
Old 12-17-2009, 07:10 PM   #10
suChris
Member
 
Registered: Nov 2009
Distribution: Slackware 13
Posts: 56

Rep: Reputation: 15
Hehe...! No prob. Glad you got it sorted out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to get wireless working with Slackware victor5 Linux - Laptop and Netbook 3 10-08-2009 01:27 PM
Wireless not working on Slackware 12 Rommeo Slackware 3 05-14-2008 08:06 PM
Wireless not working on Slackware 12 grandbazaar Linux - Wireless Networking 8 02-25-2008 08:56 PM
Wireless not working in Slackware 11 with 2.6.18 kernel Mithic Slackware 13 03-04-2007 06:12 PM
Wireless network not working on slackware 11.0!!! Busch Slackware 15 12-23-2006 08:17 PM


All times are GMT -5. The time now is 05:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration