LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 13 wireless not working (ath9k) (http://www.linuxquestions.org/questions/slackware-14/slackware-13-wireless-not-working-ath9k-776111/)

Cryophile 12-16-2009 10:28 AM

Slackware 13 wireless not working (ath9k)
 
I'm not new to Linux, but it's a return to Slackware for me. I haven't used it since Slack 9.1. I'm not the most experienced Linux user, though. Hopefully my question is in the right place.

I have an ASUS 1005HA-P, and my wifi adapter uses the AR9285 chipset. So far I can't get any results for networks in wicd, or with "iwlist wlan0 scan". I'm not sure what I'm doing wrong, but it's probably something very simple.

Code:

bash-3.1$ lsmod |grep ath
ath9k                299632  0
mac80211              155588  1 ath9k
rfkill                  9296  5 ath9k,eeepc_laptop
led_class              3392  1 ath9k
bash-3.1$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0    IEEE 802.11bgn  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated 
          Tx-Power=27 dBm 
          Retry min limit:7  RTS thr:off  Fragment thr=2352 B 
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

bash-3.1$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:26:18:41:bb:77 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:28

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

wlan0    Link encap:Ethernet  HWaddr 00:25:d3:24:6e:99 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-25-D3-24-6E-99-6C-6F-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Am I missing any other information?

Chuck56 12-16-2009 11:37 AM

Try upgrading the wireless drivers with 'compat-wireless-2.6.32-rc7.tar.bz2' available online. It uses the new 'ath9k' driver and the 'ath9k' module. That's what I needed to do recently with my Acer Aspire One

Cryophile 12-16-2009 12:30 PM

I'd tried that previously, and it was a no go. I just tried it again now, and I've had absolutely no change. Everything looks to be fine, but I can't see any networks. It's almost like my laptop's wireless itself is off, but as far as I can tell it's not.

suChris 12-16-2009 12:45 PM

Try installing wicd. It can be found in the "extra" directory of your Slackware installation CD, or at a Slackware download site. Change the drivers used by wicd in the preferences.

Run this:
Code:

wpa_supplicant -Dwext -iwlan0 -c /etc/wpa_supplicant.conf
and tell us the results. Swap "wext" for "ndiswrapper" and tell us the results.

Cryophile 12-16-2009 01:07 PM

I'd already installed wicd, and I hadn't got any results from it.
As for the supplicant that command by itself will just spew CTRL-EVENT-SCAN-RESULTS, but with -dd there's some more useful information (here's an excerpt). I didn't the ndiswrapper. Not sure how that would help.

Received 0 bytes of scan results (0 BSSes)
CTRL-EVENT-SCAN-RESULTS
CTRL_IFACE monitor send - hexdump(len=23): 2f 74 6d 70 2f 77 70 61 5f 63 74 72 6c 5f 31 30 30 36 31 2d 32 30 00
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.



and so it goes. Not sure if this is what you were looking for.

ChrisAbela 12-16-2009 03:06 PM

This is my solution. Write a script for root with the following text:

Quote:

#!/bin/sh
/sbin/ifconfig wlan0 up
/sbin/iwconfig wlan0 ap any
/sbin/iwlist wlan0 scan
echo -n "Enter the ESSID of choice: "
read ESSID
/sbin/iwconfig wlan0 essid "$ESSID"
/sbin/dhcpcd -k wlan0 2> /dev/null
/sbin/dhcpcd wlan0
/sbin/ifconfig wlan0
echo "Press any key to exit"
read
Careful! You need to run it as a script, and you might have to be quick when entering the ESSID. Try it a number of times and good luck!

Chris

dolphin77 12-16-2009 03:16 PM

just checked my system. I have also ath9k, but it is sony vaio. I use wicd and everything worked out for me automatically. I didn't have to do any extra tuning on this hardware. It worked with stock 2.6.29.6, but now I run 2.6.32 and this is my lsmod:

Code:

vladimir@darkstar:~$ lsmod |grep ath
ath9k                278573  0
mac80211              159245  1 ath9k
ath                    8336  1 ath9k
cfg80211              120258  3 ath9k,mac80211,ath
led_class              2545  2 ath9k,sdhci

Maybe you need some of this modules to be loaded?

suChris 12-17-2009 03:33 AM

Hmmm...can you post the output of lsmod? Maybe there are some conflicting drivers operating...

Cryophile 12-17-2009 08:09 AM

Haha, wow. I'm really sorry about this. Just on a whim I decided to check my bios because I knew that everything should be working properly. Somehow my bios settings had been reset to default and the Onboard WLAN was disabled. I have no idea how or when this happened, but it must have been within the last three days. It works perfectly now. Again, I'm sorry for the inconvenience.

suChris 12-17-2009 06:10 PM

Hehe...! No prob. Glad you got it sorted out.


All times are GMT -5. The time now is 12:48 PM.