LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-24-2010, 05:14 AM   #1
Rugila
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Rep: Reputation: 0
Slackware 13 startx gives black screen


Hi,

I put Slackware 13 and the scenarios is:

1. I start the computer and after startx I got black screen, the keyboard is not responding the led of the display is yellow etc. Now I reset the computer,
2. Booting Windoze
3. Choose RESTART not SHUTDOWN from Windoze
4. Booting Slack
5. startx works fine , the X server is starting and working great.

I have Radeon 9500. I configured X server with 3D accel over 2500 FPS on glxgears. The same problem persists even with X server VESA configured.
 
Old 03-24-2010, 08:30 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 10,888
Blog Entries: 1

Rep: Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307
Hi,

Welcome to LQ!

What does your logs show? Look at '/var/log/Xorg.0.log' and 'dmesg'.

What happens without a '/etc/X11/xorg.conf'?
 
Old 03-24-2010, 06:42 PM   #3
Rugila
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

Welcome to LQ!

What does your logs show? Look at '/var/log/Xorg.0.log' and 'dmesg'.

What happens without a '/etc/X11/xorg.conf'?
same problem without xorg.conf , and then I have only 60 Hz
 
Old 03-24-2010, 07:28 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,256

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Try:

grep '(EE)' /var/log/Xorg.0.log
grep '(WW)' /var/log/Xorg.0.log

Those command should provide information why X is stalling.
 
Old 03-25-2010, 03:37 AM   #5
Rugila
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Yes, thanks very much. I will investigate in details the log.I was busy to test another distro (Ubuntu, Opensuse , Debian )and now I know 100% why I like Slackware more than those. I will stick with Slack even if I must use Windoze too boot it.
 
Old 03-25-2010, 02:55 PM   #6
Rugila
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Woodsman View Post
Try:

grep '(EE)' /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.





Quote:
Originally Posted by Woodsman View Post

grep '(WW)' /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/local" does not exist.
(WW) The directory "/usr/share/fonts/CID" does not exist.
(WW) The directory "/usr/share/fonts/local" does not exist.
(WW) The directory "/usr/share/fonts/CID" does not exist.
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(WW) RADEON(0): DRI init changed memory map, adjusting ...
(WW) RADEON(0): MC_FB_LOCATION was: 0xe7ffe000 is: 0xe7ffe000
(WW) RADEON(0): MC_AGP_LOCATION was: 0xffffffc0 is: 0xf1fff000
 
Old 03-26-2010, 03:05 AM   #7
Rugila
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Original Poster
Rep: Reputation: 0
The issue is that is no log for X because I cannot connect to X . The log contains only the infos when I am connected.
 
Old 03-26-2010, 07:56 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 10,888
Blog Entries: 1

Rep: Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307
Hi,

Quote:
Originally Posted by Rugila View Post
The issue is that is no log for X because I cannot connect to X . The log contains only the infos when I am connected.
If your install is proper and you enter the 'startx' command a '/var/log/Xorg.0.log' will be created upon initiation. You should have logged information for a failure or good start of 'X'. The log entries can be used to identify problems in your configuration even if the 'X' server has defaulted to a condition that would seem everything was OK.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help. Startx gives black screen! sl4ckw4r3 Slackware 23 01-29-2010 05:08 PM
Black screen & system hang on startx -Slackware 12, nvidia driver and kernel 2.6.21.5 theapodan Linux - Hardware 1 11-18-2008 03:44 AM
Startx results in a black screen with VGA and screen errors kwosource Linux - Newbie 4 03-11-2005 02:58 PM
'startx' gives me a black screen on new slackware 10 install evank Linux - Newbie 5 01-07-2005 09:59 PM
black screen when try startx Brian_CC Slackware 8 10-15-2003 06:06 PM


All times are GMT -5. The time now is 12:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration