LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2010, 03:39 PM   #1
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Rep: Reputation: 0
Unhappy Slackware 13 - Problems with "su" as superuser(root)


Slack13 - Kernel 2.6.32.2

Hi. I don't speak English very well.

I have a problem with "su" in Terminal in X.
I can't access my root account anymore.
I haven't problem in console but in "X" I have problem.
 
Old 03-18-2010, 03:51 PM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543
Hi, your English looks just fine to me.

What exactly happens when you use `su` in an X terminal? Is the password rejected? Or do some strange errors happen, such as maybe "command not found" or something like that? Please elaborate about the exact symptoms of "cannot access my root account".

Also, I notice you are from Brazil? If the case is of the password being rejected, I ask this: have you got the same keyboard layout & locale/language settings while in your desktop, running X, as you do when you are outside of X, at the Virtual Terminal? Does your root password contain any strange, foreign, accented, etcetera characters, which may not be getting entered correctly from your desktop?

Finally -- Did you change anything with the system recently? Did you have no problem one day, then "something happened", and now it does not work? If so, what did you change? Maybe upgraded some packages, or removed some, or whatever?

Sasha
 
1 members found this post helpful.
Old 03-18-2010, 06:32 PM   #3
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,955

Rep: Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936Reputation: 936
xorgsetup
 
1 members found this post helpful.
Old 03-18-2010, 10:50 PM   #4
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 0
Unhappy

Hi Sasha.

Yes, I'm from Brazil. No, I don't have problem with my Layout.
My Keyboard It's OK and my password too. My problem is 'su' in
an X Terminal (Like konsole, gnome-terminal, xTerm, etc) and
Console(without X11), but I don't have problem with 'Logon'.
For example:

When I will restart my computer, I can access my root account
normally, less with 'su' in Console and X11.

Accesses my link below:

Screenshot - wrong password

I added an attachment.
Attached Images
File Type: jpg Screenshot-43.jpg (127.2 KB, 67 views)
 
Old 03-18-2010, 11:19 PM   #5
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543
I'm sorry I got distracted by how cool your screenshot looked you should put a screenshot in the giant thread called "This is my slackware desktop", it's very nice.

I'm not sure what to suggest, but it *appears* that you're simply entering the wrong password, due to character/locale problem.

As Didier suggested above, perhaps running `xorgsetup` will help, provided that you set the keyboard to be the same as you did when you installed the OS and selected a keyboard. For example, if when you installed the OS, you chose "en_US" as the keyboard setting during installation, then run xorgsetup and set the keyboard language to that setting again, and see if this helps.

I assume you are absolutely certain that you know what the root password IS, so another suggestion (I tested this earlier) is to type your root password in plain text, either on a text-editor or on a terminal window (type it at the prompt and just hit enter to get to the next line), so that you can copy & paste it later. Now, you can see the password in plain text on the screen-- make sure it is exactly correct;
Now, type su, and where it asks for the password, highlight the password you put in plain text, using your mouse, and press SHIFT+MiddleClick to paste the password (you will not see anything, but trust me, it did paste). Now hit ENTER.

If neither of these ideas helps, I apologize; I have no other suggestion at this time, so I really hope that someone else has another approach to try.

Sasha
 
1 members found this post helpful.
Old 03-19-2010, 01:18 AM   #6
slkrover
Member
 
Registered: Mar 2010
Distribution: Slackware 14.1
Posts: 68

Rep: Reputation: 16
Are you using su or su - . The screen shot only shows su.
 
1 members found this post helpful.
Old 03-19-2010, 03:41 PM   #7
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 0
Unhappy

Hi.

I don`t need help anymore.

I upgraded my Slackware and I found a lot of problems here.
Now I need to reinstall everything again. I can access normally
with `su` now, after upgraded. When I access as root or another
account, I see that message:

Code:
configuration error - unknown item 'DIALUPS_CHECK_ENAB' (notify administrator)
configuration error - unknown item 'NOLOGIN_STR' (notify administrator)
Password:
Last login: Fri Mar 19 03:48:50 -0300 2010 on /dev/tty1.
No mail.

Never have children, only grandchildren.
                -- Gore Vidal

miltonjr@MOBJRLinux:~$
My log:
Code:
Mar 18 14:32:29 MOBJRLinux login[3079]: ROOT LOGIN  on `tty2'
Mar 18 23:38:46 MOBJRLinux su[6766]: Authentication failed for root
Mar 18 23:38:46 MOBJRLinux su[6766]: - pts/0 miltonjr-root
Mar 19 03:48:30 MOBJRLinux login[3024]: ROOT LOGIN  on '/dev/tty1'
Mar 19 03:49:03 MOBJRLinux su[3076]: unknown configuration item `DIALUPS_CHECK_ENAB'
Mar 19 03:49:03 MOBJRLinux su[3076]: unknown configuration item `NOLOGIN_STR'
Mar 19 03:49:05 MOBJRLinux su[3076]: Successful su for root by miltonjr
Mar 19 03:49:05 MOBJRLinux su[3076]: + /dev/tty1 miltonjr:root
Mar 19 03:49:15 MOBJRLinux su[3080]: unknown configuration item `DIALUPS_CHECK_ENAB'
Mar 19 03:49:15 MOBJRLinux su[3080]: unknown configuration item `NOLOGIN_STR'
Mar 19 03:49:18 MOBJRLinux su[3080]: Successful su for root by miltonjr
Mar 19 03:49:18 MOBJRLinux su[3080]: + /dev/tty1 miltonjr:root
Mar 19 13:41:56 MOBJRLinux login[3039]: ROOT LOGIN  on '/dev/tty1'
Mar 19 15:48:20 MOBJRLinux login[3033]: invalid password for 'miltonjr'  on '/dev/tty1'
Mar 19 15:48:25 MOBJRLinux login[3033]: invalid password for 'UNKNOWN'  on '/dev/tty1'
Mar 19 17:00:43 MOBJRLinux login[3196]: ROOT LOGIN  on '/dev/tty1'
Attached Files
File Type: txt slack13_32_kernel26322.txt (84.9 KB, 3 views)

Last edited by mobjr; 03-19-2010 at 05:04 PM.
 
Old 03-19-2010, 03:50 PM   #8
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543Reputation: 543
I had that stuff too, after I first upgraded to -current. Those messages are, if I recall correctly, caused by deprecated items in the /etc/login.defs file. Once you have replaced the old version of the file, with the new one (usually with the .new suffix), the problem will go away.

You might want to look around the system for other .new files and examine them for changes in the new version over the old version; then, make sure you either merge the old and the new, or manually edit/copy/rename whichever version you want to keep. Doing this sort of cleanup would save you having to re-install.

Also, if you have Slackpkg installed, it has an option for dealing with .new files.

P.S. - why did you attach that dmesg or kernel.txt file? It looks OK in there.


Sasha
 
2 members found this post helpful.
Old 03-19-2010, 06:09 PM   #9
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 201

Rep: Reputation: 43
I only added the slackpkg command.
slackpkg new-config
 
1 members found this post helpful.
Old 03-19-2010, 06:22 PM   #10
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 0
Question

I forgot...

About my screenshot, thanks.
slkrover, I use `su --login`.

================================

OK
I use slapt-get (slapt-get) and I have slackpkg.

I have `Gnome` and `KDE`. My KDE I can`t start more and my Gnome
I can`t see my Wallpaper and my Keyboard layout is different now.
I will rename one by one and make a backup for each file(security).
I rename `login.defs.new` to `login.defs`, I don`t have problem now.


I found this files
Code:
/var/tmp/kdecache-root/plasma-svgelements-ElegancepN3679.new
/usr/share/texmf/tex/latex/titlesec/titletoc.new
/usr/share/texmf/doc/latex/fancyhdr/fancyheadings.new
/etc/X11/xdm/xdm-config.new
/etc/X11/xdm/Xservers.new
/etc/rc.d/rc.font.new
/etc/rc.d/rc.wireless.new
/etc/rc.d/rc.local.new
/etc/rc.d/rc.ntpd.new
/etc/rc.d/rc.inet1.new
/etc/rc.d/rc.S.new
/etc/rc.d/rc.inet1.conf.new
/etc/rc.d/rc.M.new
/etc/dbus-1/system.d/bluetooth.conf.new
/etc/dbus-1/session.conf.new
/etc/dbus-1/system.conf.new
/etc/cups/cupsd.conf.new
/etc/netatalk/AppleVolumes.default.new
/etc/kde/kdm/kdmrc.new
/etc/lvm/lvm.conf.new
/etc/openldap/ldap.conf.new
/etc/ssh/sshd_config.new
/etc/ssh/ssh_config.new
/etc/gtk-2.0/i486-slackware-linux/im-multipress.conf.new
/etc/httpd/httpd.conf.new
/etc/mplayer/mplayer.conf.new
/etc/sane.d/hp3900.conf.new
/etc/sane.d/umax_pp.conf.new
/etc/sane.d/genesys.conf.new
/etc/sane.d/epjitsu.conf.new
/etc/sane.d/saned.conf.new
/etc/sane.d/dll.conf.new
/etc/sane.d/gt68xx.conf.new
/etc/sane.d/fujitsu.conf.new
/etc/profile.new
/etc/mke2fs.conf.new
/etc/login.access.new
/etc/vsftpd.conf.new
/etc/slapt-get/slapt-update-notifier.conf.new
/etc/slapt-get/slapt-getrc.new
/etc/passwd.new
/etc/services.new
/etc/dnsmasq.conf.new
/etc/gshadow.new
/etc/group.new
/etc/shadow.new
/etc/wgetrc.new
/etc/logrotate.conf.new
/etc/login.defs.new
/etc/wpa_supplicant.conf.new
 
Old 03-19-2010, 07:10 PM   #11
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 201

Rep: Reputation: 43
Thats allot.
I usually overwrite the ones i haven't changed and diff the ones i know i changed so i know what i should do.
slackpkg is real good for keeping your Slackware up to date.
But it only handles official packages.
I think you should start checking .new files when you update or upgrade your Slackware.
You can't always trust a tool to do everything for you so always read the changelog before an update or upgrade.

Last edited by Nille_kungen; 03-19-2010 at 07:14 PM.
 
1 members found this post helpful.
Old 03-24-2010, 01:53 AM   #12
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 0
Cool

Don't worry. Now I have Slackware 13 64 Bits.

Thanks GrapefruiTgirl, Didier Spaier, slkrover, Nille_kungen.
 
  


Reply

Tags
bucheb, junior, slack13, slack64, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"As Superuser" text in the title bar of Ubiquity Kenny_Strawn Ubuntu 3 02-28-2010 06:41 AM
newbie question: whats the difference between "su root", "su" and "su -&quo mojarron Slackware 9 12-07-2009 04:08 PM
Logged in as "root"/Fedora 8 but get "Operation not permitted" when using "chmod etc gosunlee Linux - Newbie 7 02-10-2008 05:56 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
Konqueror as "superuser" (Root) ? bigjohn Ubuntu 6 07-08-2006 02:22 AM


All times are GMT -5. The time now is 05:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration