LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-29-2009, 02:40 PM   #1
0rwell
LQ Newbie
 
Registered: Sep 2009
Posts: 18

Rep: Reputation: 2
Slackware 13 Installer Does Not Detect My HDD


Howdy all,

I'm a well-versed Slacker from many versions ago. I have Slackware installed on many different machines, with different versions (including armedslack on a Sheeva Plug), and I can not get this thing to detect my drives for the life of me.

My disk is a Sata2 drive in a dell box (if it helps, the service tag is 5d6x1c1). When I boot, I first tried hugesmp.s, and when I run df -h, there are no local drives. cfdisk confirmed no drives.

I tried with huge.s, scsi2.s and scsi.s, but can not find sata.i or bare.i.

What am I doing wrong?

Thanks in advance,

_Orwell
 
Old 10-29-2009, 02:49 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Well, one thing I would try is go into the BIOS settings and see if there are options for the SATA controller mode. There's usually something like AHCI/RAID, SATA, PATA. AHCI usually is detected best, but if you're running Windoze, it may have problems with this.

Also, have you tried something like 'fdisk -l' and 'fdisk /dev/sda', etc.
 
Old 10-29-2009, 03:42 PM   #3
0rwell
LQ Newbie
 
Registered: Sep 2009
Posts: 18

Original Poster
Rep: Reputation: 2
Brilliant! I swapped my SATA over from Native mode to combination mode and it now works like a champ!

Thanks a million... I can't believe I failed so hard. Thanks again!

_Orwell
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install Debian. Installer doesn't detect my ISO image dorifutoboi Debian 2 09-07-2009 10:22 PM
Ubuntu installer doesn't detect SATA but Fedora does adam-red Ubuntu 5 10-08-2007 04:29 PM
Debian installer cannot detect my cd-rom kazu182 Debian 5 02-26-2007 03:46 PM
Installer won't detect CD drive Farcanell Mandriva 4 03-15-2005 12:06 PM
Slackware 9.0 install freezes trying to detect partitions on my 120 GB HDD Nicolae Slackware - Installation 1 02-19-2004 05:18 AM


All times are GMT -5. The time now is 01:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration