LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-02-2012, 01:36 PM   #1
zeelog
Member
 
Registered: Jan 2008
Posts: 109

Rep: Reputation: 1
Slackware 13 does not see my external usb hard drive


How do I get Slackware 13 to work with my external usb hard
drive ? I have no idea what to do because in other Linux OS
it was all done automatically for me. When everything is done
for you, you don't learn much do you.
 
Old 08-02-2012, 02:02 PM   #2
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
From the command prompt you may need to mount the drive yourself. From KDE or XFCE it will be automatically mounted for you and will show up in the file browser. To start the GUI (Graphical User Interface) from the prompt type startx. To change the default desktop or window manager type xwmconfig.

DNA
AKA mrascii
 
Old 08-02-2012, 02:04 PM   #3
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
A coupla links for you here:

http://www.ehow.com/how_6826525_acce...slackware.html
http://www.basicconfig.com/linux/mount
 
1 members found this post helpful.
Old 08-02-2012, 02:16 PM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,252

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
I usually do it this way:

0) If X is launched fire up a terminal or xterm

1) become root with the "su" command

2) plug in your external usb drive.

3) wait ~ 15 seconds for it to synchronize

4) type following command in the terminal or xterm:

Code:
dmesg|tail
The output should show the drive's partition(s) as e.g. sdb1, sdb2, ...

To mount /dev/sdb1 for instance as /media type:
Code:
mount -t auto /dev/sdb1 /media
Of course replace /media by another mount point if you prefer.

Last edited by Didier Spaier; 08-02-2012 at 02:20 PM.
 
1 members found this post helpful.
Old 08-02-2012, 02:32 PM   #5
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
@jostber: The ehow link says the drive will be mounted under /mnt which is, of course, wrong. The correct mount point is under /media.

DNA
AKA mrascii
 
Old 08-02-2012, 05:17 PM   #6
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,336
Blog Entries: 5

Rep: Reputation: 786Reputation: 786Reputation: 786Reputation: 786Reputation: 786Reputation: 786Reputation: 786
http://www.bournetoraiseshell.com/ar...20731143231397
 
Old 08-02-2012, 05:20 PM   #7
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 214

Rep: Reputation: 64
Are you a member of plugdev group?
 
1 members found this post helpful.
Old 08-03-2012, 12:27 AM   #8
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 299

Rep: Reputation: 50
This is basically what I do.
I wait a few seconds after I plugged the external drive, then (from a console) I type in this command:
Code:
cat /proc/partitions
This displays all the partitions (internal and external drives).
In my case sda is the internal disk device, so I just mount whichever
partition I need from the external drive (e.g., /dev/sdb1, or /dev/sdb2)
For instance (as root) if your partition is /dev/sdb1 you can run these commands
Code:
mkdir -p /mnt/sdb1
mount /dev/sdb1 /mnt/sdb1
Actually I have entries in /etc/fstab and have already created /mnt/sdb1 ... /mnt/sdb4 /mnt/sdc1 ...
So all I need to do (as an ordinary user) is
Code:
mount /mnt/sdb1
Here's one of the entries in my /etc/fstab:
Code:
/dev/sdb1      /mnt/sdb1    auto      user,noauto,noatime,exec 1 0
 
1 members found this post helpful.
Old 08-03-2012, 01:44 AM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You might want to consider writing udev rules for persistent device naming, so you don't have to worry about checking what it's called each time. See, e.g. this.
 
Old 08-04-2012, 09:20 AM   #10
zeelog
Member
 
Registered: Jan 2008
Posts: 109

Original Poster
Rep: Reputation: 1
Slackware 13 does not see my external usb hard drive

Success ! I can now mount my 2T Seagate external USB 2.0 hard drive.
I used root to do the mounting. I have used both the command line
and a terminal in KDE.
But I can not do anything with it. I can not delete files nor create
a new directory or anything else. It does umount.
I used mount -rw -t ntfs /dev/sdb1 /mnt/sdb1
and mount -t auto /dev/sdb1 /mnt/sdb1
and mount /dev/sdb1 /mnt/sdb1
And all kinds of variations besides. It mounts. I can navigate it,
but not much else.
I have tried /etc/fstab /dev/sdb1 /mnt/sdb1 auto user,noauto,noatime,exec 1 0
mount /mnt/sdb1 works but, again, I can't do anything with the Seagate.
I suspect it is a file system problem, but what to do ?
What am I doing wrong ?
This external hard drive works on other OS, so I must be doing, or not doing,
something to cause the problem.
Thank you all for your messages. It is appreciated.
 
Old 08-04-2012, 09:43 AM   #11
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,252

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
The default for -t ntfs is that the files are owned by root, not writable and readable by nobody else, see "man mount".

I have this in /etc/fstab for an internal HD, anybody can read the files and only root can write it:
Code:
/dev/sda2 /windows ntfs-3g fmask=133,dmsk=022 1 0
Adapt according to your taste.
 
1 members found this post helpful.
Old 08-04-2012, 11:46 AM   #12
zeelog
Member
 
Registered: Jan 2008
Posts: 109

Original Poster
Rep: Reputation: 1
Slackware 13 does not see my external usb hard drive

mount -t ntfs-3g /dev/sdb1 /media/external works great !
I'm doing this in root, but that's what I usually use in Slackware
This is great ! I can use the external Seagate just like a regular hd.
Thanks Didier Spaier.
Where did you find the file system ntfs-3g ?
I only find plain ntfs in cat /proc/filesystems and in man mount.
There is no ntfs-3g.
I would never have found it on my own. Thanks!
 
Old 08-04-2012, 11:56 AM   #13
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,252

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
ntfs-3g is the partition type Slackware installer uses to write the relevant line in /etc/fstab if you (politely, of course) ask it to include a windows partition that it detected as being a ntfs one at time of setting your disk's partitions

FYI it is provided in Slackware by the package ntfs-3g in the /a series.

Last edited by Didier Spaier; 08-04-2012 at 11:59 AM.
 
1 members found this post helpful.
Old 08-05-2012, 08:07 PM   #14
zeelog
Member
 
Registered: Jan 2008
Posts: 109

Original Poster
Rep: Reputation: 1
Slackware 13 does not see my external usb hard drive

Now that I know ntsf-3g can mount and allow me to use my
external usb 2.0 Seagate 2T hard drive, you could say this
problem has been solved.
Except I noticed my other two Linux OSs use the fuse file
system to do the job. Slackware 13 also has the fuse file
system ( cat /proc/filesystems )
The other Linux OSs have an fstab that list filesystems that
are always mounted on boot in /lib/init/fstab
<file system> < mount point> < type > < options > < dump > < pass >
none /sys/fs/fuse/connections fusectl optional 0 0
I think Slackware 13 may have such an fstab in
/boot/initrd-tree/etc/fstab, yes ?
Slackware does have the directory /sys/fs/fuse/connections
So, is it possible to use the fuse file system for external usb hard drives
like the other Linux OSs for Slackware 13 ?
Or should I start a different thread for the above question,
and declare this one solved ?
Thank you all for your help. I've learned a lot.
 
Old 08-06-2012, 12:43 AM   #15
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,252

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
This is really a different topic, so please do start a different thread for that.

Anyhow in Slackware 13.37 ntfs-3g is compiled with the option "--fuse=internal" (which is the default) so the settings found in other distributions *could* be reproduced in Slackware: feel free to play with that if you wish

This is not done by default in Slackware, probably because:
- it is not needed by most users
- change the dmask and fmask if needed in the relevant line of /etc/fstab is a lot more simple: simplicity is at the heart of Slackware's "philosophy"
- the usual setting for mounting ntfs drives is probably more secure as it is in Slackware

PS the explanations above may be not that accurate as I don't know fuse well, please other posters correct it as needed.

Last edited by Didier Spaier; 08-06-2012 at 12:46 AM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting Linux on an external USB hard drive (not a memory stick, a hard drive) comcastuser Linux - Hardware 4 01-13-2010 06:59 PM
Problems with USB External Hard Drive on Slackware 12.1 TwinReverb Slackware 5 12-01-2008 05:17 AM
external enclosure for an internal hard drive vs external USB hard drive powah Linux - Hardware 1 03-10-2006 09:03 AM
Installing grub to external USB hard drive for later use as internal hard drive dhave Linux From Scratch 2 12-10-2005 08:48 AM
XS Drive II external USB hard drive/card reader max74 Linux - Hardware 7 10-21-2003 10:41 PM


All times are GMT -5. The time now is 01:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration