LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2009, 01:36 PM   #16
cheires
LQ Newbie
 
Registered: Aug 2009
Posts: 13

Rep: Reputation: 0

Well, that solution did work, but when i restarted my laptop,the black screen with a nonblinking cursor at the upper top left returned.
How can i make the changes permanent?
 
Old 09-03-2009, 01:52 PM   #17
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Quote:
Originally Posted by cg132 View Post

I have an old x1300 agp radeon running in vesa. If anyone finds another driver that works on slack13 let me know, I'm having lots of problems as well.
You will need to use the open source drivers, or downgrade your X server to 1.5.* and your kernel to 2.6.27.

Adam

Last edited by adamk75; 09-03-2009 at 01:55 PM.
 
Old 09-03-2009, 01:54 PM   #18
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Quote:
Originally Posted by CrowTRobot View Post
The reason I wanted them in the first place was the driver it's using (I don't know what it is using, I haven't figured out this new xorg.conf-less system) is acting strange. First I noticed it doesn't have OpenGL support, programs like the BlueMarble widget in KDE4 make this clear. Another problem is that after a while of using KDE4, whenever I open a new window (regardless of the program) my entire screen changes to something like inverted colors but worse picture quality, making it barely usable. However, when I close the new window, everything changes back to normal!

I tried using an xorg.conf with the 'radeon' and 'radeonhd' drivers and the same problems happen with both. I haven't tried using anything but KDE4, I'll see if the same color change thing happens in fluxbox and get back to you.

<snip>

I still don't have OpenGL support though.
The BlueMarble widget requires GLSL, as I recall, and that isn't supported with the open source drivers yet, however you should still have 3D acceleration. What is the output of 'glxinfo | grep -i renderer' ?

Adam
 
Old 09-04-2009, 01:51 PM   #19
gusluke
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 1
Quote:
Originally Posted by cheires View Post
Well, that solution did work, but when i restarted my laptop,the black screen with a nonblinking cursor at the upper top left returned.
How can i make the changes permanent?

Maybe you have to block the automatic load of radeon and drm modules from startup..

and then auto load de fglrx module
 
Old 09-04-2009, 03:14 PM   #20
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Rep: Reputation: 50
Sorry, didn't read the above posts carefully. Never mind about PAE...

@gusluke:
can you explain step 5 to me? what does that do? Also, can you post your xorg.conf file?

1) sh ati-driver-installer-9-8-x86.x86_64.run --buildpkg Slackware/All
2) installpkg fglrx-module-8.64-x86_64-1_kernel_2.6.29.6.tgz fglrx-x740_64a-8.64-x86_64-1.tgz
3) aticonfig --initial
4) aticonfig --overlay-type=Xv
5) cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb
6) rmmod radeon
7) rmmod drm
8) (donīt know if itīs ok, but i do it) gunzip /lib/modules/2.6.29.6/external/fglrx.ko.z (maybe zipped work too, donīt know)
9) depmod -a
10) modprobe fglrx

Last edited by vik; 09-04-2009 at 03:25 PM.
 
Old 09-05-2009, 04:42 AM   #21
cheires
LQ Newbie
 
Registered: Aug 2009
Posts: 13

Rep: Reputation: 0
Quote:
Originally Posted by gusluke View Post
Maybe you have to block the automatic load of radeon and drm modules from startup..

and then auto load de fglrx module
Hi there,

The fglrx module is loaded at startup, and the drm and radeon modules no longer exist.
To start the X system, i use KDM, that produces log files.

The error message is "fglrx: No matching Device sectiona for instance (Bus ID PCI:0@1:0:1) found"

I i reinstall the driver using this instructions


1) sh ati-driver-installer-9-8-x86.x86_64.run --buildpkg Slackware/All
2) installpkg fglrx-module-8.64-x86_64-1_kernel_2.6.29.6.tgz fglrx-x740_64a-8.64-x86_64-1.tgz
3) aticonfig --initial
4) aticonfig --overlay-type=Xv
5) cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb
6) rmmod radeon
7) rmmod drm
8) (donīt know if itīs ok, but i do it) gunzip /lib/modules/2.6.29.6/external/fglrx.ko.z (maybe zipped work too, donīt know)
9) depmod -a
10) modprobe fglrx

It works fine...
Anyone has some idea how to solve this?
 
Old 09-05-2009, 05:46 AM   #22
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
Thank you very much, gusluke.
Thanks to you OpenGL now works fine with my Slackware64-13.0 installation on ASUS X53K series F3KA laptop (Radeon 2600 HD).
I also had some trouble finding unified drivers location (any link please?)
So here it is: https://a248.e.akamai.net/f/674/9206...x86.x86_64.run
Earlier I feared to look at ATI cards for Linux drivers reason. But now I see it works fine with Linux. Good to know that

Last edited by kornerr; 09-05-2009 at 05:48 AM.
 
Old 09-05-2009, 10:15 AM   #23
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 223

Rep: Reputation: 17
Anyone managed to install the driver on Slack32 ? and how!
 
Old 09-05-2009, 08:36 PM   #24
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Rep: Reputation: 50
@Bller: you might be having the problem I did with Slackware 12.2 if you compile in PAE 64G under the kernel options. Try recompiling with that set to 4G and see if it works.

Here's how I did it (just finished installing 64 bit today, accidentally grabbed the 32-bit version previously). Hopefully it will continue to work...
I recompiled the kernel like this:
cd /usr/src/linux
make mrproper
cp /boot/config-generic-2-6-29 .config
make oldconfig
make menuconfig
general setup->local version -mine (my preference to keep the modules uncluttered between kernels)
processor type->K8 (I have an AMD processor)
File Systems->ext4 and ext3 built-in (so I won't need an initrd)
check under Bus Options that msi is enabled (saw this in this thread)
check under Processor Type that PAT is not enabled under mtrr (saw this in another thread)
make -j4
make modules_install
make install
change the links in /boot for System.map, config, and vmlinuz
update /etc/lilo.conf to add an entry for the new kernel

reboot, make sure everything comes up.
edit /etc/inittab, make sure it starts in run level 3.
reboot again so it unloads the open source drivers radeon and drm (not sure if there's any other modules that would conflict with fglrx, so I just reboot instead of rmmod)

at command prompt as root:
sh ati-driver-installer-9-8-x86.x86_64.run --buildpkg Slackware/All
installpkg fglrx-module*tgz fglrx-x740*tgz
aticonfig --initial
aticonfig --overlay-type=Xv
init 4
running glxgears works, although I didn't see anything about Direct Rendering: yes in glxinfo or fglrxinfo output.

Last edited by vik; 09-05-2009 at 08:46 PM.
 
Old 09-06-2009, 05:20 AM   #25
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 223

Rep: Reputation: 17
Quote:
Originally Posted by vik View Post
@Bller: you might be having the problem I did with Slackware 12.2 if you compile in PAE 64G under the kernel options. Try recompiling with that set to 4G and see if it works.

Here's how I did it (just finished installing 64 bit today, accidentally grabbed the 32-bit version previously). Hopefully it will continue to work...
I recompiled the kernel like this:
cd /usr/src/linux
make mrproper
cp /boot/config-generic-2-6-29 .config
make oldconfig
make menuconfig
general setup->local version -mine (my preference to keep the modules uncluttered between kernels)
processor type->K8 (I have an AMD processor)
File Systems->ext4 and ext3 built-in (so I won't need an initrd)
check under Bus Options that msi is enabled (saw this in this thread)
check under Processor Type that PAT is not enabled under mtrr (saw this in another thread)
make -j4
make modules_install
make install
change the links in /boot for System.map, config, and vmlinuz
update /etc/lilo.conf to add an entry for the new kernel

reboot, make sure everything comes up.
edit /etc/inittab, make sure it starts in run level 3.
reboot again so it unloads the open source drivers radeon and drm (not sure if there's any other modules that would conflict with fglrx, so I just reboot instead of rmmod)

at command prompt as root:
sh ati-driver-installer-9-8-x86.x86_64.run --buildpkg Slackware/All
installpkg fglrx-module*tgz fglrx-x740*tgz
aticonfig --initial
aticonfig --overlay-type=Xv
init 4
running glxgears works, although I didn't see anything about Direct Rendering: yes in glxinfo or fglrxinfo output.
Strange but i didn`t compile anything before.( Don`t really know what compiling really does :-s ). Is it necessary for the driver to work?
 
Old 09-06-2009, 10:24 AM   #26
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Rep: Reputation: 50
I was under the impression you recompiled the kernel. If not, then my suggestion won't help you as the stock 32-bit kernel has PAE set correctly. What happens when you try to install it with Slackware 32-bit?
 
Old 09-06-2009, 02:35 PM   #27
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 223

Rep: Reputation: 17
Quote:
Originally Posted by vik View Post
I was under the impression you recompiled the kernel. If not, then my suggestion won't help you as the stock 32-bit kernel has PAE set correctly. What happens when you try to install it with Slackware 32-bit?
Well i didn`t really try, i`m afraid i`ll broke something again, and destroy my system.
 
Old 09-08-2009, 08:49 PM   #28
toastytoast
LQ Newbie
 
Registered: Jan 2009
Posts: 5

Rep: Reputation: 0
all i had to do was just use the --buildpkg Slackware/All then install it with installpkg works just fine when i type startx it goes to the black screen for maybe a second or 2 then goes right into x
i both glxgears and fgl_glxgears work
 
Old 09-14-2009, 05:31 AM   #29
cheires
LQ Newbie
 
Registered: Aug 2009
Posts: 13

Rep: Reputation: 0
Does anyone had instealled successfully the 9.9 ATI Driver?
I try to install it but there was an error, the same as in the 9.8.

the " fglrx: No matching Device sectiona for instance (Bus ID PCI:0@1:0:1) found" error
 
Old 09-14-2009, 06:36 AM   #30
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Quote:
Originally Posted by cheires View Post
Does anyone had instealled successfully the 9.9 ATI Driver?
I try to install it but there was an error, the same as in the 9.8.

the " fglrx: No matching Device sectiona for instance (Bus ID PCI:0@1:0:1) found" error
I doubt that's the source of the problem. Can you please show us your full /var/log/Xorg.0.log file?

Adam
 
  


Reply

Tags
ati, graphics, linux, opengl, radeon, slackware, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
system freeze with Slackware 12.0 BCarey Slackware 22 07-29-2008 08:20 PM
Total system freeze on ATI 3D driver enable wdingus Linux - Hardware 3 12-24-2007 11:26 AM
Slackware 12 System Freeze arubin Slackware 13 07-10-2007 08:44 AM
looking for a driver that doesnt freeze the system Tuxman8898 Linux - Wireless Networking 2 04-26-2005 03:55 PM
ati radeon freeze kde on slackware 10 fax8 Slackware 21 02-23-2005 05:27 PM


All times are GMT -5. The time now is 09:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration