LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-31-2009, 04:21 PM   #1
Maestro485
Member
 
Registered: Apr 2004
Location: Pittsburgh
Distribution: Slackware
Posts: 136

Rep: Reputation: 16
Slackware 13 and NVidia Compositing


I upgraded my desktop to the new Slackware today, and it's definitely very cool. However, when I went to enable desktop effects in the display settings, I'm told this:

Compositing is not supported on your system. Required X extensions (XComposite and XDamage) are not available.

I have an old NVidia GeForce 5200 and I'm using the most recent NVidia driver from their website. Using this command:

nvidia-xconfig --add-argb-glx-visuals --allow-glx-composite --composite --disable-glx-root-clipping --damage-events --randr-rotation --render-accel --nvagp=agpgart

I basically tried enabling everything I could think of, and the xorg.conf file was updated appropriately, but still no luck.

I also have xinerama enabled, and it's working fine.

Any ideas?
 
Old 08-31-2009, 04:31 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Xinerama and compositing are mutually exclusive as far as I know. Can't you use xrandr instead of xinerama?

Eric
 
Old 08-31-2009, 04:52 PM   #3
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 422

Rep: Reputation: 58
Quote:
Originally Posted by Maestro485 View Post
I have an old NVidia GeForce 5200 and I'm using the most recent NVidia driver from their website.
The "FX" 5200 uses NVIDIA-Linux-x86-173.14.20.pkg1.run

Did you run nvidia-xconfig without all the options? That's all I did on my system. On reboot, the automagic stuff did the rest.

I also recommend using the SlackBuild for installing the nvidia driver. As usual, alter the slackbuild for your nvidia driver version (and pkg#). Since I installed the nvidia driver with the .run package the first time I removed the .run package with --uninstall and renamed the xorg.conf before reinstalling the nvidia driver with the slackbuild
 
Old 08-31-2009, 05:14 PM   #4
Maestro485
Member
 
Registered: Apr 2004
Location: Pittsburgh
Distribution: Slackware
Posts: 136

Original Poster
Rep: Reputation: 16
Ahhh, I see. I had previously had it configured as a dual-head system, but since KDE4 doesn't support that I just checked the "Enable Xinerama" box in the nvidia-settings dialog. I didn't realize there was another way to do it.

Thanks for the help!
 
Old 08-31-2009, 06:12 PM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Quote:
Originally Posted by Maestro485 View Post
Ahhh, I see. I had previously had it configured as a dual-head system, but since KDE4 doesn't support that I just checked the "Enable Xinerama" box in the nvidia-settings dialog. I didn't realize there was another way to do it.

Thanks for the help!
Check the "krandrtray" program of KDE4.

Eric
 
Old 09-21-2009, 01:16 PM   #6
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
Resolution

I have the same setup as the OP. I followed the steps here, and have tried several other things. While I can get X to run and KDE to configure, I can't seem to get the 1680x1050 resolution that I had set up on KDE 3.5.10. My monitor's native resolution is 1680x1050 so everything look so much better that way. I know it must be possible, but X doesn't seem to want to pick up Modes or ModeLine in xorg.conf.
Also, there is no option for that resolution in nvidia-settings. The highest it goes is 1600x1200.

Currently, I am using the nvidia driver and kernel (legacy) packages from Slackbuilds and have xorg.conf set up from nvidia-xconfig.

Slackware 13, nVidia FX5200

Thanks,
Bert

PS Let me know if it is appropriate to bump or if this warranted a new thread. Nettiquitte is not my strong suit (although I'm working on it.)
 
Old 09-21-2009, 01:27 PM   #7
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
I think I see what's going on here. I have a ViewSonicVX2235WM Monitor using a DVI connection. For whatever reason the EDID seems to be indicating a 1600x1200 native resolution. It looks like the problem is actually a monitor problem and not x or nvidia. Now how to address this. Do I look to correcting the incorrect information from the monitor or look to overriding the settings. I believe that xorg.conf overrode the settings with Slackware 12.2. That may be the way to go.
 
Old 09-22-2009, 12:11 PM   #8
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
The ViewSonic vx2235wm sends a different EDID for the analogue and digital interfaces. The digital is dysfunctional in that it limits the pixel clock to 135.0.

I added to the Device section in xorg.conf: Option "ModeValidation" "DFP-0: NoMaxPClkCheck"

Restarted X and finally...1680x1050.

One more thing...for almost two years I have been trying to get this resolution in Windows and could not do it. Windows has no xorg.conf to edit so if it won't work, that's that.

I thought I would post this since I found numerous occasions that ppl were having this issue with the dual head (DVI VGA) nVidia cards with the FX5200 GPU.

I hope this is helpful.
Bert
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't use compositing when using dual monitors! baldurpet Linux - Hardware 3 08-29-2009 04:43 AM
Slackware 64 -current / KDE 4.2.4 / lost compositing. botnet Slackware 22 07-21-2009 01:54 PM
compositing window manager problems pepsimachine15 Linux - Software 5 06-30-2008 11:22 PM
display compositing weird behavior verbose Linux - General 1 01-31-2008 09:12 PM
Xcomposite extension, Compositing manager? NightSky Linux - Newbie 2 09-05-2007 07:57 PM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration