LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-05-2009, 01:54 AM   #1
Switch7
Member
 
Registered: Sep 2009
Posts: 92

Rep: Reputation: 16
Post Slackware 13 64bit: Using slackpkg upgrade-all messes computer up.


I wanted to keep my computer and security up to date but whenever I try to upgrade slackware 13 64bit, my computer doesn't seem to be working anymore.

I looked up through the forum and found these but none of them was able to help:
http://www.linuxquestions.org/questi...kg+upgrade-all
http://www.linuxquestions.org/questi...kg+upgrade-all
http://www.linuxquestions.org/questi...kg+upgrade-all
http://www.linuxquestions.org/questi...kg+upgrade-all
http://www.linuxquestions.org/questi...kg-...-745386/


After update finishes, my terminal, firefox, etc. doesn't work anymore. Doing a shutdown -h now doesn't respond either. The next time I restart it, slackware is still seen on LILO and after I select it, I usually get *Myhostname Login: but I now get (none) Login: and I can't login anymore.


I unchecked one of the mirror below "slackware 13" in slackpkg and typed

Code:
slackpkg update
slackpkg upgrade-all

In the upgrade menu, I'm getting

Code:
Choose packages to upgrade:
[*] bash-4.0.024-i486-1.txz
[*] bison-1.35-i386-1.txz
[*] blackbox-0.70.1-i486-2.txz
[*] kernel-firmware-2.6.30.5-noarch-1_testing.txz
[*] kernel-source-2.6.30.5_smp-noarch-1_testing.txz
[*] links-0.98-i386-2.txz
[*] mesa-7.5-i486-1_slack13.0.txz
[*] mozilla-firefox-3.5.3-i686-1.txz
[*] php-5.2.11-i486-1_slack13.0.txz
[*] samba-3.2.15-i486-1_slack13.0.txz
[*] seamonkey-1.1.18-i486-1.txz
[*] seamonkey-solibs-1.1.18-i486-2.txz
[*] xf86-video-intel-2.5.1-i486-1.txz
I clicked <ok> then I was asked to keep old files and I typed "k" to keep old files. After I typed "k" and update finished, my computer stopped working so I reinstalled it again.


I reinstalled it again and did
Code:
slackpkg update
slackpkg install-new
slackpkg upgrade-all
For the install-new, I get

Code:
Looking for NEW packages to install. Please wait... DONE

No packages match the pattern for install. Try:

/usr/sbin/slackpkg upgrade|reinstall
After that, I did the same thing above but it turned out the same so I reinstalled it again.

I tried again and did

Code:
slackpkg update
slackpkg upgrade patches
and got:

Code:
[*] mesa-7.5-i486-1_slack13.0.txz
[*] mozilla-firefox-3.5.3-i686-1.txz
[*] php-5.2.11-i486-1_slack13.0.txz
[*] samba-3.2.15-i486-1_slack13.0.txz
[*] seamonkey-1.1.18-i486-1.txz
[*] seamonkey-solibs-1.1.18-i486-2.txz
After it finished, my terminal was working perfectly but firefox that I tried opening never worked. I can still log back in and startx and what not but firefox doesn't work at all.

I reinstalled it again but I wanted to wait for some answers before trying again. Thank you for reading.
 
Old 10-05-2009, 02:59 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
You say you are running Slackware 64-bit, yet the output from slackpkg commands show that it is trying to install the 32-bit packages on your system.
Are you using an old version of slackpkg and/or configuration files?

Try upgrading to the latest version of slackpkg (it is in slackware64-13.0 so a re-install of Slackware should do it) and then make sure you are using the new files it installed into /etc/slackpkg . Usually, all you need to do is uncomment the URL for one of the mirrors for slackware64.

Eric
 
Old 10-05-2009, 04:44 AM   #3
Switch7
Member
 
Registered: Sep 2009
Posts: 92

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Alien Bob View Post
You say you are running Slackware 64-bit, yet the output from slackpkg commands show that it is trying to install the 32-bit packages on your system.
Are you using an old version of slackpkg and/or configuration files?

Try upgrading to the latest version of slackpkg (it is in slackware64-13.0 so a re-install of Slackware should do it) and then make sure you are using the new files it installed into /etc/slackpkg . Usually, all you need to do is uncomment the URL for one of the mirrors for slackware64.

Eric
Thank you for the reply. I got it fixed and everything is working fine now. I just realized slackware 13 64bit mirror was all the way on the bottom. I accidentally uncommented the slackware 13 32bit mirror which was on the way top. I can't believe I missed this comment... I apologize for not reading the entire message that was clearly stated on the top. English is my second language so I need to re-read often to understand it.

Also, just a last question that I been having trouble with ever since I switch to 64bit. I'm not sure if I should've made a new thread but I thought it'll bad to fill up the front page from one person.

I'm getting Slackware 01 00 00 00 just like the image in this thread: http://www.linuxquestions.org/questi...-00-00-750987/

Quote:
Or convert it from binary to decimal.
I know this is the solution and I searched more on this but I can't seem to find the correct solution to this problem. I'm not sure which text file or other configuration I need to edit to make it convert it from binary to decimal so my computer would read Slackware Linux instead of 01 00 00 00.
 
Old 10-05-2009, 05:00 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
If you regard the "01 00 00 00" in the text "Slackware 01 00 00 00" as a binary number and convert that to our decimal system, then you get the number "64".
So basically, the LILO boot screen says "Slackware64" when you install the 64-bit version, and it would still show "Slackware Linux" if you install the 32-bit version.

Eric
 
Old 10-05-2009, 05:07 AM   #5
Switch7
Member
 
Registered: Sep 2009
Posts: 92

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Alien Bob View Post
If you regard the "01 00 00 00" in the text "Slackware 01 00 00 00" as a binary number and convert that to our decimal system, then you get the number "64".
So basically, the LILO boot screen says "Slackware64" when you install the 64-bit version, and it would still show "Slackware Linux" if you install the 32-bit version.

Eric
I see, so the 01 00 00 00 is normal for the 64bit. Thank you very much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How Do You Upgrade Slackware 12.2 To 64bit hkothari Slackware 6 07-01-2009 05:40 PM
Upgrade with slackpkg STARHARVEST Slackware 11 05-17-2008 07:07 PM
Using slackpkg to Upgrade to Slackware-Current x94qvi Slackware 8 10-20-2007 07:53 PM
Upgrade to 2005LE messes up a lot! vintermann Mandriva 3 08-26-2005 05:04 AM
slackpkg upgrade _mu_ Slackware 9 01-29-2004 08:28 PM


All times are GMT -5. The time now is 01:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration