LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-25-2010, 10:24 PM   #1
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
Slackware 13 (64 bit) Wireless with WPA2-PSK and WPA Cipher set to AES


I had Slackware 13 (64 bit) installed and working until I had a hardware failure. My CPU fan quit and while removing it the fan swung and knocked a part off the motherboard. Sent the motherboard back for repair (MSI P43 Neo F) and when I received it back it was a MSI P45 Neo F (most likely reconditioned) basically the same motherboard but to be safe I backed up to a data drive and did a reinstall to make sure there was no missing modules or anything. Prior to formatting and reinstalling I had wireless networking working fine using a Belkin F5D7050 USB device that uses the rt2500usb drivers. With the new motherboard with same wireless device I can't seem to get it working, the only thing that changed from time the motherboard went out for repair and I received it back is we changed the router (Trendnet 639GR) because a few of us in the house now have wireless N devices. The new router is configured as follows
Quote:
DHCP = yes
DHCP Addresses = 192.168.1.5 - 192.168.1.199
router address = 192.168.1.1
SSID = Disfunctional
Security Mode = WPA2-PSK
WPA Cipher = AES (needed for N devices to get over 54mbs)
On the Slackware box I use static addresses 192.168.1.200 and above if I need additional addresses. With not having wireless working I am manually entering the information so I will try my best to keep it correct.
Quote:
/etc/rc.d/rc.inet1.conf

GATEWAY="192.168.1.1"

IFNAME[4]="WLAN0"
IPADDR[4]="192.168.1.200"
NETMASK[4]="255.255.255.0"
WLAN_ESSID[4]="Disfunctional"
WLAN_MODE[4]="Master|Managed" (router says master but tried both)
WLAN_RATE[4]="auto"
WLAN_CHANNEL[4]="auto"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
WLAN_WPACONF[4]="/etc/wpa_supplicant.conf"
WPAOPTS[4]="-Dwext -iwlan0 -c/etc/wpa_supplicant.conf"

/etc/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
country=US

network={
scan_ssid=0
ssid="Disfunctional"
proto="WPA" (tried WPA2 as well)
key_mgmt="WPA-PSK" (tried WPA2-PSK as well)
pairwise="TKIP" (tried AES but get error)
group=TKIP WEP104 WEP40
psk="edited and removed"
priority=5
}

network={
key_mgmt=NONE
priority=0
}

even though it suggested that I not use /etc/rc.d/rc.woreless.conf tried it on the chance it would work, here is what I did in there.

VERBOSE=1
case "$HWADDR" in

*)
INFO="Trendnet Router"
ESSID="Disfunctional"
;;

even tried changing *) to the first part of the MAC address of the router as follows

00:14:D1:*)
INFO="Trendnet Router"
ESSID="Disfunctional"
;;
if I unplug the wireless device and run a tail on the log I get the following:
Quote:
usb 1-4: new high speed USB device using ehci_hcd and address 4
usb 1-4: New USB device found, idVendor=05d, idProduct=7050
usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-4: Product: Belkin 54g USB Network Adapter
usb 1-4: Manufacturer: Belkin
usb 1-4: configuration #1 chosen from 1 choice
wmaster0 (rt2500usb): not using net_device_ops yet
wlan0 (rt2500usb): not using net_device_ops yet
Registered led device: rt2500usb-phy:radio
WPA authentication did not complete, try running '/etc/rc.d/rc.inet1 wlan0_start' in a few seconds.
ADDRCONF(NETDEV_UP): wlan0: link is not ready
/etc/rc.d/rc.inet1: /sbin/ifconfig wlan0 192.168.1.200 broadcast 192.168.1.255 netmask 255.255.255.0
/etc/rc.d/rc.inet1: /sbin/route add default gw 192.168.1.1 metric 1
Listening on interface #4 wlan0, 192.168.1.200#123 Enabled
I know the rt2500usb modules are loaded, not sure if they working because I am yet to see the light blink on the usb wireless device but I am thinking it is old enough the bulb may be burnt out (I could be wrong).
Quote:
lsmod | grep rt

rt2500usb 22116 0
rt73usb 27140 0
rt2x00usb 11296 2 rt2500usb, rt73usb
rt2x00lib 30816 3 rt2500usb, rt73usb, rt2x00usb
rfkill 11316 2 rt2x00lib
led_class 4360 1 rt2x00lib
mac80211 171288 4 p54usb, p54common, rt2x00usb, rt2x00lib
rtc_cmos 11928 0
parport_pc 28200 1
rtc_core 19652 1 rtc_cmos
cfg80211 42064 2 rt2x00lib, mac80211
rtc_lib 2880 1 rtc_core
parport 36752 3 lp, ppdev, parport_pc
No matter what I do when I list iwconfig the Access Point for wlan0 is ALWAYS Not-Associated.
Quote:
iwlist wlan0 scan
wlan0 Scan completed:
cell 01 - Address: 00:14:D1:C7:A3:10
ESSID: "Disfunctional"
Mode: Master
Channel: 6
Frequency: 2.437 GHz (Channel 6)
Quality=52/100 Signal level: -46 dBm
Encryption key: on
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher:CCMP
Pairwise Cipher (1): PSK
Authentication Suites: (1): PSK
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
IE: Unknown: series of numbers
Bit Rates: 1mb/s; 2mb/s; 5.5mb/s; 11mb/s; 9mb/s;
18mb/s; 36mb/s; 54mb/s; 6mb/s; 12mb/s;
24mb/s; 48mb/s
Extra:tsf=0000006b5d6f1a5a
Extra: Last beacon: 445ms ago
My ifconfig and iwconfig look like this (I issued a ifconfig eth0 down that's why it not showing)
Quote:
ifconfig
lo Link encap: Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:48 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3260 (3.1 Kib) TX bytes:3260 (3.1 Kib)

wlan0 Link encap: Ethernet HWaddr 00:11:50:89:26:e9
inet addr:192.168.1.200 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap: UNSPEC HWaddr 00-11-50-89-26-E9-00-00-00-00-00-00-00-00-00-00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

iwconfig
lo no wireless extensions
eth0 no wireless extensions
wmaster0 no wireless extensions
wlan0 IEEE 802.11bg ESSID: "Disfunctional"
Mode: Managed Frequency: 2.457 GHz Access Point: Not-Associated
Tx-Power=19 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
I am well aware that the wpa_supplicant.conf file and the router have encryption on but the iwconfig for wlan0 has it set to off but when I set it nothing shows up.
Quote:
iwconfig wlan0 enc on
iwconfig wlan0 key on
wlan0 IEEE 802.11bg ESSID: "Disfunctional"
Mode: Managed Frequency: 2.457 GHz Access Point: Not-Associated
Tx-Power=19 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

stopping and then starting /etc/rc.d/rc.inet1 produces theese errors

/etc/rc.d/rc.inet1 stop
/etc/rc.d/rc.inet1 start
/etc/rc.d/rc.inet1: wlan0 information: 'Fill with your own settings..'
Error for wireless request "Set Nickname" (8B1C) :
SET failed on device wlan0 ; Operation not supported.
Any help on this would be greatly appreciated. Thank you in advance.
 
Old 01-26-2010, 12:33 AM   #2
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Original Poster
Rep: Reputation: 15
I have found a partial fix/workaround but I am still missing something. I found out my router supports multiple SSID's so I created another one for Slackware to connect to set security mode to wpa-psk and wpa cipher to tkip. then ran
Quote:
wpa_passphrase Slackware-SRV somestupidpassword
I then pasted the output of the command psk line to wpa_supplicant.conf and rc.inet1.conf where it was required, I edited /etc/resolv.conf and set search and nameserver(s) to my isp and I am connected to the router (the client list shows the MAC address of the wireless device) but I can't ping the router or any FQDN or IP outside of the slackware box. I still get the following errors if I restart /etc/rc.d/rc.inet1
Quote:
/etc/rc.d/rc.inet1: wlan0 information: 'Fill with your own settings...'
Error for wireless request "Set Mode" (8B06):
Set failed on device wlan0 ; Invalid argument.
Error for wireless request "Set Nickname" (8B1C):
Set failed on device wlan0 ; Operation not supported.
and now if I do a iwconfig wlan0 it shows the new ESSID and the mac address of the router for access point and the encryption key. Only thing I see there that I don't think is right is Mode:Managed should be Mode:Master (according to the router) but I get the error on that with a restart of rc.inet1 and Security mode:open I don't think this is right. If I do a route without "-n" it takes a while but still shows the IP of the router as gateway on the wlan0 device.
 
Old 01-26-2010, 02:09 AM   #3
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Original Poster
Rep: Reputation: 15
Fixed

I think it was the adapter, I switched the Belkin F5D7050 USB with a Belkin Wireless G Plus Mimo (which uses the same drivers) and it worked only thing is it uses wlan1 instead of wlan0 but that not a big deal. The other one worked in Windows so I will just switch them (lights work and all so it wasn't burnt out like I thought). It just weird because it the one I was using on the system originally but now it not working.
 
Old 01-26-2010, 05:52 AM   #4
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
If you wanted to have your new device listed as wlan0, remove /etc/udev/rules.d/70-persistent-net.rules. This file will be regenerated on reboot. The first wlan device connected gets wlan0, even if that device is removed and no longer used, the next one receives the name wlan1, and so on.

About your encryption, I've found some wireless chipsets, and even revisions of the same chipset, have issues with AES encryption. With my rt73 wireless device I can connect to WPA2/TKIP, but not WPA2/AES on a Belkin router (forget the model). However, it will connect using either TKIP or AES on my Linksys WRT54GL. My Intel 4965 doesn't have an issue connecting to either router. Not sure if it's a problem with the router, the driver for the rt73, or just a limitation of the rt73.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scripts (kommander and command line) to start wireless devices with wpa/wpa2/wpa-aes Fluxx Linux - Wireless Networking 4 06-28-2010 02:51 AM
Wireless encryption with Slackware 12.2 (WPA, WPA2): Best practice? gargamel Slackware 3 12-22-2008 03:42 PM
LXer: Configuring WPA2 (AES) in Slackware LXer Syndicated Linux News 0 08-15-2008 06:30 AM
CNet Wireless-G USB Dongle 54 Mbps 802.11g, WPA/AES/WPA2 compatible to SuSe 10.1? ungua Linux - Hardware 2 06-14-2007 05:31 AM
How do i set up WPA PSK with wpa supplicant and linuxant? Eleavings Linux - Wireless Networking 4 12-27-2004 11:24 AM


All times are GMT -5. The time now is 10:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration