LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-02-2010, 03:12 AM   #1
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
Slackware 13 (64 bit) IFNAME[4]="wlan0:1"


I have a fresh install of Slackware 13 64 bit, that all I have basically done is installed wireless with my desired encryption/security posted here: set up Apache with 2 Virtual Hosts (added 2 hosts to the /etc/hosts file and the Windows C:\Windows\System32\Driver\etc\hosts) Mysql and samba and changed the boot manager from Lilo to Grub2. Now if I set up an alias to my wireless device I get the following error:
Quote:
SIOCSIFFLAGS can not assign requested address
and it doesn't bring up the wlan0 device at all (normal one or the alias). BUT if I wait till it finishes booting and then issue:
Quote:
sudo /sbin/ifconfig wlan0 192.168.1.200 up
sudo /sbin/ifconfig wlan0:1 192.168.1.201 up
and check ifconfig and iwconfig and the error logs it brings them up with no errors. Also if I assign the alias in /etc/rc.d/rc.local it brings it up on boot with NO errors, what am I doing wrong in the /etc/rc.d/rc.inet1.conf file that it errors out on boot but I can do it from command line or the /etc/rc.d/rc.local file and it works perfectly? Only other thing I did was edit the start section of /etc/rc.d/rc.inet1 so that it loads in the background and I get a faster boot time.
 
Old 02-02-2010, 04:50 AM   #2
santaslilslacker
LQ Newbie
 
Registered: Nov 2007
Distribution: Slackware64_current
Posts: 28

Rep: Reputation: 4
Open /etc/rc.d/rc.inet1.conf and add somewhere following lines:

/sbin/ifconfig wlan0:1 192.168.1.201 netmask 255.255.255.0
/sbin/route add -host 192.168.1.201 dev lo

Assuming your wlan0 is already properly configured, everytime you boot your machine that alias will be up & running
Regards,
 
Old 02-02-2010, 06:20 AM   #3
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Original Poster
Rep: Reputation: 15
Unfortunatly that didn't work either. What I did do after I tried your suggestion was changed my wlan0 device from IFNAME[4] to IFNAME[2] with all the accompanying settings and then used IFNAME[3] for the alias device like so
Quote:
# Config information for wlan:
IFNAME[1]="wlan0"
IPADDR[1]="192.168.1.200"
NETMASK[1]="255.255.255.0"
WLAN_ESSID[1]="Disfunctional"
WLAN__RATE[1]="auto"
WLAN_CHANNEL[1]="auto"
WLAN_WPA[1]="wpa_supplicant"
WLAN_DRIVER[1]="wext"
WLAN_WPACONF[1]="/etc/wpa_supplicant.conf"
#USE_DHCP[1]=""
#DHCP_HOSTNAME[1]=""

# Config information for wlan0:1:
IFNAME[2]="wlan0:1"
IPADDR[2]="192.168.1.201"
NETMASK[2]="255.255.255.0"
#USE_DHCP[2]=""
#DHCP_HOSTNAME[2]=""
I still get the error but BOTH the device and the alias come up on boot, well let me re-word that. While I sit and watch it boot I get the "SIOCSIFFLAGS can not assign requested address" error but if I view the /var/log/messages error log file there is no error for the wlan0 or wlan0:1 device. I didn't use IFNAME[0] by chance I ever need/want to use a wired device. Still strange that I get the error and they both come up.
 
Old 02-02-2010, 07:34 AM   #4
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
From the IP-Alias Howto in /usr/src/doc/Linux-HOWTOs:
Quote:
3. Troubleshooting: Questions and Answers

3.1. Question: How can I keep the settings through a reboot?

Answer: Whether you are using BSD-style or SysV-style (Redhat?? for example)
init, you can always include it in /etc/rc.d/rc.local. Here's what I have on
my SysV init system (Redhat?? 3.0.3 and 4.0):

My /etc/rc.d/rc.local: (edited to show the relevant portions)
#setting up IP alias interfaces
echo "Setting 172.16.3.1, 172.16.3.10, 172.16.3.100 IP Aliases ..."
/sbin/ifconfig lo 127.0.0.1
/sbin/ifconfig eth0 up
/sbin/ifconfig eth0 172.16.3.1
/sbin/ifconfig eth0:0 172.16.3.10
/sbin/ifconfig eth0:1 172.16.3.100
#setting up the routes
echo "Setting IP routes ..."
/sbin/route add -net 127.0.0.0
/sbin/route add -net 172.16.3.0 dev eth0
/sbin/route add -host 172.16.3.1 eth0
/sbin/route add -host 172.16.3.10 eth0:0
/sbin/route add -host 172.16.3.100 eth0:1
/sbin/route add default gw 172.16.3.200
Hope that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is "sticky bit mode" , "SUID" , "SGID" augustus123 Linux - General 10 08-03-2012 05:40 AM
Shouldn't "Slackware64" Become just "Slackware" and 32-bit Become "Slackware32"? foodown Slackware 6 06-23-2009 02:24 PM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 08:11 PM
Wireless chip is displayed as "Ath0" instead of "wlan0" with Belkin F5D7000 ceramicsushi Linux - Wireless Networking 4 04-06-2006 12:26 AM
What do you recommend ""I want to built my Pc using AMD 64 bit."" nuketemala Linux - Hardware 1 05-01-2004 02:32 AM


All times are GMT -5. The time now is 09:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration