LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-06-2012, 02:15 PM   #1
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 305

Rep: Reputation: 22
Question SlackWare 13.37 xfce + xkb-plugin == ctrl+alt+backspace not working


Hi.
Since some time ago I'm experiencing very annoying error: Ctrl+Alt+Backspace does not works.
After some experiments I have detected source of error - xkb-plugin - panel plugin which indicates current input language(I have 3 languages). But it causes it in some weird ways:
1. If I setup xkb-plugin, it appears Ctrl+Alt+Bksp does not works.
2. Then I shutting down X, go to ~/.config/xfce4/panel and erase xkb-plugin-13248295020.rc file. Starting xfce - Ctrl+Alt+Bksp works
3. Then when I accidentally(or on purpose) go to configuration of xkb-plugin, and close it(even without changes), Ctrl+Alt+Bksp stops to work in the same moment.
4. Then I shutdown X, clear xkb-plugin-13248295020.rc file, leaving there only one line never_modify_config=true (which was false ). Starting xfce, Ctrl+Alt+Bksp works again, even after visiting xkb-plugin configuration.
For now I'm pretty happy.

Now main questions:
1. How to achieve this without such messy operations?
2. Will it work long or will be broken at any random moment?(I mean if I go and configure something completely unrelated again)
 
Old 01-20-2012, 09:48 AM   #2
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Rep: Reputation: Disabled
AFAIK it is disabled by default in X. You should be able to permanently [en|dis]able it by setting

Code:
DontZap [false|true]
in xorg.conf (or /etc/xorg.conf.d/server.conf).

Code:
man x
man xorg.conf


But then, x does not always do what is promised in the documentation, so I whish you luck...
 
Old 01-20-2012, 10:28 AM   #3
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 305

Original Poster
Rep: Reputation: 22
As I said, it is enabled in my case. But something buggy: X, xfce, xkb-plugin, etc, disables it when xkb-plugin tries to save its configuration.
 
Old 01-23-2012, 01:12 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Rep: Reputation: Disabled
From my (limited) experience it is most probably X, thus I whished you luck . And I see very little chance to find out what exactly is causing this, except, perhaps, for the lucky stricke that some knowledgeable person looks in on this thread and enlightens us...

If you want to try something out, my suggestion would be to just "play" with the parameters in xorg.conf.
 
Old 01-23-2012, 07:00 AM   #5
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 305

Original Poster
Rep: Reputation: 22
JZL240I-U, it is not X fault, it is xfce4-xkb-plugin's fault - this is what I detected(and I have posted it in first message of this thread).
 
Old 01-23-2012, 07:05 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Rep: Reputation: Disabled
Quote:
Originally Posted by FeyFre View Post
...it is not X fault, it is xfce4-xkb-plugin's fault - this is what I detected(and I have posted it in first message of this thread).
I know what you wrote -- I just don't trust X to behave sensibly. Anyhow, it's your funeral , so good luck again.
 
Old 01-24-2012, 10:28 PM   #7
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,904

Rep: Reputation: Disabled
The problem is indeed in the xkb plugin. Have a look at /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf - this file sets up some default XkbOptions for the terminate sequence, and there's a commented example of at least one more. The problem is that the xkb plugin does not read in existing xkb options (which is not necessarily a bug on its own) - it just sets new ones depending upon the layout selected in the plugin. Ideally, the plugin would have a way to include some global stuff, but at the moment, it doesn't. I wanted to implement it myself, but after looking through the code, I was reminded (rather harshly, might I add) that I'm not nearly good enough with C to do that...
 
Old 01-25-2012, 01:06 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Rep: Reputation: Disabled
Is there a reason the maintainers created it that way? I mean, if the OP isn't the only one to complain about things there might (should?) be some intent to implement things the way they are, but what might that be?
 
Old 01-25-2012, 09:18 AM   #9
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,904

Rep: Reputation: Disabled
I think it was just an oversight.
 
  


Reply

Tags
xfce4


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+alt+backspace DaRkBoDoM Linux - Desktop 4 08-13-2010 09:16 AM
Ctrl+alt+backspace marsques Linux - Newbie 2 02-04-2009 01:05 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Cannot use Ctrl+Alt+Backspace to kill X tmorton Linux - Laptop and Netbook 3 11-11-2003 06:25 PM
Ctrl+Alt+Backspace Socka Linux - Newbie 8 05-18-2003 07:18 AM


All times are GMT -5. The time now is 02:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration