LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   SlackWare 13.37 xfce + xkb-plugin == ctrl+alt+backspace not working (http://www.linuxquestions.org/questions/slackware-14/slackware-13-37-xfce-xkb-plugin-%3D%3D-ctrl-alt-backspace-not-working-922462/)

FeyFre 01-06-2012 03:15 PM

SlackWare 13.37 xfce + xkb-plugin == ctrl+alt+backspace not working
 
Hi.
Since some time ago I'm experiencing very annoying error: Ctrl+Alt+Backspace does not works.
After some experiments I have detected source of error - xkb-plugin - panel plugin which indicates current input language(I have 3 languages). But it causes it in some weird ways:
1. If I setup xkb-plugin, it appears Ctrl+Alt+Bksp does not works.
2. Then I shutting down X, go to ~/.config/xfce4/panel and erase xkb-plugin-13248295020.rc file. Starting xfce - Ctrl+Alt+Bksp works :)
3. Then when I accidentally(or on purpose) go to configuration of xkb-plugin, and close it(even without changes), Ctrl+Alt+Bksp stops to work in the same moment.
4. Then I shutdown X, clear xkb-plugin-13248295020.rc file, leaving there only one line never_modify_config=true (which was false ). Starting xfce, Ctrl+Alt+Bksp works again, even after visiting xkb-plugin configuration.
For now I'm pretty happy.

Now main questions:
1. How to achieve this without such messy operations?
2. Will it work long or will be broken at any random moment?(I mean if I go and configure something completely unrelated again)

JZL240I-U 01-20-2012 10:48 AM

AFAIK it is disabled by default in X. You should be able to permanently [en|dis]able it by setting

Code:

DontZap [false|true]
in xorg.conf (or /etc/xorg.conf.d/server.conf).

Code:

man x
man xorg.conf

;)

But then, x does not always do what is promised in the documentation, so I whish you luck...

FeyFre 01-20-2012 11:28 AM

As I said, it is enabled in my case. But something buggy: X, xfce, xkb-plugin, etc, disables it when xkb-plugin tries to save its configuration.

JZL240I-U 01-23-2012 02:12 AM

From my (limited) experience it is most probably X, thus I whished you luck ;). And I see very little chance to find out what exactly is causing this, except, perhaps, for the lucky stricke that some knowledgeable person looks in on this thread and enlightens us...

If you want to try something out, my suggestion would be to just "play" with the parameters in xorg.conf.

FeyFre 01-23-2012 08:00 AM

JZL240I-U, it is not X fault, it is xfce4-xkb-plugin's fault - this is what I detected(and I have posted it in first message of this thread).

JZL240I-U 01-23-2012 08:05 AM

Quote:

Originally Posted by FeyFre (Post 4582058)
...it is not X fault, it is xfce4-xkb-plugin's fault - this is what I detected(and I have posted it in first message of this thread).

I know what you wrote -- I just don't trust X to behave sensibly. Anyhow, it's your funeral ;), so good luck again.

rworkman 01-24-2012 11:28 PM

The problem is indeed in the xkb plugin. Have a look at /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf - this file sets up some default XkbOptions for the terminate sequence, and there's a commented example of at least one more. The problem is that the xkb plugin does not read in existing xkb options (which is not necessarily a bug on its own) - it just sets new ones depending upon the layout selected in the plugin. Ideally, the plugin would have a way to include some global stuff, but at the moment, it doesn't. I wanted to implement it myself, but after looking through the code, I was reminded (rather harshly, might I add) that I'm not nearly good enough with C to do that...

JZL240I-U 01-25-2012 02:06 AM

Is there a reason the maintainers created it that way? I mean, if the OP isn't the only one to complain about things there might (should?) be some intent to implement things the way they are, but what might that be?

rworkman 01-25-2012 10:18 AM

I think it was just an oversight.


All times are GMT -5. The time now is 03:24 PM.