LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-26-2012, 05:26 AM   #1
elocholero
LQ Newbie
 
Registered: Jul 2012
Posts: 3

Rep: Reputation: Disabled
Slackware 13.37 X.Org troubles


I'm a having trouble starting 3d support for my video card (radeon x1550). What I determined is that only x.org drivers support my video card, because radeon dropped supporting it since last year kernel (or so). I feel a bit lost with this. Any ideas on what to install/reinstall/configure/what-else-logs-to-post would be highly appreciated

Quote:
/var/log/Xorg.0.log
Quote:
[ 32.723]
X.Org X Server 1.9.5
Release Date: 2011-03-17
[ 32.730] X Protocol Version 11, Revision 0
[ 32.732] Build Operating System: Slackware 13.37 Slackware Linux Project
[ 32.735] Current Operating System: Linux JOGURT_OWOCOWY 2.6.37.6-smp #2 SMP Sat Apr 9 23:39:07 CDT 2011 i686
[ 32.737] Kernel command line: BOOT_IMAGE=Linus ro root=806 vt.default_utf8=1
[ 32.739] Build Date: 18 March 2011 12:08:03AM
[ 32.742]
[ 32.750] Current version of pixman: 0.20.2
[ 32.752] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 32.757] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 32.764] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 26 10:11:10 2012
[ 32.808] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 32.810] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 32.827] (==) No Layout section. Using the first Screen section.
[ 32.827] (==) No screen section available. Using defaults.
[ 32.827] (**) |-->Screen "Default Screen Section" (0)
[ 32.827] (**) | |-->Monitor "<default monitor>"
[ 32.827] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 32.827] (==) Automatically adding devices
[ 32.827] (==) Automatically enabling devices
[ 32.828] (WW) The directory "/usr/share/fonts/local" does not exist.
[ 32.828] Entry deleted from font path.
[ 32.828] (WW) The directory "/usr/share/fonts/CID" does not exist.
[ 32.828] Entry deleted from font path.
[ 32.844] (==) FontPath set to:
/usr/share/fonts/TTF,
/usr/share/fonts/OTF,
/usr/share/fonts/Type1,
/usr/share/fonts/misc,
/usr/share/fonts/75dpi/:unscaled,
/usr/share/fonts/100dpi/:unscaled,
/usr/share/fonts/75dpi,
/usr/share/fonts/100dpi,
/usr/share/fonts/cyrillic
[ 32.844] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 32.844] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 32.844] (II) Loader magic: 0x81f0f80
[ 32.844] (II) Module ABI versions:
[ 32.844] X.Org ANSI C Emulation: 0.4
[ 32.844] X.Org Video Driver: 8.0
[ 32.844] X.Org XInput driver : 11.0
[ 32.844] X.Org Server Extension : 4.0
[ 32.845] (--) PCI:*(0:2:0:0) 1002:7183:174b:3000 rev 0, Mem @ 0xc0000000/268435456, 0xdfff0000/65536, I/O @ 0x0000e800/256, BIOS @ 0x????????/131072
[ 32.845] (--) PCI: (0:2:0:1) 1002:71a3:174b:3001 rev 0, Mem @ 0xdffe0000/65536
[ 32.845] (II) Open ACPI successful (/var/run/acpid.socket)
[ 32.845] (II) LoadModule: "extmod"
[ 32.867] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 32.869] (II) Module extmod: vendor="X.Org Foundation"
[ 32.869] compiled for 1.9.5, module version = 1.0.0
[ 32.869] Module class: X.Org Server Extension
[ 32.869] ABI class: X.Org Server Extension, version 4.0
[ 32.869] (II) Loading extension MIT-SCREEN-SAVER
[ 32.869] (II) Loading extension XFree86-VidModeExtension
[ 32.869] (II) Loading extension XFree86-DGA
[ 32.869] (II) Loading extension DPMS
[ 32.869] (II) Loading extension XVideo
[ 32.869] (II) Loading extension XVideo-MotionCompensation
[ 32.869] (II) Loading extension X-Resource
[ 32.869] (II) LoadModule: "dbe"
[ 32.870] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 32.871] (II) Module dbe: vendor="X.Org Foundation"
[ 32.871] compiled for 1.9.5, module version = 1.0.0
[ 32.871] Module class: X.Org Server Extension
[ 32.871] ABI class: X.Org Server Extension, version 4.0
[ 32.871] (II) Loading extension DOUBLE-BUFFER
[ 32.871] (II) LoadModule: "glx"
[ 32.872] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 32.874] (II) Module glx: vendor="X.Org Foundation"
[ 32.874] compiled for 1.9.5, module version = 1.0.0
[ 32.874] ABI class: X.Org Server Extension, version 4.0
[ 32.875] (==) AIGLX enabled
[ 32.875] (II) Loading extension GLX
[ 32.875] (II) LoadModule: "record"
[ 32.876] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 32.877] (II) Module record: vendor="X.Org Foundation"
[ 32.877] compiled for 1.9.5, module version = 1.13.0
[ 32.877] Module class: X.Org Server Extension
[ 32.877] ABI class: X.Org Server Extension, version 4.0
[ 32.877] (II) Loading extension RECORD
[ 32.877] (II) LoadModule: "dri"
[ 32.878] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 32.890] (II) Module dri: vendor="X.Org Foundation"
[ 32.890] compiled for 1.9.5, module version = 1.0.0
[ 32.890] ABI class: X.Org Server Extension, version 4.0
[ 32.890] (II) Loading extension XFree86-DRI
[ 32.890] (II) LoadModule: "dri2"
[ 32.891] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 32.892] (II) Module dri2: vendor="X.Org Foundation"
[ 32.892] compiled for 1.9.5, module version = 1.2.0
[ 32.892] ABI class: X.Org Server Extension, version 4.0
[ 32.892] (II) Loading extension DRI2
[ 32.892] (==) Matched ati as autoconfigured driver 0
[ 32.892] (==) Matched vesa as autoconfigured driver 1
[ 32.892] (==) Matched fbdev as autoconfigured driver 2
[ 32.892] (==) Assigned the driver to the xf86ConfigLayout
[ 32.892] (II) LoadModule: "ati"
[ 32.893] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[ 32.903] (II) Module ati: vendor="X.Org Foundation"
[ 32.903] compiled for 1.9.5, module version = 6.14.1
[ 32.903] Module class: X.Org Video Driver
[ 32.903] ABI class: X.Org Video Driver, version 8.0
[ 32.903] (II) LoadModule: "radeon"
[ 32.903] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[ 32.936] (II) Module radeon: vendor="X.Org Foundation"
[ 32.936] compiled for 1.9.5, module version = 6.14.1
[ 32.936] Module class: X.Org Video Driver
[ 32.936] ABI class: X.Org Video Driver, version 8.0
[ 32.936] (II) LoadModule: "vesa"
[ 32.937] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 32.947] (II) Module vesa: vendor="X.Org Foundation"
[ 32.947] compiled for 1.9.2, module version = 2.3.0
[ 32.947] Module class: X.Org Video Driver
[ 32.947] ABI class: X.Org Video Driver, version 8.0
[ 32.947] (II) LoadModule: "fbdev"
[ 32.949] (WW) Warning, couldn't open module fbdev
[ 32.949] (II) UnloadModule: "fbdev"
[ 32.949] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 32.952] (II) RADEON: Driver for ATI Radeon chipsets:

(..)long video cards list(..)

[ 32.956] (II) VESA: driver for VESA chipsets: vesa
[ 32.957] (--) using VT number 7

[ 32.967] (II) [KMS] Kernel modesetting enabled.
[ 32.967] (WW) Falling back to old probe method for vesa
[ 32.967] (II) RADEON(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 32.967] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
[ 32.967] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[ 32.967] (==) RADEON(0): Default visual is TrueColor
[ 32.967] (==) RADEON(0): RGB weight 888
[ 32.967] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[ 32.967] (--) RADEON(0): Chipset: "ATI Radeon X1300/X1550" (ChipID = 0x7183)
[ 32.967] (II) RADEON(0): PCIE card detected
[ 32.967] drmOpenDevice: node name is /dev/dri/card0
[ 32.967] drmOpenDevice: open result is 11, (OK)
[ 32.967] drmOpenByBusid: Searching for BusID pci:0000:02:00.0
[ 32.967] drmOpenDevice: node name is /dev/dri/card0
[ 32.967] drmOpenDevice: open result is 11, (OK)
[ 32.967] drmOpenByBusid: drmOpenMinor returns 11
[ 32.967] drmOpenByBusid: drmGetBusid reports pci:0000:02:00.0
[ 32.968] (II) Loading sub module "exa"
[ 32.968] (II) LoadModule: "exa"
[ 32.968] (II) Loading /usr/lib/xorg/modules/libexa.so
[ 32.969] (II) Module exa: vendor="X.Org Foundation"
[ 32.969] compiled for 1.9.5, module version = 2.5.0
[ 32.969] ABI class: X.Org Video Driver, version 8.0
[ 32.969] (II) RADEON(0): KMS Color Tiling: enabled
[ 32.969] (II) RADEON(0): SwapBuffers wait for vsync: enabled
[ 32.993] (II) RADEON(0): Output VGA-0 has no monitor section
[ 33.013] (II) RADEON(0): Output S-video has no monitor section
[ 33.067] (II) RADEON(0): Output DVI-0 has no monitor section
[ 33.091] (II) RADEON(0): EDID for output VGA-0
[ 33.111] (II) RADEON(0): EDID for output S-video
[ 33.165] (II) RADEON(0): EDID for output DVI-0
[ 33.165] (II) RADEON(0): Manufacturer: GSM Model: 567e Serial#: 269663
[ 33.165] (II) RADEON(0): Year: 2008 Week: 8
[ 33.165] (II) RADEON(0): EDID Version: 1.3
[ 33.165] (II) RADEON(0): Digital Display Input
[ 33.165] (II) RADEON(0): Max Image Size [cm]: horiz.: 49 vert.: 32
[ 33.165] (II) RADEON(0): Gamma: 2.20
[ 33.165] (II) RADEON(0): DPMS capabilities: StandBy Suspend Off
[ 33.165] (II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[ 33.165] (II) RADEON(0): First detailed timing is preferred mode
[ 33.165] (II) RADEON(0): redX: 0.635 redY: 0.342 greenX: 0.292 greenY: 0.611
[ 33.165] (II) RADEON(0): blueX: 0.147 blueY: 0.070 whiteX: 0.313 whiteY: 0.329
[ 33.165] (II) RADEON(0): Supported established timings:
[ 33.165] (II) RADEON(0): 720x400@70Hz
[ 33.165] (II) RADEON(0): 640x480@60Hz
[ 33.165] (II) RADEON(0): 640x480@75Hz
[ 33.166] (II) RADEON(0): 800x600@56Hz
[ 33.166] (II) RADEON(0): 800x600@60Hz
[ 33.166] (II) RADEON(0): 800x600@75Hz
[ 33.166] (II) RADEON(0): 832x624@75Hz
[ 33.166] (II) RADEON(0): 1024x768@60Hz
[ 33.166] (II) RADEON(0): 1024x768@75Hz
[ 33.166] (II) RADEON(0): 1280x1024@75Hz
[ 33.166] (II) RADEON(0): 1152x864@75Hz
[ 33.166] (II) RADEON(0): Manufacturer's mask: 0
[ 33.166] (II) RADEON(0): Supported standard timings:
[ 33.166] (II) RADEON(0): #0: hsize: 1440 vsize 900 refresh: 60 vid: 149
[ 33.166] (II) RADEON(0): #1: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
[ 33.166] (II) RADEON(0): #2: hsize: 1280 vsize 960 refresh: 60 vid: 16513
[ 33.166] (II) RADEON(0): #3: hsize: 1152 vsize 864 refresh: 75 vid: 20337
[ 33.166] (II) RADEON(0): Supported detailed timing:
[ 33.166] (II) RADEON(0): clock: 119.0 MHz Image Size: 474 x 296 mm
[ 33.166] (II) RADEON(0): h_active: 1680 h_sync: 1728 h_sync_end 1760 h_blank_end 1840 h_border: 0
[ 33.166] (II) RADEON(0): v_active: 1050 v_sync: 1053 v_sync_end 1059 v_blanking: 1080 v_border: 0
[ 33.166] (II) RADEON(0): Supported detailed timing:
[ 33.166] (II) RADEON(0): clock: 146.2 MHz Image Size: 474 x 296 mm
[ 33.166] (II) RADEON(0): h_active: 1680 h_sync: 1784 h_sync_end 1960 h_blank_end 2240 h_border: 0
[ 33.166] (II) RADEON(0): v_active: 1050 v_sync: 1053 v_sync_end 1059 v_blanking: 1089 v_border: 0
[ 33.166] (II) RADEON(0): Ranges: V min: 56 V max: 75 Hz, H min: 30 H max: 83 kHz, PixClock max 155 MHz
[ 33.166] (II) RADEON(0): Monitor name: W2252
[ 33.166] (II) RADEON(0): EDID (in hex):
[ 33.166] (II) RADEON(0): 00ffffffffffff001e6d7e565f1d0400
[ 33.166] (II) RADEON(0): 08120103ea312078eaaec5a2574a9c25
[ 33.166] (II) RADEON(0): 125054a76b80950081808140714f0101
[ 33.166] (II) RADEON(0): 0101010101017c2e90a0601a1e403020
[ 33.166] (II) RADEON(0): 3600da281100001a21399030621a2740
[ 33.166] (II) RADEON(0): 68b03600da281100001c000000fd0038
[ 33.166] (II) RADEON(0): 4b1e530f000a202020202020000000fc
[ 33.166] (II) RADEON(0): 0057323235320a2020202020202000dd
[ 33.166] (II) RADEON(0): Printing probed modes for output DVI-0
[ 33.166] (II) RADEON(0): Modeline "1680x1050"x59.9 119.00 1680 1728 1760 1840 1050 1053 1059 1080 +hsync -vsync (64.7 kHz)
[ 33.166] (II) RADEON(0): Modeline "1680x1050"x60.0 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync (65.3 kHz)
[ 33.166] (II) RADEON(0): Modeline "1280x1024"x75.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
[ 33.166] (II) RADEON(0): Modeline "1280x1024"x60.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
[ 33.166] (II) RADEON(0): Modeline "1440x900"x59.9 106.50 1440 1520 1672 1904 900 903 909 934 -hsync +vsync (55.9 kHz)
[ 33.166] (II) RADEON(0): Modeline "1280x960"x60.0 108.00 1280 1376 1488 1800 960 961 964 1000 +hsync +vsync (60.0 kHz)
[ 33.166] (II) RADEON(0): Modeline "1152x864"x75.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz)
[ 33.166] (II) RADEON(0): Modeline "1024x768"x75.1 78.80 1024 1040 1136 1312 768 769 772 800 +hsync +vsync (60.1 kHz)
[ 33.166] (II) RADEON(0): Modeline "1024x768"x60.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz)
[ 33.166] (II) RADEON(0): Modeline "832x624"x74.6 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync (49.7 kHz)
[ 33.166] (II) RADEON(0): Modeline "800x600"x75.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz)
[ 33.166] (II) RADEON(0): Modeline "800x600"x60.3 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz)
[ 33.166] (II) RADEON(0): Modeline "800x600"x56.2 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync (35.2 kHz)
[ 33.166] (II) RADEON(0): Modeline "640x480"x75.0 31.50 640 656 720 840 480 481 484 500 -hsync -vsync (37.5 kHz)
[ 33.166] (II) RADEON(0): Modeline "640x480"x60.0 25.20 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz)
[ 33.166] (II) RADEON(0): Modeline "720x400"x70.1 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz)
[ 33.166] (II) RADEON(0): Output VGA-0 disconnected
[ 33.166] (II) RADEON(0): Output S-video disconnected
[ 33.166] (II) RADEON(0): Output DVI-0 connected
[ 33.166] (II) RADEON(0): Using exact sizes for initial modes
[ 33.166] (II) RADEON(0): Output DVI-0 using initial mode 1680x1050
[ 33.166] (II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[ 33.166] (II) RADEON(0): mem size init: gart size :1fdff000 vram size: s:10000000 visible:f8d4000
[ 33.166] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
[ 33.166] (==) RADEON(0): DPI set to (96, 96)
[ 33.166] (II) Loading sub module "fb"
[ 33.166] (II) LoadModule: "fb"
[ 33.167] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 33.175] (II) Module fb: vendor="X.Org Foundation"
[ 33.175] compiled for 1.9.5, module version = 1.0.0
[ 33.175] ABI class: X.Org ANSI C Emulation, version 0.4
[ 33.175] (II) Loading sub module "ramdac"
[ 33.175] (II) LoadModule: "ramdac"
[ 33.175] (II) Module "ramdac" already built-in
[ 33.175] (II) UnloadModule: "vesa"
[ 33.175] (II) Unloading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 33.175] (--) Depth 24 pixmap format is 32 bpp
[ 33.175] (II) RADEON(0): [DRI2] Setup complete
[ 33.175] (II) RADEON(0): [DRI2] DRI driver: r300
[ 33.175] (II) RADEON(0): Front buffer size: 7128K
[ 33.175] (II) RADEON(0): VRAM usage limit set to 222904K
[ 33.178] (==) RADEON(0): Backing store disabled
[ 33.178] (II) RADEON(0): Direct rendering enabled
[ 33.179] (II) RADEON(0): Render acceleration enabled for R300/R400/R500 type cards.
[ 33.179] (II) RADEON(0): Setting EXA maxPitchBytes
[ 33.179] (II) EXA(0): Driver allocated offscreen pixmaps
[ 33.179] (II) EXA(0): Driver registered support for the following operations:
[ 33.179] (II) Solid
[ 33.179] (II) Copy
[ 33.179] (II) Composite (RENDER acceleration)
[ 33.179] (II) UploadToScreen
[ 33.179] (II) DownloadFromScreen
[ 33.180] (II) RADEON(0): Acceleration enabled
[ 33.180] (==) RADEON(0): DPMS enabled
[ 33.180] (==) RADEON(0): Silken mouse enabled
[ 33.186] (II) RADEON(0): Set up textured video
[ 33.187] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 33.187] (--) RandR disabled
[ 33.187] (II) Initializing built-in extension Generic Event Extension
[ 33.187] (II) Initializing built-in extension SHAPE
[ 33.187] (II) Initializing built-in extension MIT-SHM
[ 33.187] (II) Initializing built-in extension XInputExtension
[ 33.187] (II) Initializing built-in extension XTEST
[ 33.187] (II) Initializing built-in extension BIG-REQUESTS
[ 33.187] (II) Initializing built-in extension SYNC
[ 33.187] (II) Initializing built-in extension XKEYBOARD
[ 33.187] (II) Initializing built-in extension XC-MISC
[ 33.187] (II) Initializing built-in extension XINERAMA
[ 33.187] (II) Initializing built-in extension XFIXES
[ 33.187] (II) Initializing built-in extension RENDER
[ 33.187] (II) Initializing built-in extension RANDR
[ 33.187] (II) Initializing built-in extension COMPOSITE
[ 33.187] (II) Initializing built-in extension DAMAGE
[ 33.279] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 33.279] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 33.279] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 33.279] (II) AIGLX: enabled GLX_SGI_make_current_read
[ 33.279] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 33.280] (II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/r300_dri.so
[ 33.280] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 33.281] (II) RADEON(0): Setting screen physical size to 444 x 277
[ 33.629] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[ 33.629] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 33.629] (**) Power Button: Applying InputClass "keyboard-all"
[ 33.629] (II) LoadModule: "evdev"
[ 33.629] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 33.635] (II) Module evdev: vendor="X.Org Foundation"
[ 33.635] compiled for 1.9.3, module version = 2.6.0
[ 33.635] Module class: X.Org XInput Driver
[ 33.635] ABI class: X.Org XInput driver, version 11.0
[ 33.635] (**) Power Button: always reports core events
[ 33.635] (**) Power Button: Device: "/dev/input/event3"
[ 33.641] (--) Power Button: Found keys
[ 33.641] (II) Power Button: Configuring as keyboard
[ 33.641] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 33.641] (**) Option "xkb_rules" "evdev"
[ 33.641] (**) Option "xkb_model" "evdev"
[ 33.641] (**) Option "xkb_layout" "us"
[ 33.641] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 33.680] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[ 33.680] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 33.680] (**) Power Button: Applying InputClass "keyboard-all"
[ 33.680] (**) Power Button: always reports core events
[ 33.680] (**) Power Button: Device: "/dev/input/event2"
[ 33.684] (--) Power Button: Found keys
[ 33.684] (II) Power Button: Configuring as keyboard
[ 33.684] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[ 33.684] (**) Option "xkb_rules" "evdev"
[ 33.684] (**) Option "xkb_model" "evdev"
[ 33.684] (**) Option "xkb_layout" "us"
[ 33.684] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 33.687] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event4)
[ 33.687] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[ 33.687] (**) Logitech USB-PS/2 Optical Mouse: always reports core events
[ 33.687] (**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event4"
[ 33.692] (--) Logitech USB-PS/2 Optical Mouse: Found 12 mouse buttons
[ 33.692] (--) Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
[ 33.692] (--) Logitech USB-PS/2 Optical Mouse: Found relative axes
[ 33.692] (--) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
[ 33.692] (II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
[ 33.692] (II) Logitech USB-PS/2 Optical Mouse: Adding scrollwheel support
[ 33.692] (**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
[ 33.692] (**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 33.692] (II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
[ 33.692] (**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
[ 33.692] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration profile 0
[ 33.692] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration factor: 2.000
[ 33.692] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration threshold: 4
[ 33.692] (II) Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
[ 33.692] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse0)
[ 33.692] (II) No input driver/identifier specified (ignoring)
[ 33.699] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event1)
[ 33.699] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 33.699] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[ 33.699] (**) AT Translated Set 2 keyboard: always reports core events
[ 33.699] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
[ 33.705] (--) AT Translated Set 2 keyboard: Found keys
[ 33.705] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[ 33.705] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[ 33.705] (**) Option "xkb_rules" "evdev"
[ 33.705] (**) Option "xkb_model" "evdev"
[ 33.705] (**) Option "xkb_layout" "us"
[ 33.705] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 33.709] (II) config/udev: Adding input device Speakup (/dev/input/event0)
[ 33.709] (**) Speakup: Applying InputClass "evdev keyboard catchall"
[ 33.709] (**) Speakup: Applying InputClass "keyboard-all"
[ 33.710] (**) Speakup: always reports core events
[ 33.710] (**) Speakup: Device: "/dev/input/event0"
[ 33.717] (--) Speakup: Found keys
[ 33.717] (II) Speakup: Configuring as keyboard
[ 33.717] (II) XINPUT: Adding extended input device "Speakup" (type: KEYBOARD)
[ 33.717] (**) Option "xkb_rules" "evdev"
[ 33.717] (**) Option "xkb_model" "evdev"
[ 33.717] (**) Option "xkb_layout" "us"
[ 33.717] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 60.625] (II) RADEON(0): EDID vendor "GSM", prod id 22142
[ 60.625] (II) RADEON(0): Using EDID range info for horizontal sync
[ 60.625] (II) RADEON(0): Using EDID range info for vertical refresh
[ 60.625] (II) RADEON(0): Printing DDC gathered Modelines:
[ 60.625] (II) RADEON(0): Modeline "1680x1050"x0.0 119.00 1680 1728 1760 1840 1050 1053 1059 1080 +hsync -vsync (64.7 kHz)
[ 60.625] (II) RADEON(0): Modeline "1680x1050"x0.0 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync (65.3 kHz)
[ 60.625] (II) RADEON(0): Modeline "800x600"x0.0 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz)
[ 60.625] (II) RADEON(0): Modeline "800x600"x0.0 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync (35.2 kHz)
[ 60.625] (II) RADEON(0): Modeline "640x480"x0.0 31.50 640 656 720 840 480 481 484 500 -hsync -vsync (37.5 kHz)
[ 60.626] (II) RADEON(0): Modeline "640x480"x0.0 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz)
[ 60.626] (II) RADEON(0): Modeline "720x400"x0.0 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz)
[ 60.626] (II) RADEON(0): Modeline "1280x1024"x0.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
[ 60.626] (II) RADEON(0): Modeline "1024x768"x0.0 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync (60.0 kHz)
[ 60.626] (II) RADEON(0): Modeline "1024x768"x0.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz)
[ 60.626] (II) RADEON(0): Modeline "832x624"x0.0 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync (49.7 kHz)
[ 60.626] (II) RADEON(0): Modeline "800x600"x0.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz)
[ 60.626] (II) RADEON(0): Modeline "1152x864"x0.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz)
[ 60.626] (II) RADEON(0): Modeline "1440x900"x0.0 88.75 1440 1488 1520 1600 900 903 909 926 +hsync -vsync (55.5 kHz)
[ 60.626] (II) RADEON(0): Modeline "1280x1024"x0.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
[ 60.626] (II) RADEON(0): Modeline "1280x960"x0.0 108.00 1280 1376 1488 1800 960 961 964 1000 +hsync +vsync (60.0 kHz)
 
Old 07-26-2012, 11:40 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,174

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
You sent us miles of output from which I gather you have an old card which AMD like to forget they made (Join the large club) and it's basically working, but might do a bit better if you got the xorg.conf settings out of the way. Key check is

Quote:
glxinfo |grep render
Have you a good picture? The correct driver seems to be there
 
1 members found this post helpful.
Old 07-26-2012, 12:23 PM   #3
elocholero
LQ Newbie
 
Registered: Jul 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Yes, the picture is great, I'm using 1680x1050 and can't tell a bad word about it. The difficulties begins when I'm trying to run some 3d acceleration requiring applications (like to run some older games time to time). I was struggling with this for weeks few months ago (so I'm not exactly in the subject atm, but I'm trying to get back into it) and now just giving it last shot to figure out if I can do anything besides upgrading my video card (or downgrading my kernel, but I think outdated dependencies would kill me anyway in this case. I was trying to get 3d acceleration working under wine and virtual machine.

This is part of mine wine.log

Quote:
trace:wgl:X11DRV_WineGL_InitOpenglInfo GL version : 2.1 Mesa 7.9.2.
trace:wgl:X11DRV_WineGL_InitOpenglInfo GL renderer : Gallium 0.4 on RV515.
trace:wgl:X11DRV_WineGL_InitOpenglInfo GLX version : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX version : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX vendor: : SGI.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX version : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX vendor: : Mesa Project and SGI.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Direct rendering enabled: True
According to this http://wiki.winehq.org/3DDriverIssues I'm only on mine software rendering and with virtual machine I'm feeling that I have somehow similar problem.
 
Old 07-26-2012, 03:46 PM   #4
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Maybe these threads can give you some information?

http://www.linuxquestions.org/questi...-x1400-793635/
http://www.slacky.eu/forum/viewtopic.php?f=6&t=30411
http://www.linuxquestions.org/questi...dering-866420/
 
1 members found this post helpful.
Old 07-26-2012, 06:24 PM   #5
elocholero
LQ Newbie
 
Registered: Jul 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
OMG I'm an idiot Thank You for Yours Links Jostber. Thanks to them I came to conclusion, that there is everything fine with mine OpenGl output in glxinfo. From there I went to OpenGl testing on virtual machine with GPU Caps Viewer (never did that before, previously was only relaying on wine emulating and was assuming that there is the same case with virtual machine) and it came out I had OpenGl 2.1 running, but in dxdiag I found out that Direct3d Acceleration was disabled, so after short googling something what seemed to be the case, I found out that I have to install Guest Additions together with Direct3d support (which I did, but without that support, since it was marked as experimental I was bit unsure about it and after it was telling me that I have to run it in safe mode to install and I was already so excited having my silverlight working that day I have installed virtual machine so I skipped it and later on absolutely forgot about it), (doubt if this solution will help anyone anytime, but still) Now I just have to figure out how to get rid of black backgrounds in rendered applications, but think that's not only slackware case now and sorry for my bad grammar

Last edited by elocholero; 07-26-2012 at 06:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless troubles in slackware 11 $Linuxnoob Slackware 18 06-25-2007 01:27 PM
Slackware 11.0 install troubles chris26 Slackware 14 11-30-2006 02:27 PM
Having Network Troubles with Slackware :( AtomicBanana Linux - Hardware 4 06-23-2004 07:47 AM
sound troubles in slackware Mr.Mounsey Linux - Hardware 1 11-25-2003 07:25 PM


All times are GMT -5. The time now is 05:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration