LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-02-2011, 02:22 PM   #1
genericflounder
LQ Newbie
 
Registered: Jan 2010
Posts: 8

Rep: Reputation: 0
Slackware 13.37 Upgrade - HALD hang at boot with USB card reader.


Just had a small little frustrating issue, figured I'd post it up in case someone else runs into it.

I just upgraded from 13.1 to 13.37. Lots of nice changes!

Anyhoo, during boot, the HAL daemon would hang for about 45 seconds before continuing. I made it verbose and had it write to the syslog. After reading the logs, I commented it out from rc.M and tried starting it after the system had booted. No lag, no hang.

Long story short, I put HALD back into rc.M, halted the system, disconnected the card reader, and rebooted... no lag, no hang.

Halt again, reconnect, and once again things are working as they should.

Hope this eliminates frustration for someone. I'm still curious as to how this would happen after the upgrade, so if anyone has some insight please share :P
 
Old 05-02-2011, 02:30 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,509

Rep: Reputation: 571Reputation: 571Reputation: 571Reputation: 571Reputation: 571Reputation: 571
I have a usb card reader that hangs everything at the bios. I see the installed disks, and there we halt. I've repeated this with a number of PCs. Cure is simple - take the card reader out.
 
Old 05-02-2011, 02:45 PM   #3
genericflounder
LQ Newbie
 
Registered: Jan 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by business_kid View Post
I have a usb card reader that hangs everything at the bios. I see the installed disks, and there we halt. I've repeated this with a number of PCs. Cure is simple - take the card reader out.
Just a bad reader then eh?
Mine was and still is working fine. Just that weird hickup after the upgrade, which only affected HAL not the BIOS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
usb device detection, manual insertion card(smart card) reader problem, zapkhiel Linux - Hardware 4 07-17-2009 08:50 AM
Internal Card reader causes system hang at boot. 1kyle Suse/Novell 1 10-30-2008 04:06 PM
MEPIS: how to mount a flash card in an usb card reader for n00b frenchn00b Linux - General 1 08-06-2008 05:26 PM
Slackware thinks USB Card Reader is an Ethernet device apachedude Linux - Hardware 3 02-04-2005 07:59 AM
USB multi-card reader; only one card can be mounted in Slack 10. KidsWriter71 Linux - Hardware 6 09-11-2004 07:24 PM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration