LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware 13.37 problems with Ati 11.4 drivers (http://www.linuxquestions.org/questions/slackware-14/slackware-13-37-problems-with-ati-11-4-drivers-877711/)

mlpa 04-28-2011 06:11 PM

Slackware 13.37 problems with Ati 11.4 drivers
 
I did a fresh install of Slackware64 13.37.
All went well. I download the latest Ati video drivers, 11.4, and build the slackware package.
Install, and run aticonfig --initial all good.

But when I run startx I only get a black screen, can someone help me?

Darth Vader 04-28-2011 06:47 PM

This is typical for 'out of range' resolutions. I suggest to just specify the monitor information and the desired resolutions, under your xorg.conf.

adamk75 04-28-2011 06:55 PM

Can you remotely access the machine or get to the /var/log/Xorg.0.log file that is generated?

Adam

TobiSGD 04-28-2011 07:06 PM

May I ask where you got the 11.4 drivers? The AMD website lists 11.3 as the current version.

mlpa 04-28-2011 07:23 PM

I get the driver for here, it's revision number 11.4.

Quote:

This is typical for 'out of range' resolutions. I suggest to just specify the monitor information and the desired resolutions, under your xorg.conf.
What mean 'out of range'?

I will try get the log from Xorg.0.log

adamk75 04-28-2011 07:42 PM

Quote:

Originally Posted by TobiSGD (Post 4340015)
May I ask where you got the 11.4 drivers? The AMD website lists 11.3 as the current version.

Though the download page says 11.3, if you mouse over the download link you'll see the installer says 11.4.

Adam

mlpa 04-28-2011 07:45 PM

I reinstall the Ati driver, but by the installer not compiling a package.
At first I reboot and get a kernel panic, using Slackware dvd I enter my system and rebuild initrd and ran lilo.
New reboot an now it's fine with proper drivers, it's surreal :$

hakan56 04-29-2011 01:54 AM

Thank you "mipa", it works for me too. :)
Code:

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6500M/5600/5700 Series
OpenGL version string: 4.1.10666 Compatibility Profile Context

..Radeon Mobility HD 5650.

$ fgl_glxgears
Using GLX_SGIX_pbuffer
4457 frames in 5.0 seconds = 891.400 FPS
4459 frames in 5.0 seconds = 891.800 FPS
4400 frames in 5.0 seconds = 880.000 FPS

..full screen (17") = 1600x900

When I tried "--buildpkg" (fglrx-8.841-x86_64-1.tgz) the computer "freeze" and I got this error in /var/log/Xorg.0.log
Code:

    45.878] (II) fglrx(0): Kernel Module Version Information:
[    45.878] (II) fglrx(0):    Name: fglrx
[    45.878] (II) fglrx(0):    Version: 8.84.5
[    45.878] (II) fglrx(0):    Date: Apr  5 2011
[    45.878] (II) fglrx(0):    Desc: ATI FireGL DRM kernel module
[    45.878] (II) fglrx(0): Kernel Module version matches driver.
[    45.878] (II) fglrx(0): Kernel Module Build Time Information:
[    45.878] (II) fglrx(0):    Build-Kernel UTS_RELEASE:        2.6.37.6
[    45.878] (II) fglrx(0):    Build-Kernel MODVERSIONS:        yes
[    45.878] (II) fglrx(0):    Build-Kernel __SMP__:            yes
[    45.878] (II) fglrx(0):    Build-Kernel PAGE_SIZE:          0x1000
[    45.878] (II) fglrx(0): [uki] register handle = 0x00004000
[    45.942] (EE) fglrx(0): Not enough video memory to allocate primary surface (frame buffer).
[    45.942] (II) fglrx(0): Shutdown CMMQS
[    45.942] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[    45.942] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0x7f976b9bc000
[    45.942] (WW) fglrx(0): ***********************************************************
[    45.942] (WW) fglrx(0): * DRI initialization failed                              *
[    45.942] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
[    45.942] (WW) fglrx(0): * 2D and 3D acceleration disabled                        *
[    45.942] (WW) fglrx(0): ***********************************************************
[    45.942]
Fatal server error:
[    45.942] AddScreen/ScreenInit failed for driver 0
[    45.942]

/Håkan

mlpa 04-29-2011 02:37 AM

For what I see, this new release works well using the default installer than the package.
And now it supports a uninstall, that I think restores the files it changes.

iphigenie 05-08-2011 03:08 PM

Quote:

Originally Posted by mlpa (Post 4340321)
For what I see, this new release works well using the default installer than the package.
And now it supports a uninstall, that I think restores the files it changes.

I can confirm having had the same issue with installing the package, same error message in the log. startx goes to black nothingness and nothing can be done to come out of it. on 1337 32 bit

Which worked fine when running the direct install (after uninstalling the packages)

I am not sure what the difference is, I didn't do a filesystem snapshot. The xorg.conf generated is identical both times.

Pixxt 05-08-2011 07:19 PM

I always before I build the fglrx packages, I run "xorgsetup" to have a nice sane default /etc/X11/xorg.conf . After i install the fglrx package then i ati-config --initial this seems to work for me. YMMV

hippy jonny 05-09-2011 01:25 AM

I'm a noobie so apologies if this already known.

I had a similar problem with ati 11.4. Build, install and aticonfig --initial ran without a hitch but on startx I ended up with a white screen with only the three finger saltute option to break out. Appending "nomodeset" in lilo.conf seemed to work for me. It appears to disable all the in-kernel ati drivers, dri etc stuff.

Amrod78 05-09-2011 05:34 AM

I had to add "blacklist radeon" in /etc/modprobe.d/blacklist.conf to avoid the black screen.

zsd 05-11-2011 05:23 PM

11.5 is available now at http://www2.ati.com/drivers/linux/at...x86.x86_64.run

Cheers.

thelastblack 08-31-2011 06:17 AM

hey, i just downloaded 11.8 version and it is a .run file which i have no idea of what to do with that. Should i just run it inside a terminal(using bash) or there are extra steps for that?
Thanks


All times are GMT -5. The time now is 03:29 PM.