LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-29-2011, 04:55 PM   #1
Maestro485
Member
 
Registered: Apr 2004
Location: Pittsburgh
Distribution: Slackware
Posts: 136

Rep: Reputation: 16
Slackware 13.37 KDE Desktop Effects only work for root


Hi all,

I just got Slackware 13.37 up and running and all is well except for the KDE Desktop Effects. If I log in as root, they're enabled and work fine. However, when I log in as a user they are disabled and the option to enable them is greyed out.

Other OpenGL programs run fine as a user, such as the glxgears test program and OpenGL screensavers.

ATI card running this driver:

http://support.amd.com/us/gpudownloa...2&lang=English

It must be some kind of permission issue but I'm not really sure where to look.

Thanks!
 
Old 04-29-2011, 08:39 PM   #2
Maestro485
Member
 
Registered: Apr 2004
Location: Pittsburgh
Distribution: Slackware
Posts: 136

Original Poster
Rep: Reputation: 16
Short story: Got it working.

Long story:

When the slackware install was done and it rebooted, for some reason the frame buffer would set itself to some ridiculous resolution which made the screen unreadable. I ssh'd to the box and edited /etc/inittab to boot to a graphical interface to bypass this problem.

Upon doing so, I logged in as root to download video drivers. Since I couldn't read the screen in runlevel 3, I installed the driver while KDE was open. I figured it would complain about X running if it mattered. This was not a good assumption to make (actually, pretty stupid in hindsight) and it's most likely the root of the problem.

Instead, I let it boot to runlevel 3 (with the unreadable screen) then ssh'd to the box and reinstalled the video driver that way.

After that it was a matter of wrestling with the display configuration (I have 2 monitors that are 2 different sizes and my video card doesn't like that very much).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE4 desktop effects work in root but not in user account Tribulation Linux - Desktop 2 04-07-2011 06:19 PM
[SOLVED] Problems with Slackware 13.1 KDE Desktop Effects on ATI Radeon HD 4850 Erik_FL Slackware 9 11-15-2010 09:20 PM
[SOLVED] KDE desktop effects not working with Intel graphics (Slackware-Current; March 7, 2010 piratesmack Slackware 5 03-09-2010 09:08 AM
Can't get desktop effects to work outside of root user mothergoose729 Slackware 17 11-23-2009 09:40 PM
Slackware 12.2(current) + KDE 4.1.96 + Xinerama = No Desktop Effects frandalla Slackware 3 01-29-2009 11:22 AM


All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration