LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-21-2012, 12:39 PM   #16
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled

Thanks for the info and how to get it to start automatically. I'll try it out and see what happens. Don't suppose you have any idea about the dead space on my primary monitor? The 30-40 pixels of extra space below the taskbar that the mouse can travel into?
 
Old 03-21-2012, 03:08 PM   #17
VARNICA
LQ Newbie
 
Registered: Apr 2011
Posts: 11

Rep: Reputation: 0
Try to specify resolution, maybe that is the problem.
 
Old 03-21-2012, 03:46 PM   #18
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
Good idea. I'll have to give that a shot. I'll reboot my laptop so it wipes the settings and I'll specify the resolution of both screens. Maybe it will be the difference.
 
Old 03-21-2012, 04:46 PM   #19
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
Try doing something like
Code:
xrandr --output LVDS1 --auto --primary --output VGA1 --right-of LVDS1 --auto
Using the auto switch should make it use the default resolution of the monitor. I have done this with my laptop and 22" monitor being 1280x800 and 1680x1050 respectively.
 
Old 03-22-2012, 08:42 AM   #20
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
I tried the command and it did work to set my proper resolutions, but I am still having the issue of the dead space below the edge of my main display (laptop screen). Any other ideas?
 
Old 03-26-2012, 06:53 AM   #21
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
Hi all,

I'm really hoping to mark this ticket as solved, but I'm still hoping for a solution to the extra space below my main screen (although I'm probably going to give up on that for now), and I have stumbled on a new issue. I tried what VARNICA suggested to add my xrandr commands to my xinitrc file, but it didn't work.

I am new to Slackware and Linux for these types of changes. Is there something I have to enable or do to have it look at the xinitrc file? I put it in my home directory and had to create it since it didn't exist. But I thought it automatically searched for it. Can someone direct me to what I have to do to make my xrandr commands launch at startup?

Thanks.
 
Old 03-26-2012, 04:52 PM   #22
VARNICA
LQ Newbie
 
Registered: Apr 2011
Posts: 11

Rep: Reputation: 0
Hello

you have .xinitrc file in your home directory, but it is hidden. Try ls -la command and you should see it .xinitrc
Files with dot in front are hidden. Or open terminal and in your home directory type

Code:
nano .xinitrc
Cheers
 
Old 03-27-2012, 08:13 AM   #23
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
When I did that (I use VI though), it was a new file that was created. So the file didn't exist prior to me creating it. I did add the commands exactly as you laid it out, but it didn't appear to do anything.
 
Old 03-27-2012, 09:15 AM   #24
VARNICA
LQ Newbie
 
Registered: Apr 2011
Posts: 11

Rep: Reputation: 0
Hello what DE do you use and
can you post the output of

Code:
ls -la /home/user/
switch user whit your log in user.

or simply in user directory exec ls -la and post so we can see.

Last edited by VARNICA; 03-27-2012 at 09:23 AM.
 
Old 03-27-2012, 10:12 AM   #25
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
Here is the output.
Quote:
total 204
drwx--x--x 37 jeremy users 4096 Mar 26 16:42 ./
drwxr-xr-x 4 root root 4096 Mar 16 10:00 ../
-rw------- 1 jeremy users 644 Mar 26 07:37 .ICEauthority
-rw------- 1 jeremy users 364 Mar 26 07:37 .Xauthority
-rw------- 1 jeremy users 4851 Mar 27 09:10 .bash_history
-rw-r--r-- 1 jeremy users 73 Mar 16 15:51 .bash_profile
-rw-r--r-- 1 jeremy users 170 Mar 16 16:00 .bashrc
drwxr-xr-x 5 jeremy users 4096 Mar 22 08:04 .cache/
drwxr-xr-x 11 jeremy users 4096 Mar 22 14:45 .config/
drwx------ 3 jeremy users 4096 Mar 16 10:05 .dbus/
drwx------ 3 jeremy users 4096 Mar 26 09:47 .dropbox/
drwxr-xr-x 2 jeremy users 4096 Mar 27 03:54 .electricsheep/
drwxr-xr-x 2 jeremy users 4096 Mar 23 15:01 .fontconfig/
drwx------ 3 jeremy users 4096 Sep 22 2012 .freerdp/
drwx------ 2 jeremy users 4096 Mar 26 07:37 .gconf/
drwx------ 2 jeremy users 4096 Mar 26 07:38 .gconfd/
drwx------ 3 jeremy users 4096 Mar 21 11:03 .gnome2/
-rw------- 1 jeremy users 183 Mar 26 08:30 .gtk-bookmarks
drwxr----- 2 jeremy users 4096 Mar 16 10:05 .hplip/
drwxr-xr-x 3 jeremy users 4096 Mar 23 15:01 .libreoffice/
drwxr-xr-x 3 jeremy users 4096 Mar 16 10:05 .local/
drwx------ 4 jeremy users 4096 Mar 16 12:05 .mozilla/
drwxr-xr-x 2 jeremy users 4096 Mar 21 02:55 .mplayer/
drwxr-xr-x 3 jeremy users 4096 Mar 22 14:46 .openoffice.org/
drwxr-xr-x 3 jeremy users 4096 Mar 26 16:42 .pentadactyl/
drwx------ 3 jeremy users 4096 Mar 20 10:02 .putty/
drwx------ 2 jeremy users 4096 Mar 26 11:43 .remmina/
-rw-r--r-- 1 jeremy users 3729 May 23 2009 .screenrc
-rw-r--r-- 1 jeremy users 87 Mar 22 16:43 .startxrandr
drwxr-xr-x 3 jeremy users 4096 Mar 20 13:47 .teamviewer/
drwxr-xr-x 3 jeremy users 4096 Mar 22 08:03 .thumbnails/
drwxr-xr-x 2 jeremy users 4096 Mar 26 10:42 .tickr/
drwxr-xr-x 4 jeremy users 4096 Mar 26 11:37 .wine/
-rw-r--r-- 1 jeremy users 32 Mar 22 16:46 .xinitrc
-rw-r--r-- 1 jeremy users 0 Mar 27 11:08 .xscreensaver-getimage.cache
-rw-r--r-- 1 jeremy users 779 Mar 15 2007 .xsession
-rw------- 1 jeremy users 9977 Mar 27 11:04 .xsession-errors
drwxr-xr-x 2 jeremy users 4096 Mar 16 10:05 Desktop/
drwxr-xr-x 2 jeremy users 4096 Mar 16 10:05 Documents/
drwxr-xr-x 3 jeremy users 4096 Mar 26 11:05 Downloads/
drwx------ 13 jeremy users 4096 Mar 26 07:37 Dropbox/
drwxr-xr-x 2 jeremy users 4096 Mar 16 10:05 Music/
drwxr-xr-x 2 jeremy users 4096 Mar 26 11:04 Packages/
drwxr-xr-x 2 jeremy users 4096 Mar 16 10:05 Pictures/
drwxr-xr-x 2 jeremy users 4096 Mar 16 10:05 Public/
drwxr-xr-x 17 jeremy users 4096 Mar 26 11:05 Scripts/
drwxr-xr-x 2 jeremy users 4096 Mar 16 10:05 Templates/
drwxr-xr-x 2 jeremy users 4096 Mar 16 10:05 Videos/
drwxr-xr-x 9 jeremy users 4096 Mar 19 11:57 slackware64-compat32/
 
Old 03-27-2012, 10:16 AM   #26
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
Keep in mind that .xinitrc exists because I created it. The following is what is in the file:
Code:
/bin/sh /home/user/.startxrandr
 
Old 03-27-2012, 11:46 AM   #27
VARNICA
LQ Newbie
 
Registered: Apr 2011
Posts: 11

Rep: Reputation: 0
Ok, strange but try this first change the mode of script

Code:
chmod +x .startxrand
and then in X go to the start menu Settings, Xfce 4 Settings Manager, Session and Startup, Application Autostart and Add the script .startxrandar
 
Old 03-27-2012, 12:13 PM   #28
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
Ok, so I just did what you suggested and it worked. Thank you very much.

Now the question I have is isn't there a way to have that start via files from the command line or something? Using the application autostart is fine, but I would like to know how to get things to start automatically just by modifying the proper files (like with the .xinitrc if it had worked). I'm trying to learn all I can and I don't want to end up being tied to any specific window manager if possible.

Thanks.
 
Old 03-27-2012, 04:35 PM   #29
VARNICA
LQ Newbie
 
Registered: Apr 2011
Posts: 11

Rep: Reputation: 0
If you want to start from command line, you can copy .xinitrc from /etc/X11/xinit/xinitrc.xfce to your home directory, just rename it to .xinitrc. And edit to start the script.



To learn more here are some links:


http://www.slackbook.org/html/x-wind...m-xinitrc.html

and

https://wiki.archlinux.org/index.php/Xinitrc

Last edited by VARNICA; 03-28-2012 at 09:23 AM.
 
Old 03-28-2012, 08:07 AM   #30
jdgr
Member
 
Registered: Feb 2012
Location: Ontario, Canada
Distribution: Fedora 18
Posts: 65

Original Poster
Rep: Reputation: Disabled
Thanks for the info and the links. I'll read through them and try it out.

Thanks for all your help, going to finally close this thread
 
  


Reply

Tags
slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Monitor Xorg Configuration with different resolutions terry84 Linux - Software 6 11-02-2010 12:39 AM
Help with monitor resolutions! cereal83 Slackware 24 02-27-2005 10:10 PM
monitor and resolutions cs-cam Linux - Newbie 2 11-14-2004 06:47 PM
Dual Monitor Support in Slackware 10? wiskic10_4 Linux - Hardware 2 10-17-2004 02:41 PM
monitor resolutions are limited after setting up dual head display in fedora ZorlacBabelfish Linux - Newbie 0 03-11-2004 09:07 AM


All times are GMT -5. The time now is 11:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration