LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-15-2012, 06:56 AM   #16
mysql_connect
Member
 
Registered: Jul 2005
Distribution: Slackware 13.37 / Slackware64 13.37
Posts: 35

Original Poster
Rep: Reputation: 0

xorg.conf:

http://pastebin.com/dCHiMzUQ

Xorg.0.log:

http://pastebin.com/igczn8Hk
 
Old 02-15-2012, 07:15 AM   #17
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
I'm not completely sure what's going on here. fglrx properly supports xrandr and uses the Xorg XINERAMA extension to describe monitor placement for the window manager. So this is likely due to some quirk of the hybrid graphics, or maybe something with your xorg.conf file. I'd be interested in knowing if this xorg.conf file works correctly for you:

Code:
Section "Monitor"
        Identifier   "LVDS1"
        Option "PreferredMode" "1366x768"
EndSection

Section "Monitor"
        Identifier   "VGA1"
        Option "PreferredMode" "1600x900"
        Option "RightOf" "LVDS1"
EndSection

Section "Device"
  Identifier "Default Device"
  Driver "fglrx"
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "Default Device"
  Monitor "Default Monitor"
  DefaultDepth 24
  SubSection "Display"
        Depth 24
        Virtual 2966 2966
  EndSubSection
EndSection
This is basically my xorg.conf file, but with the Identifiers for the monitors changed.
 
Old 02-15-2012, 07:40 AM   #18
mysql_connect
Member
 
Registered: Jul 2005
Distribution: Slackware 13.37 / Slackware64 13.37
Posts: 35

Original Poster
Rep: Reputation: 0
Same thing with your xorg.conf, 1 big freaking desktop with windows stretching everywhere, this is so frustrating. Thanks for you help so far Adam.
 
Old 02-15-2012, 08:13 AM   #19
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Unfortunately, then, I'm not sure what's going on. I know that the fglrx drivers keep some configuration in /etc/ati/amdpcsdb but I don't know of anything in there that would cause your XINERAMA extension to display the wrong information.
 
Old 02-21-2012, 03:27 PM   #20
mysql_connect
Member
 
Registered: Jul 2005
Distribution: Slackware 13.37 / Slackware64 13.37
Posts: 35

Original Poster
Rep: Reputation: 0
Ideas anyone? Upgraded to 4.8.0 no change.
 
Old 02-22-2012, 01:35 PM   #21
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
you could try to run
Code:
aticonfig --initial=dual-head --screen-layout=right
which should result in :0.0 on the first screen and :0.1 on the second one. you should be able to move the mouse between the monitors, but -- at least in fluxbox -- both desktops will act seperately.
 
Old 02-22-2012, 03:55 PM   #22
whizje
Member
 
Registered: Sep 2008
Location: The Netherlands
Distribution: Slackware64 current
Posts: 582

Rep: Reputation: 129Reputation: 129
You might try
Code:
aticonfig --initial=dual-head --dtop=horizontal --screen-layout=right
 
Old 02-22-2012, 04:50 PM   #23
rawrFox
LQ Newbie
 
Registered: May 2011
Location: Knapford, Sodor
Distribution: Slackware, FreeBSD
Posts: 13

Rep: Reputation: 10
mysql_connect,

amdcccle does have display config in it.

Start it up, click on 'Display Manager' under the 'Pages' section, and both your monitors should be listed.

If you then switch to the 'Multi-Diplay' tab, it should allow you to configure your multiple monitor setup, the default seems to be cloned displays, this might be your problem. Change the selection in the drop down list to switch away from cloned.
It does require a reboot (or restart of X) to enact though.

This is the way I've always done it, never needed to mess with the X configs, hope it helps...
 
Old 02-29-2012, 06:45 AM   #24
mysql_connect
Member
 
Registered: Jul 2005
Distribution: Slackware 13.37 / Slackware64 13.37
Posts: 35

Original Poster
Rep: Reputation: 0
As I state in my previous posts I have tried everything (and posted my xorg conf, X log, etc), amdcccle doesn't show any display options as you can see here:

http://imageshack.us/f/403/amdcccle.jpg/
 
Old 02-29-2012, 09:03 AM   #25
rawrFox
LQ Newbie
 
Registered: May 2011
Location: Knapford, Sodor
Distribution: Slackware, FreeBSD
Posts: 13

Rep: Reputation: 10
mysql_connect: Sorry, I obviously misread your first post.

The only other thing I can think is that you are running amdcccle without root privileges, or that you haven't run aticonfig yet (which has already been suggested). I assume there is nothing helpful on the 'Switchable Graphics' screen.

Either way, it doesn't seem like its to do with that utility anyway, more to do with X, and I don't have much experience in that area.

Sorry I couldn't be more help, hope you find a solution soon.
 
  


Reply

Tags
13.37, 64bit, ati, dual monitor, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help in getting the graphic Up on Switchable Graphics Hamerins Linux - Laptop and Netbook 7 01-03-2012 08:40 PM
Summary of Switchable Graphics on Linux? AMD/NVIDIA jmite Linux - Hardware 1 10-08-2011 04:58 AM
Radeon 6990m and switchable graphics w/linux Glasser Linux - Laptop and Netbook 9 08-17-2011 06:21 AM
[SOLVED] Ubuntu 10.10 64bit graphics worse than the 32bit graphics K.out Ubuntu 4 01-23-2011 09:51 AM
T410s Nvidia Switchable Optimus Graphics - a problem? fhsm Linux - Laptop and Netbook 4 12-12-2010 08:57 PM


All times are GMT -5. The time now is 06:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration