LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-11-2012, 05:57 AM   #31
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 53

Rep: Reputation: 17

Hi, I have an oldish AMD graphics card. Maybe my process to get that card to work might help or give some other ideas.


Quote:
bash-4.2# lspci -vv
------
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV620 [Mobility Radeon HD 3400 Series] (prog-if 00 [VGA controller])
------
Kernel driver in use: radeon
I had given up to use the proprietary flglx-driver as it kept giving me install-problems. At the moment I am using the open source driver from the kernel at its native resolution of 1280x800, and the ati-driver that comes with Slackware.

For this, I did the following:

1) installed a subset of xf86-video drivers:

Quote:
bash-4.2# ls /var/log/packages/xf86-video-*
/var/log/packages/xf86-video-ati-6.14.4-x86_64-1
/var/log/packages/xf86-video-dummy-0.3.5-x86_64-1
/var/log/packages/xf86-video-modesetting-0.4.0-x86_64-1
/var/log/packages/xf86-video-v4l-0.2.0-x86_64-5
/var/log/packages/xf86-video-vesa-2.3.1-x86_64-1
2) edited /etc/lilo.conf (after doing so make sure to rerun 'lilo' as root)
vga=773 and the rest, including all VESA framebuffer settings commented out
added the 'append=video=[native resolution]' to the linux-booting block

Quote:
image = /boot/vmlinuz
initrd = /boot/initrd.gz
root = /dev/sda6
label = Linux
read-only
append="video=1280x800"
3) included a video.xorg.conf file:

Quote:
bash-4.2# less /etc/X11/xorg.conf.d/video.xorg.conf

Section "Device"
Identifier "video_driver"
Driver "ati"
EndSection

(plus similar files for the touchpad (50-synaptics.conf) and keyboard-layout (90-keyboard-layout.conf) settings)

4) made sure that all ati-stuff installed by the fglrx package is removed (In my, possibly outdated experience: after uninstalling the package, ati/fglrx stuff keeps lying around in /etc as well as in other places like /usr/share and /usr/src.) Reinstalled Mesa as its glx-component could be overridden by the ati-driver.

5) I do not have an /etc/modprobe.d/blacklist.conf (see ReadMe in /etc/modprobe.d/) or one dedicated to radeon to get it blacklisted

NOTE in case the kernel-driver is not good enough: it used to be possible to create slackware packages from the AMD flgrx install package; please run the install-script with " --help" to see the appropriate options for this (something like " --with package=Slackware Linux" would be the setting for that).

Hope this could help you on your way (btw ati-cards never blew up my computer like nvidia's did).

PS. Your amd graphics card is not like the linux-unfriendly optimus cards from nvidia?? if so you might need another solution altogether.

Last edited by brobr; 09-11-2012 at 11:33 AM.
 
Old 09-30-2012, 12:26 PM   #32
seangregory
Member
 
Registered: Apr 2009
Posts: 30

Original Poster
Rep: Reputation: 0
Ok guys

Something different

I installed Slackware 14 32 bit. THe open source driver, xf86-video-ati is installed with libdrm and mesa. I passed nomodeset to lilo.

Booted in ran xorg setup ..... it detected the radeon card under device there is radeon.. started x .. worked like a charm

glxinfo - direct rendering yes.....

but when i reboot without passing nomodeset to lilo the same old story... screen goes blank after initial boot.

Any thoughts
 
Old 09-30-2012, 04:06 PM   #33
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 53

Rep: Reputation: 17
Could it be a backlight issue as discussed here?
https://wiki.archlinux.org/index.php/Backlight
http://slacklinux.darkbb.com/t5068-n...when-i-boot-up
http://ubuntuforums.org/archive/inde...t-1613132.html
One suggestion in this last thread is interesting, which you could try out directly, namely that the card might be at minimal brightness (black screen) when you start-up and if you change that in a reverse manner the screen comes up. Your graphics card is mentioned in some of these posts thus it seems to be related.

Google is your friend (but look beyond the ubuntu posts...)

good luck

PS. Why the change from 64bit, that i5 processor normally runs with "Genuine W****s 7 Home Pr*** 64-bit???
 
Old 10-04-2012, 01:49 PM   #34
seangregory
Member
 
Registered: Apr 2009
Posts: 30

Original Poster
Rep: Reputation: 0
Thanks a mill Brobr....

Yes the issue is with the back light.... how i identified it is that when after the initial boot process when the screen goes dark. i just closed the laptop screen and then when i bring it back up i am able to see whats on the screen.

http://slacklinux.darkbb.com/t5068-n...when-i-boot-up - i have tried this but no luck.... now i am having another issue i am not able to startx unless i go to nomodeset....

Any suggestions....
 
Old 10-04-2012, 02:21 PM   #35
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 53

Rep: Reputation: 17
Hi Sean,

Did you see this section of "CHANGES_AND_HINTS"?

Quote:
Now that KMS (Kernel Mode Setting) for graphics cards has (mostly) stabilized,
it is enabled by default for intel, ati, and nvidia graphics chipsets. It
is possible to disable it use "nomodeset" as a kernel append in lilo.conf,
but Xorg will not work at all on intel (and some ati) chips if you do that.

If you want to change the resolution of the KMS console, that can be done
with something like this as a kernel append in lilo.conf:
append="video=1024x768"

Speaking of lilo.conf and KMS, make sure you use either vga=normal or
vga=extended -- some of the framebuffers don't like KMS very much...
It is part of a whole blurb on X11 that also mentions

Quote:
Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection
Hopefully this (file) gives you some more pointers to look into.

Also, did you try to build another kernel for which the configs are in /extra? The 3.4/5/6 versions seem to deal better with the new intel chips and/or graphics issues

Last edited by brobr; 10-04-2012 at 05:59 PM.
 
Old 10-05-2012, 06:22 AM   #36
seangregory
Member
 
Registered: Apr 2009
Posts: 30

Original Poster
Rep: Reputation: 0
Dear Brobr

Finally the backlight issue is fixed .

i've added append="acpi_osci=Linux acpi_backlight=vendor" in lilo and ran /sbin/lilo . the issue is fixed. Thank you a million. Also thanks a million to all in LQ.org who spend their valuable time for me suggesting solutions .. but still i am having trouble with KDE start.. i have tried what u have mentioned/ Mr. Brobr

Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection

Still the same issue. i am starting x as a normal user and not root. the KDE welcome screen all comes up but at the desktop only the widget saying desktop comes up and nothing else right clicking gives some options as leave, add widget, run command etc.. thats all
 
Old 10-12-2012, 03:16 AM   #37
seangregory
Member
 
Registered: Apr 2009
Posts: 30

Original Poster
Rep: Reputation: 0
Guys pls help

The back light issue is fixed. open source ati driver is also configured fine why because while booting it detects my graphics card and its memory as 512 mb and says radeon initialized... but i am not able to start x kde. i tried as a normal user. the desktop comes up but nothing is on the screen other than the widget on the top right hand corner that says leave , add panel etc comes up... nothing else..

By the way i tried ubuntu 12.04 with the open source driver for ati everything works fine...

I really love to use slackware... please help...

Sean
 
Old 10-12-2012, 03:33 AM   #38
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 53

Rep: Reputation: 17
Hi Sean, I do not use KDE as my desktop. Maybe old configuration files could be blocking the start up (as I experienced with XFCE a while ago after upgrading to current). If you start with a gui-login (runlevel 4 in /etc/inittab) you could chose another desktop (like XFCE), just for the time, to check whether the problem is kde specific. Or from runlevel 3, begin with xwmconfig (instead of startx) and pick your choice.

Another way to test this is to create another user with a fresh home folder (as root, "adduser") and startx like that user. That would then create a default kde-environment from scratch and will show you whether config-files in your own home-folder interfere with something.

Also check KDE-specific fora for a solution for this.

Good luck,

rob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not booting through nfsroot but booting properly through Flash saumitralele Linux - Newbie 4 01-11-2011 10:06 PM
OpenSUSE not booting properly Mairiiv Linux - Server 3 04-16-2010 03:12 AM
my system is not booting properly ram_rajavarapu Linux - Hardware 1 10-27-2008 12:31 PM
My system is not booting properly ram_rajavarapu Linux - Hardware 1 10-11-2008 07:32 PM
Dual Booting 9.2 64bit and Win Xp jaz9090 Suse/Novell 1 02-14-2005 06:14 PM


All times are GMT -5. The time now is 06:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration