LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-26-2009, 10:07 AM   #1
elija
Member
 
Registered: Jul 2008
Location: The garden of England. Technically, the compost heap.
Distribution: Fedora these days or Linux Lite
Posts: 31

Rep: Reputation: 16
Slackware 13 (32 bit) and Wacom Bamboo


I have downloaded and installed this slackbuild linuxwacom (0.8.3_6) (http://slackbuilds.org/repository/13...ty/linuxwacom/)

I have modified /etc/rc.d/rc.modules to enable the wacom driver
I have modified xorg.conf as suggested on the slackbuild - or rather the wacom project page)

When I less /proc/bus/usb/devices as root I see

Code:
T:  Bus=07 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc= 14/900 us ( 2%), #Int=  1, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0001 Rev= 2.06
S:  Manufacturer=Linux 2.6.29.6-smp uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:1d.1
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=07 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=056a ProdID=0069 Rev= 2.00
S:  Manufacturer=WACOM
S:  Product=CTF-430 V2.0-0
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr= 40mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=wacom
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
By going in to /dev/input and listing the contents I can see the device appear as mouse2 when I plug it in.

modprobe -l | grep wacom produces
Code:
kernel/drivers/input/touchscreen/wacom_w8001.ko
kernel/drivers/usb/input/wacom.ko
lsusb | grep -i wacom produces
Code:
Bus 007 Device 002: ID 056a:0069 Wacom Co., Ltd
Because of the mouse2 thing in /dev/input I changed the xorg.conf so that /dev/input/wacom became /dev/input/mouse2

The appropriate piece of my xorg.conf
Code:
Section "InputDevice"
	Driver        "wacom"
	Identifier    "stylus"
	Option        "Device"        "/dev/input/mouse2"    # USB ONLY
	Option        "Type"          "stylus"
	Option        "USB"           "on"                  # USB ONLY
EndSection

Section "InputDevice"
	Driver        "wacom"
	Identifier    "eraser"
	Option        "Device"        "/dev/input/mouse2"    # USB ONLY
	Option        "Type"          "eraser"
	Option        "USB"           "on"                  # USB ONLY
EndSection

Section "InputDevice"
	Driver        "wacom"
	Identifier    "cursor"
	Option        "Device"        "/dev/input/mouse2"    # USB ONLY
	Option        "Type"          "cursor"
	Option        "USB"           "on"                  # USB ONLY
EndSection

# This section is for Intuos3, CintiqV5, Graphire4, or Bamboo
Section "InputDevice"
	Driver        "wacom"
	Identifier    "pad"
	Option        "Device"        "/dev/input/mouse2"    # USB ONLY
	Option        "Type"          "pad"
	Option        "USB"           "on"                  # USB ONLY
EndSection

The tablet stubbornly refuses to do anything. Where can I go from here?
 
Old 09-27-2009, 08:04 AM   #2
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
wacom is supported by hal. search wacom on this forum and you will find several posts regarding setup.
 
Old 09-27-2009, 08:40 AM   #3
elija
Member
 
Registered: Jul 2008
Location: The garden of England. Technically, the compost heap.
Distribution: Fedora these days or Linux Lite
Posts: 31

Original Poster
Rep: Reputation: 16
I followed this except I used and installed the slackbuild.

When I plug in my tablet, I see it appear as wacom under /dev/input and I can see it appear in the "Configure Extended Input devices" in GIMP.

Everything seems to be in Screen mode but still the tablet is dead as a dodo. Is it because I used the slackbuild?

Last edited by elija; 09-27-2009 at 08:45 AM.
 
Old 09-27-2009, 08:54 AM   #4
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 443

Rep: Reputation: 56
I doubt the problem is the slackbuild. It worked fine here. If you cat every event file in /dev/input/ and use the pen a little. Do you get any response from one of the devices?

Edit:
And does this correspond with the device in xorg.conf?

Last edited by Dinithion; 09-27-2009 at 08:57 AM.
 
Old 09-27-2009, 08:58 AM   #5
elija
Member
 
Registered: Jul 2008
Location: The garden of England. Technically, the compost heap.
Distribution: Fedora these days or Linux Lite
Posts: 31

Original Poster
Rep: Reputation: 16
None. The tablet should work on the desktop right?

Had the bright idea of checking the Xorg log. These lines seem to relate to the wacom. Do they look right?

Code:
(**) Option "SendCoreEvents"
(**) cursor: always reports core events
(**) cursor device is /dev/input/wacom
(**) cursor is in relative mode
(**) WACOM: suppress value is 2
(**) Option "USB" "on"
(**) cursor: reading USB link
(**) Option "BaudRate" "9600"
(II) XINPUT: Adding extended input device "cursor" (type: Wacom Cursor)
(**) Option "Device" "/dev/input/wacom"
cursor Wacom X driver grabbed event device
(==) Wacom using pressure threshold of 30 for button 1
(==) Wacom USB Bamboo1 tablet speed=9600 (38400) maxX=5104 maxY=3712 maxZ=511 resX=1012 resY=1012  tilt=disabled
(==) Wacom device "cursor" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012
(**) Option "SendCoreEvents"
(**) stylus: always reports core events
(**) stylus device is /dev/input/wacom
(**) stylus is in absolute mode
(**) WACOM: suppress value is 2
(**) Option "USB" "on"
(**) stylus: reading USB link
(**) stylus: threshold = 30
(**) stylus: max x set to 5104 by xorg.conf
(**) stylus: max y set to 3712 by xorg.conf
(**) stylus: max z = 511
(**) Option "BaudRate" "9600"
(II) XINPUT: Adding extended input device "stylus" (type: Wacom Stylus)
(==) Wacom device "stylus" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012
(**) Option "SendCoreEvents"
(**) eraser: always reports core events
(**) eraser device is /dev/input/wacom
(**) eraser is in absolute mode
(**) WACOM: suppress value is 2
(**) Option "USB" "on"
(**) eraser: reading USB link
(**) eraser: threshold = 30
(**) eraser: max x set to 5104 by xorg.conf
(**) eraser: max y set to 3712 by xorg.conf
(**) eraser: max z = 511
(**) Option "BaudRate" "9600"
(II) XINPUT: Adding extended input device "eraser" (type: Wacom Eraser)
(==) Wacom device "eraser" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012
(II) config/hal: Adding input device Wacom Bamboo1
(**) Wacom Bamboo1: always reports core events
(**) Wacom Bamboo1 device is /dev/input/event6
(**) Wacom Bamboo1 is in absolute mode
(**) WACOM: suppress value is 2
(**) Option "BaudRate" "9600"
(**) Wacom Bamboo1: serial speed 9600
(II) XINPUT: Adding extended input device "Wacom Bamboo1" (type: Wacom Stylus)
(**) Option "Device" "/dev/input/event6"
Wacom Bamboo1 Wacom X driver can't grab event device, errno=16
(==) Wacom using pressure threshold of 30 for button 1
(==) Wacom USB Bamboo1 tablet speed=9600 (38400) maxX=5104 maxY=3712 maxZ=511 resX=1012 resY=1012  tilt=disabled
(==) Wacom device "Wacom Bamboo1" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012
(II) config/hal: Adding input device Wacom Bamboo1 pad
(**) Wacom Bamboo1 pad: always reports core events
(**) Wacom Bamboo1 pad device is /dev/input/event6
(**) Wacom Bamboo1 pad is in relative mode
(**) WACOM: suppress value is 2
(**) Wacom Bamboo1 pad: reading USB link
(**) Wacom Bamboo1 pad: threshold = 30
(**) Wacom Bamboo1 pad: max x set to 5104 by xorg.conf
(**) Wacom Bamboo1 pad: max y set to 3712 by xorg.conf
(**) Wacom Bamboo1 pad: max z = 511
(**) Option "BaudRate" "9600"
(**) Wacom Bamboo1 pad: serial speed 9600
(II) XINPUT: Adding extended input device "Wacom Bamboo1 pad" (type: Wacom Pad)
(==) Wacom device "Wacom Bamboo1 pad" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012
(II) config/hal: Adding input device Wacom Bamboo1 cursor
(**) Wacom Bamboo1 cursor: always reports core events
(**) Wacom Bamboo1 cursor device is /dev/input/event6
(**) Wacom Bamboo1 cursor is in relative mode
(**) WACOM: suppress value is 2
(**) Wacom Bamboo1 cursor: reading USB link
(**) Wacom Bamboo1 cursor: threshold = 30
(**) Wacom Bamboo1 cursor: max x set to 5104 by xorg.conf
(**) Wacom Bamboo1 cursor: max y set to 3712 by xorg.conf
(**) Wacom Bamboo1 cursor: max z = 511
(**) Option "BaudRate" "9600"
(**) Wacom Bamboo1 cursor: serial speed 9600
(II) XINPUT: Adding extended input device "Wacom Bamboo1 cursor" (type: Wacom Cursor)
(==) Wacom device "Wacom Bamboo1 cursor" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012
(II) config/hal: Adding input device Wacom Bamboo1 eraser
(**) Wacom Bamboo1 eraser: always reports core events
(**) Wacom Bamboo1 eraser device is /dev/input/event6
(**) Wacom Bamboo1 eraser is in absolute mode
(**) WACOM: suppress value is 2
(**) Wacom Bamboo1 eraser: reading USB link
(**) Wacom Bamboo1 eraser: threshold = 30
(**) Wacom Bamboo1 eraser: max x set to 5104 by xorg.conf
(**) Wacom Bamboo1 eraser: max y set to 3712 by xorg.conf
(**) Wacom Bamboo1 eraser: max z = 511
(**) Option "BaudRate" "9600"
(**) Wacom Bamboo1 eraser: serial speed 9600
(II) XINPUT: Adding extended input device "Wacom Bamboo1 eraser" (type: Wacom Eraser)
(==) Wacom device "Wacom Bamboo1 eraser" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012

Last edited by elija; 09-27-2009 at 09:02 AM.
 
Old 09-27-2009, 09:16 AM   #6
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 443

Rep: Reputation: 56
If you don't get any text on the screen by doing cat /dev/input/eventX, where X is from 0 to i dunno, 7 or 9(?) and in particular /dev/input/wacom since that's the device xorg.conf reads from, something is wrong.

I'm not sure, but perhaps you've got to recompile the kernel to include wacom, if you haven't done so already.
Does "lsmod | grep wacom" show anything?
 
Old 09-27-2009, 09:40 AM   #7
elija
Member
 
Registered: Jul 2008
Location: The garden of England. Technically, the compost heap.
Distribution: Fedora these days or Linux Lite
Posts: 31

Original Poster
Rep: Reputation: 16
It does

Code:
wacom                  20004  0
Recompile the kernel - that sounds scary!
 
Old 09-27-2009, 09:48 AM   #8
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 443

Rep: Reputation: 56
if:
zcat /proc/config.gz | grep -i wacom

shows either
CONFIG_TABLET_USB_WACOM=m
or
CONFIG_TABLET_USB_WACOM=y

You won't need to recompile. However, if you got the module, I can't think of any thing that might be wrong. Not at the moment anyway.
 
Old 09-27-2009, 10:10 AM   #9
elija
Member
 
Registered: Jul 2008
Location: The garden of England. Technically, the compost heap.
Distribution: Fedora these days or Linux Lite
Posts: 31

Original Poster
Rep: Reputation: 16
That shows

Code:
CONFIG_TOUCHSCREEN_WACOM_W8001=m
 
Old 09-27-2009, 10:27 AM   #10
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 443

Rep: Reputation: 56
Ok, then you don't have the wacom module. I'm not 100% sure, but I think you need this module in order to compile the wacom package properly. If that is the case, you need to recompile the kernel. There are tons of howtos on the Internet. You want to compile the wacom tablet support as a module, and then rebuild the linuxwacom package with the SBO, and reinstall it.
 
Old 09-27-2009, 11:19 AM   #11
elija
Member
 
Registered: Jul 2008
Location: The garden of England. Technically, the compost heap.
Distribution: Fedora these days or Linux Lite
Posts: 31

Original Poster
Rep: Reputation: 16
Just to get a graphics tablet working!

Sigh... I'm off to do some reading
 
Old 09-27-2009, 12:19 PM   #12
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 443

Rep: Reputation: 56
You won't need to do much. Basically you need to make menuconfig or make xconfig, choose that one particular module, exit and make the module. you don't have to think of very much else since you want it as a module. If you had choose it to be included, instead of module, you would have to change the kernel in /boot, perhaps update lilo and then reboot. But modules can be compiled and loaded right afterwards without having to reboot.

I think it's a shame that this module isn't included by default. I will make a request in another thread.
 
Old 09-27-2009, 04:22 PM   #13
elija
Member
 
Registered: Jul 2008
Location: The garden of England. Technically, the compost heap.
Distribution: Fedora these days or Linux Lite
Posts: 31

Original Poster
Rep: Reputation: 16
It does seem like an odd one to leave out. I should imagine it's fairly commonly wanted.

I tried both make menuconfig and make xconfig. In each case I got an error about "No rule to make target".

Is this compiling the kernel? I don't even know what to Google to find out how to do what I need to do.

It's almost enough to drive me back to Ubuntu, begging Mark Shuttleworth's forgiveness for my desertion. Almost. In all other respects, I really like Slackware so far and even this will no longer be a problem when I understand what I'm doing

Last edited by elija; 09-27-2009 at 04:23 PM.
 
Old 09-28-2009, 03:49 PM   #14
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 443

Rep: Reputation: 56
Ok, I will probably be somewhat flamed for this. It doesn't need to be so difficult, but this method got some weaknesses. One thing is that it shouldn't be done as root, because its insecure. And some will argue that this should be done outside /usr/src. Anyway, this is the easy way: ($ represents commands to be executed)

$ cd /usr/src/linux
$ make menuconfig
Goto: Device drivers -> Input device support -> Tablets
Goto: "Wacom Intuos/Graphire tablet support (USB)" and press m. (For module).
exit and save changes

Now, we have selected the extra module that's needed. Now we have to compile it. This will probably take a while. Anyway:

$ make modules
$ make modules_install

Now, remove the old linuxwacom package, rebuild it from source and SBo, and reinstall. Hopefully it will work
(Btw, since we tell you to do this the "sloppy" way, as root, remember to be careful)
 
Old 09-28-2009, 03:55 PM   #15
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,398

Rep: Reputation: Disabled
I'd have done that as root, in /usr/src , as well ;-)

http://alien.slackbook.org/dokuwiki/...kernelbuilding

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wacom tablet on Slackware 12.1 sleekslack Slackware 18 10-21-2009 05:22 PM
Tablet Wacom Bamboo series iswc_technical Linux - Hardware 3 04-07-2009 08:47 AM
Getting my Wacom Bamboo to work on my Acer Aspire One running Linpus Linux Lite rignahkohe Linux - Newbie 3 01-23-2009 07:31 AM
Wacom Graphire has bizarre behavior in Inkscape (Hardy Heron 64-bit) DeekBeek Ubuntu 0 12-26-2008 01:16 PM
wacom tablet and slackware 10 arubin Slackware 0 07-01-2004 06:23 PM


All times are GMT -5. The time now is 10:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration