LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware 13.1 on projector (http://www.linuxquestions.org/questions/slackware-14/slackware-13-1-on-projector-842101/)

Asido 11-03-2010 07:30 AM

slackware 13.1 on projector
 
I was trying to plug projector on my laptop with slackware 13.1 installed. The problem is that the projector stops showing whenever I start X. I can see everything starting from LILO loader, but whenever I type "startx" - bam, no signal or just a black screen on the wall. I try to switch to console mode with ctrl+alt+f1 - the view appears, switching back to X with ctrl+alt+f7 - view disappears.
I am using awesome WM. I tried XFCE, but the result was the same. I also tried to change resolution to
Code:

xrandr --output default --mode 1024x768 / 800x600
, but again, no difference. My laptop is ASUS F3Jc. Fn keys doesn't help as well.

bogzab 11-03-2010 07:58 AM

I use a projector with my Slackware 13.1 laptop running both KDE4 and XFCE. The key for me is the NVIDIA proprietary driver which will detect displays and allow you to configure them separately, so the internal lcd can be disabled and the external projector enabled, vice-versa or both can be configured to work in "TwinView". No doubt an expert in xorg configuration could do this without the nvidia driver, but if you have nvidia graphics that would be one way to fix your problem.

zoran119 11-03-2010 08:05 AM

have a look at your devices with

Code:

xrandr -q
and then try something like

Code:

xrandr --output vga1 --mode 1280x1024

Asido 11-03-2010 08:10 AM

Quote:

Originally Posted by zoran119 (Post 4147909)
have a look at your devices with
Code:

xrandr -q

This is the output:
Code:

Screen 0: minimum 320 x 240, current 1280 x 800, maximum 1280 x 800
default connected 1280x800+0+0 0mm x 0mm
  1280x800      50.0*
  1024x768      51.0 
  800x600        52.0 
  640x512        53.0 
  640x480        54.0    55.0 
  512x384        56.0 
  400x300        57.0 
  320x240        58.0

And as I told in my first post, I have tried to change to different resolutions (1024x768 and 800x600) which just didn't make any difference.

And yes, I have NVidia. Could you explain in more details how to do that switching?

bogzab 11-03-2010 08:57 AM

To do the switching usng the nvidia proprietary driver, you have to get the driver to install from the nvidia website (google linux driver nvidia). Once you have run the installation script you should see an nvidia driver icon / menu entry in kde / xfce or whatever you are using to start applications. That then gives you a fairly easy to use GUI interface to the driver including the various displays that it detects.

zoran119 11-03-2010 09:08 AM

if you want to use the proprietary nvidia driver, i'd suggest installing it from sbo. then you should be able to run nvidia-settings to configure your screens.

Asido 11-03-2010 10:12 AM

I don't have any icons on my window manager, but nvidia-settings command worked. I'll try to do something tomorrow and will let you know.

bogzab 11-04-2010 04:24 AM

@Zoran119 - you are right of course - the SBo route is much better than just downloading from nvidia and running their install. I think in fact last time I installed, I did it that way too. Looks like OP has the driver anyway, so should be able to switch displays once driver gui is displayed.

onebuck 11-04-2010 06:45 AM

Hi,

Look at 'Multiple monitors/Dual screen_Nvidia ' on the Arch_Xorg_wiki. You should be able to setup the dual-head within '/etc/X11/xorg.conf' from this example.
:hattip:

Asido 11-05-2010 09:57 AM

Well, the problem was that after I plug the projector cable, in nvidia-settings by default that display is disabled. I need to enable it and select as clone of the existing screen every time. So that kinda solved the problem.


All times are GMT -5. The time now is 10:46 PM.