LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-02-2010, 09:43 PM   #1
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Rep: Reputation: 18
Slackware 13.1 on a netbook (asus eee 1005ha)


So far... so good
I love my netbook and the eye candy of kde... something else.

everything works out of the box... no need to configure anything... desktop effects are cool bl abl abla

BUT

an important fn key combo stopped working.
i can't disable the touch-pad to type and this is freaking me out. I've passed the last 3 days trying to get this working but no luck so far.

Alien bob eee-acpi packages are not doing the magic..
Archlinux eee-acpi seem to be complete...but they do not work..
I've followed woush howto and no luck either...


this netbook has a button top left corner that is supposed to kill the touchpad too... (not working)

I'm having a feeling that i'm not doing this correctly... so i came to you for help.

please advice
 
Old 06-03-2010, 02:31 AM   #2
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 930

Rep: Reputation: 96
I have the same netbook and yes, it doesn't work (used to work fine with kernel 2.6.29 of Slackware 13.0). Upgrading to 2.6.34 didn't solve the problem either. Obviously something is broken in the (experimental) eeepc driver.
 
Old 06-03-2010, 08:29 AM   #3
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Original Poster
Rep: Reputation: 18
ok good
then i'm not going crazy.

belive me... this stupid thing has me sleepless.
 
Old 06-10-2010, 08:23 AM   #4
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Original Poster
Rep: Reputation: 18
I got a bigger hard drive for my netbook so i took the time to install arch linux on it as i was told their support for this laptop was way too good.

same issues after following their wikipage about this netbook. Fn+F3 doesn't work; neither the disable touchpad button on top left corner...

I wonder if the source code found on asus webpage does have the trick for this...
 
Old 06-10-2010, 08:58 AM   #5
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
I had a similar problem with Slackware 13.0 on my AAO-D250-1417 netbook where the touchpad didn't respond to tap/click and a few of the function key combos didn't work.

http://www.linuxquestions.org/questi...1417-a-774261/

The touchpad was fixed with a HAL policy change and the function keys were fixed with xbindkeys. These were temporary solutions because after I upgraded to current, now 13.1, everything worked without needing either fix.
 
Old 06-12-2010, 06:45 PM   #6
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Original Poster
Rep: Reputation: 18
well
vertical scrolling works fine out of the box; but in windows (yes i refer to it) 2 finger tap emulates middle click and 3 finger tap emulates right click... I'm trying (actually failed miserably) to enable that feature as it won't wear down the tochpad buttons.

This is what works out of the box:

close lit suspend to ram or disk... not sure what it does but i have to wake the system up and type in my password

Fn+f1 <-------- sleep/suspend to ram (don't know exactly what it does... but it does it)
Fn+F5 <-------- decrease screen brightness works
Fn+F6 <-------- increase screen brightness works
Fn+F7 <-------- disable screen works


I've been unable to activate Fn+F3 (disable touchpad) or get a response from the silver button on top left corner for this purpose. I'm reading how to setup xbindkeys but nevertheless i can't get the imput for the Fn key..

anyhow, i've enabled the toggle touchpad as follows

using the win key (picked as Meta by kde) and F3 i call the following script
Code:
#!/bin/bash
# disable/enable touchpad
# get current state
SYNSTATE=$(synclient -l | grep TouchpadOff | awk '{ print $3 }')

# change state
if [ $SYNSTATE = 0 ]; then
    synclient touchpadoff=1
elif [ $SYNSTATE = 1 ]; then
    synclient touchpadoff=0
fi
exit 0
I don't know why acpi events/actions combo is not doing the magic for me... and i've spent some time reading about it as i know it is merely a scripting issue

I'm thinking into trying the customized xandros distro that asus has for download on this machine and check what/how they do it...
I'll be in touch if I find the time to do so

Last edited by kernel-P4N1C; 06-12-2010 at 06:49 PM.
 
Old 06-12-2010, 07:20 PM   #7
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
Quote:
Originally Posted by kernel-P4N1C View Post
I'm reading how to setup xbindkeys but nevertheless i can't get the imput for the Fn key..
I left some notes in my rc.keys file that might provide some help:

Code:
#!/bin/sh
#
# /etc/rc.d/rc.keys
#
# use "showkey -s" in console to get scan codes
# use "showkey -k" in console to get key code
# use "getkeycodes" in console for entire key map
# use "xmodmap -pke" in X11 console for all mapped keys
# use "xev" in X11 console for X Window key codes

setkeycodes e020 113 # Mute/Unmute
setkeycodes e02e 114 # Decrease volume
setkeycodes e030 115 # Increase volume
YMMV!
 
Old 06-13-2010, 12:06 AM   #8
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Original Poster
Rep: Reputation: 18
is this setup for the 1005ha?
 
Old 06-13-2010, 09:05 AM   #9
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
Quote:
Originally Posted by kernel-P4N1C View Post
is this setup for the 1005ha?
No those are for the D250. I found the codes in the rc.keys file using the commands listed in the comment lines.
 
Old 06-13-2010, 11:27 AM   #10
trumpet_tom
Member
 
Registered: Dec 2004
Distribution: Slackware64-current
Posts: 95

Rep: Reputation: 19
I'm also using Slackware 13.1 on the 1005ha. I used acpi_listen which returns 00000037 for both the touchpad toggle buttons. I was using Alien Bob's eeepc-acpi-scripts package so presumably could just add a few lines to the /etc/apci/actions/hotkey.sh file and use the lines mentioned by kernel-P4N1C above in a separate file. I gave this a try and it didn't do anything..in /var/log/messages I get things like this:
Code:
Jun 13 14:03:48 darkstar logger: ACPI group hotkey / action ATKD is not defined
so I've clearly done something wrong. Any ideas on how to modify the existing scripts or how to make my own to get this feature working?
 
Old 06-14-2010, 09:23 AM   #11
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Original Poster
Rep: Reputation: 18
@trumpet_tom
so far I haven't found a way to have these things running using acpi. I disable the touchpad by running the script (see previous post) and Meta+F3 on kde.

anyways, the beauty of slackware is precisely having to find your way to solve this kind of stupid issues.
 
Old 06-14-2010, 11:07 AM   #12
trumpet_tom
Member
 
Registered: Dec 2004
Distribution: Slackware64-current
Posts: 95

Rep: Reputation: 19
Done it!

Make a file called /etc/acpi/events/touchpad-toggle (or call it whatever you want):
Code:
event=hotkey ATKD 00000037
action=/etc/acpi/actions/touchpad-toggle.sh
Make a second file called /etc/acpi/actions/touchpad-toggle.sh:
Code:
#!/bin/bash
#Toggle touchpad

SYNSTATE=$(su tom -c "synclient -l" | grep TouchpadOff | awk '{ print $3}')
# change state
if [ $SYNSTATE = 0 ]; then
            su tom -c "synclient touchpadoff=1"
elif [ $SYNSTATE = 1 ]; then
            su tom -c "synclient touchpadoff=0"
fi
All credit to kernel-P4N1C for that. Make sure to make this script executable (as root):
Code:
chmod +x /etc/acpi/actions/touchpad-toggle.sh
The key is to make sure the script is being run as the current user otherwise synclient doesn't work. So change all instances of "tom" to whatever your user name is, or better still make a flexible script that works it out for you. I am the only user on my netbook so I can't be bothered!
 
Old 06-15-2010, 10:39 AM   #13
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Original Poster
Rep: Reputation: 18
well
i did what you suggested and it didn't worked

acpi_listen show nothing when i do Fn+F3
i only have response for F6, F5 and F1 (fn+f7 turn off the screen but has no output on console) these are the one that works.

my console output
Fn+F1
Code:
weput@weput-netbook:~$ acpi_listen 
button/sleep SLPB 00000080 00000002
Fn+F5
Code:
video LCDD 00000087 00000000
Fn+F6
Code:
video LCDD 00000086 00000000
i get the following when coming from hibernate
Code:
battery BAT0 00000081 00000001
ac_adapter AC0 00000081 00000000
processor CPU0 00000081 00000000
processor CPU1 00000081 00000000
2. I do not understand why you add the "su tom" on the script... either way it didn't worked.

Last edited by kernel-P4N1C; 06-15-2010 at 10:41 AM.
 
Old 06-15-2010, 03:02 PM   #14
trumpet_tom
Member
 
Registered: Dec 2004
Distribution: Slackware64-current
Posts: 95

Rep: Reputation: 19
I use "su tom" because if you try running xrandr as root it doesn't work. So you have to run xrandr as the currently logged in user, in my case "tom".

I'm finding that my script doesn't work until I restart acpid (/etc/rc.d/rc.acpid restart), dunno what that's about. Either way if acpi_listen isn't registering the key presses, that's a separate issue. Are you sure the eeepc_laptop module is loaded? I had to put a line in /etc/lilo.conf to make it work.
Code:
append = "acpi_osi=Linux"
otherwise have you tried running acpi_listen as root? maybe you're not a member of the right group.
 
Old 06-16-2010, 02:17 AM   #15
keeperofdakeys
LQ Newbie
 
Registered: Dec 2009
Location: Adelaide, Australia
Distribution: Slackware
Posts: 8

Rep: Reputation: 0
I have the same laptop, had the same issue, and made the same solution (although I still use 13.0).

My theory about why synclient won't load is that the driver is started with X, and when acpid initially runs it is 'not aware' of X. I used to do the same as you (restart acpi), but I found that I could unload the psmouse module (modprobe -r psmouse), which disabled the touchpad but allowed my usb mouse to continue functioning, then I reload when I want it back (modprobe psmouse).
Also something is wrong with my driver, so I have to use synclient guestmouseoff=0/1

Also the line you (and me) had to put into lilo is because of something in the kernel (although I don't need it for the generic .29 kernel that came with 13.0, only my compiled .32 version).

As an aside, I could give you some acpi scripts for volume, wireless and power management (auto cpu-scaling plus brightness, since I don't run a power manager).

Last edited by keeperofdakeys; 06-16-2010 at 02:20 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus eee 1005HA XP/Slackware dual boot install problems not_bob Slackware 6 05-08-2010 03:01 PM
how to enter into BIOS on a netbook ASUS EeePC 1005HA amimusa Linux - Hardware 2 03-13-2010 01:48 PM
Installing Slackware 13 on Asus Eee PC 1201n Netbook. I683. kaizoku roof Linux - Laptop and Netbook 2 02-22-2010 09:10 AM
Asus Eee PC 1005ha Ubuntu Netbook Remix 9.10 Wifi issue mawkernewek Linux - Laptop and Netbook 6 01-27-2010 07:33 PM
middle mouse clicks on ASUS Eee PC 1005HA DeuceNegative Linux - Hardware 4 08-01-2009 01:21 PM


All times are GMT -5. The time now is 02:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration